Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel]Formula rompicapo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel]Formula rompicapo

Postdi ramset64 » 11/02/10 22:43

Ciao,
torno a chiedere il vostro aiuto per una formula che proprio non riesco nemmeno ad immaginare :)
Nella colonna A ho delle date,
nella colonna B ho dei valori numerici
nella colonna C, vorrei sommare i valori della colonnaB quando le date della colonnaA sono uguali:

Es.
ColA ColB ColC
14-1-2010 4
14-1-2010 3
14-1-2010 1 8
18-1-2010 5
18-1-2010 2 7
20-1-2010 5 5
22-1-2010 1
22-1-2010 3
22-1-2010 4
22-1-2010 2 10

Spero di essere stato chiaro e sopratutto spero che qualcuno mi suggerisca la soluzione giusta senza l'ausilio di vba.
Nel caso l'esempio non sia chiaro, allego un piccolo esempio su file.
http://rapidshare.com/files/349331153/Cartel2.xls.html
Grazie
ramset64
Utente Senior
 
Post: 396
Iscritto il: 29/10/08 10:41
Località: Torino

Sponsor
 

Re: [excel]Formula rompicapo

Postdi Anthony47 » 11/02/10 23:05

In C1:
Codice: Seleziona tutto
=SE(A1<>A2;SOMMA.SE(A:A;A1;B:B);"")
Poi copi verso il basso.
Se invece le date non sono in ordine crescente la formula non funzionera', ma dovrai usare qualcosa come
Codice: Seleziona tutto
=SE(CONTA.SE($A$1:$A1;A1)=MAX(CONTA.SE($A$1:$A$1000;A1));SOMMA.SE($A$1:$A$1000;A1;$B$1:$B$1000);"")
Da confermare con Contr-Maiusc-Enter. Adegua quel $1:x$1000 se 1000 righe non sono sufficienti.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [excel]Formula rompicapo

Postdi ramset64 » 12/02/10 15:39

Anthony mille grazie, sei un grande! :)
ramset64
Utente Senior
 
Post: 396
Iscritto il: 29/10/08 10:41
Località: Torino

Re: [excel]Formula rompicapo

Postdi ricky53 » 14/02/10 01:26

Ciao,

oltre all'ottima soluzione di Anthony, mi permetto aggiungere un suggerimento:

Il caso da te esposto è un classico esempio risolvibile con i "SubTotali":

1. selezioni l'area dati (deve avere le intestazioni di colonna)
2. Barra dei menu
3. Dati
4. Sub Totali

personalizzi come ti occorre.

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: [excel]Formula rompicapo

Postdi ramset64 » 16/02/10 11:17

Ricky53 grazie per l'ulteriore suggerimento che verificherò senz'altro.
Ciao
ramset64
Utente Senior
 
Post: 396
Iscritto il: 29/10/08 10:41
Località: Torino


Torna a Applicazioni Office Windows


Topic correlati a "[excel]Formula rompicapo":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti

cron