Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

VBA e MATRICE.SOMMA.PRODOTTO

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

VBA e MATRICE.SOMMA.PRODOTTO

Postdi dipic » 11/02/10 13:37

Salve a tutti,
ho la seguente formula che funziona perfettamente:
=MATR.SOMMA.PRODOTTO(--(INDICE(AATPC;0;1)="CARPTES");--(INDICE(AATPC;0;3)=C7);INDICE(AATPC;0;4))
dove AATPC è il "nome" di un range.
Mi servirebbe poter tradurre la stessa in vba, ma comunque la giri mi da errore 13 "tipo non corrispondente"
Ecco le mie prove:

RESULT1= Evaluate("SUMPRODUCT(--(INDEX(AATPC,0,1)=""CARPTES"");--(INDEX(AATPC,0,3)=C7);INDEX(AATPC,0,4))")

RESULT2 = Application.WorksheetFunction.SumProduct((Application.WorksheetFunction.Index(Sheets(sSheet).Range("AATPC"), 0, 1) = "CARPTES"), (Application.WorksheetFunction.Index(Sheets(sSheet).Range("AATPC"), 0, 3) = C7), (Application.WorksheetFunction.Index(Sheets(sSheet).Range("AATPC"), 0, 4)))


Qualsiasi aiuto o suggerimento è ben accetto.
Grazie
Avatar utente
dipic
Utente Junior
 
Post: 95
Iscritto il: 13/09/08 14:57
Località: Cormòns (I)

Sponsor
 

Re: VBA e MATRICE.SOMMA.PRODOTTO

Postdi Anthony47 » 11/02/10 16:14

Questa, che e' "qualsi" come la tua:
Codice: Seleziona tutto
RESULT1 = Evaluate("SUMPRODUCT(--(INDEX(AATPC,0,1)=""CARPTES""),--(INDEX(AATPC,0,3)=C7),INDEX(AATPC,0,4))")


Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: VBA e MATRICE.SOMMA.PRODOTTO

Postdi dipic » 11/02/10 16:37

Grazie Anthony ... mi sono reso conto di aver messo la punteggiatura italiana (";" al posto di ",") ... :oops:
Un ultima cosa ... se volessi rendere il "nome" della matrice inputabile in una cella, come devo trasformare
--(INDEX(AATPC,0,3)=C7)
ho provato a sostituire con:
--(INDEX($A$1,0,3)=C7) dove $A$1=AATPC ... ma non funziona ...
Avatar utente
dipic
Utente Junior
 
Post: 95
Iscritto il: 13/09/08 14:57
Località: Cormòns (I)

Re: VBA e MATRICE.SOMMA.PRODOTTO

Postdi Anthony47 » 11/02/10 17:00

INDIRECT($A$1), ovviamente...

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "VBA e MATRICE.SOMMA.PRODOTTO":


Chi c’è in linea

Visitano il forum: alfrimpa, patel e 17 ospiti