Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Formula per ricerca tra due fogli

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Formula per ricerca tra due fogli

Postdi libraio » 04/02/10 16:46

Ciao a tutti.
Su due fogli ho due elenchi distinti che hanno in comune il codice articolo (numerico) in colonna A.
Avrei necessità di estrarre nella prima colonna libera del Foglio 2 il dato della colonna "n" dal Foglio 1 nella riga di corrispondenza dei codici della colonna A.
Cerco di spiegarmi meglio (se riesco...) con un esempio:
>> se A2 del Foglio 2 è anche in A:A del Foglio 1, in K2 del foglio 2 viene importato il dato dalla cella "n" (selezione apreta secondo le diverse esigenze) del Figlio 1 la cui cella A"n" è uguale a A2 del foglio 2.
Grazie per la collaborazione
libraio
libraio
Utente Senior
 
Post: 211
Iscritto il: 04/01/10 20:31

Sponsor
 

Re: Formula per ricerca tra due fogli

Postdi Anthony47 » 04/02/10 17:18

In K2:
Codice: Seleziona tutto
=Cerca.Vert(A2;Foglio1!$A$1:$Z$100;N,0)

Adatta l' area di foglio1 e la colonna da cercare alle tue esigenze.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula per ricerca tra due fogli

Postdi libraio » 04/02/10 17:38

Grazie Anthony,
la tua soluzione è (ovviamente) quella che cercavo! 8)
C'è tuttavia modo di evitare che nelle celle senza corrispondenza appaia #N/D ?
libraio
libraio
Utente Senior
 
Post: 211
Iscritto il: 04/01/10 20:31

Re: Formula per ricerca tra due fogli

Postdi Anthony47 » 04/02/10 17:47

=SE(val.errore(LaFormula;"";LaFormula)

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula per ricerca tra due fogli

Postdi libraio » 04/02/10 20:06

Chiedo scusa per la mia "crassa" inettitudine! :oops:
Ho tentato di elaborare la formula secondo le indicazioni di anthony, con il seguente risultato:
=SE(val.errore(Cerca.Vert(A2;Foglio1!$A$1:$Z$100;8,0;"";Cerca.Vert(A2;Foglio1!$A$1:$Z$100;8,0))
e conseguente "errore"...
Dove sbaglio? :cry:
Grazie
libraio
libraio
Utente Senior
 
Post: 211
Iscritto il: 04/01/10 20:31

Re: Formula per ricerca tra due fogli

Postdi Anthony47 » 04/02/10 20:14

Codice: Seleziona tutto
=SE(VAL.ERRORE(CERCA.VERT(A2;Foglio1!$A$1:$Z$100;8;0));"";CERCA.VERT(A2;Foglio1!$A$1:$Z$100;8;0))
Le parentesi non si chiudevano correttamente, uso erroneo di "," (invece che ";") come separatore di campi.

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Formula per ricerca tra due fogli

Postdi libraio » 04/02/10 20:47

Provato, applicato, perfetto!!
Grazie Anthony
libraio
libraio
Utente Senior
 
Post: 211
Iscritto il: 04/01/10 20:31


Torna a Applicazioni Office Windows


Topic correlati a "Formula per ricerca tra due fogli":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti