Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel 2003

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel 2003

Postdi Statix » 27/01/10 14:36

Ciao a tutti,
chiedo un favore a chi excel 2003.
Mi servirebbe una macro,che mi fà una formattazione condizionale di un range.
faccio un esempio
Codice: Seleziona tutto
in A1 il valore da evidenziare in rosso nella colonna A5:A500,
io ho excel 2007 e lo fatta è funziona perfettamente,ma quando converto il file in excel 2003 e lo dò agli altri che hanno excel 2003 non mi funziona.
grazie
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Re: Excel 2003

Postdi Statix » 27/01/10 14:38

Questa una delle macro fatta con il registratore di Excel 2007
mi servirebbe in Excel 2003

Codice: Seleziona tutto
Range("AN6:AN905").Select
    Selection.FormatConditions.Add Type:=xlExpression, Formula1:= _
        "=CONTA.SE($AN$3;AN6:AN905)>0"
    Selection.FormatConditions(Selection.FormatConditions.Count).SetFirstPriority
    With Selection.FormatConditions(1).Interior
        .Pattern = xlPatternRectangularGradient
        .Gradient.RectangleLeft = 0.5
        .Gradient.RectangleRight = 0.5
        .Gradient.RectangleTop = 0.5
        .Gradient.RectangleBottom = 0.5
        .Gradient.ColorStops.Clear
    End With
    With Selection.FormatConditions(1).Interior.Gradient.ColorStops.Add(0)
        .ThemeColor = xlThemeColorDark1
        .TintAndShade = 0
    End With
    With Selection.FormatConditions(1).Interior.Gradient.ColorStops.Add(1)
        .Color = 255
        .TintAndShade = 0
    End With
    Selection.FormatConditions(1).StopIfTrue = False
     Range("A1").Select
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: Excel 2003

Postdi Anthony47 » 27/01/10 15:19

Questa fa una cosa simile, e colora la cella di rosso; ovviamente va adattata al tuo range e alle condizioni:
Codice: Seleziona tutto
    Range("H1:H13").Select
    Selection.FormatConditions.Delete
    Selection.FormatConditions.Add Type:=xlExpression, Formula1:= _
        "=CONTA.SE($A$1:$A$14;H1)>0"
    Selection.FormatConditions(1).Interior.ColorIndex = 3

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Excel 2003

Postdi Statix » 27/01/10 16:22

Ciao Anthony,
grazie .
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta


Torna a Applicazioni Office Windows


Topic correlati a "Excel 2003":


Chi c’è in linea

Visitano il forum: raimea e 8 ospiti