Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

***Excel sommare celle contenenti formule***

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

***Excel sommare celle contenenti formule***

Postdi ProbePotter » 23/12/09 12:01

Buongiorno ed Auguri di Buon Natale a tutti.
Avrei un' esigenza, dovendo sommare le celle da L8 a L38
contenenti la formula: =SE(C8=Impostazioni!C12;"1";"")
come risultato è 1, tale somma non avviene: risultato è zero.
Potreste aiutarmi. Grazie.
Avatar utente
ProbePotter
Utente Senior
 
Post: 159
Iscritto il: 20/09/06 18:37

Sponsor
 

Re: ***Excel sommare celle contenenti formule***

Postdi zorea » 23/12/09 12:16

Ciao,
credo sia sufficiente togliere le virgolette a 1 (all'interno della formula se), in quanto le virgolette implicano il formato testo.
=SE(C8=Impostazioni!C12;1;"")

Ciao,
zorea
zorea
Utente Junior
 
Post: 48
Iscritto il: 05/06/09 15:07

Re: ***Excel sommare celle contenenti formule***

Postdi ProbePotter » 23/12/09 12:57

Avevo provato anch' io a togliere le virgolette, senza funziona correttamente.
Però, seleziona la cella con il triangolino verde in alto (testo). E sinceramente
non mi va troppo a genio. Possibile non c' è un' alternativa?
Avatar utente
ProbePotter
Utente Senior
 
Post: 159
Iscritto il: 20/09/06 18:37

Re: ***Excel sommare celle contenenti formule***

Postdi ProbePotter » 23/12/09 13:56

Ci sto lavorando su e con la formula: =CONTA.SE(L8:L38;"1")
non c' è bisogno di togliere a tutte le righe le virgolette, perchè li
somma correttamente anche se testo. Ma ora il triangolino verde
mi appare sulla cella del totale: L39... eppure dev' esserci un metodo.
Avatar utente
ProbePotter
Utente Senior
 
Post: 159
Iscritto il: 20/09/06 18:37

Re: ***Excel sommare celle contenenti formule***

Postdi pietrol » 23/12/09 15:12

Ciao probepotter
non sono sicuro perchè io ho ancora la versione 2000 ma credo che la soluzione sia di formattare le celle come numero, attualmente dovrebbero essere formattate come testo per darti quel segnale.

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: ***Excel sommare celle contenenti formule***

Postdi ProbePotter » 23/12/09 17:33

Le celle da L8 a L38 sono tutte formattate come numero.
E con la formula:
=CONTA.SE(L8:L38;"1")
=CONTA.SE(L9:L38;"1")
ecc. in ciascuna di esse mi riporta il totale correttamente in L39,
es. 1, 1, 1 totale 3. Solo che in L39 mi appare il triangolino verde.
Eppure anch' essa è formattata numero senza decimali.
Vorrei la somma in L39 "clean", di triangolino.
Cosa ne pensate ?
Avatar utente
ProbePotter
Utente Senior
 
Post: 159
Iscritto il: 20/09/06 18:37

Re: ***Excel sommare celle contenenti formule***

Postdi pietrol » 23/12/09 23:50

Ciao probepotter
ti mando un link al sito microsoft, credo che sia pertinente

http://office.microsoft.com/it-it/excel ... 20triangle

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: ***Excel sommare celle contenenti formule***

Postdi ProbePotter » 24/12/09 07:20

Ci sono, la formula: =CONTA.SE(L8:L38;"1") in L39, lavora perfettamente
e senza triangoli verdi (testo). L' anomalia era dovuta alla cella limitrofa
M39, contenente un' altra somma simile. Risolto applicando la medesima
formula in M39: =CONTA.SE(M8:M38;"1"), per quanto riguarda questa serie.
Ora sono alla ricerca di una formula tipo questa:
=SE(C8=Impostazioni!C8;"07.42";"00.00")
Praticamente; se in C8 (Foglio1) è uguale a C8 Foglio "Impostazioni"
allora scrivi orario: 07.42, se diverso (Falso) 00.00. Avrei necessità di
due riferimenti così composti:
=SE(C8=Impostazioni!C8;"07.42";"00.00");SE(C8=Impostazioni!C16;"07.42";"00.00")
che controllino C8 e C16 di Impostazioni, per le stringhe:
"Lavoro" in C8 e "Recupero" in C16. Non trovo il bandolo della matassa...
Is all. Per ora vi ringrazio per la cooperazione ed Auguro Buon Natale a tutti di
pc-facile.
Avatar utente
ProbePotter
Utente Senior
 
Post: 159
Iscritto il: 20/09/06 18:37

Re: ***Excel sommare celle contenenti formule***

Postdi Anthony47 » 24/12/09 11:12

Per quanto riguarda la formula =SE(C8=Impostazioni!C8;"07.42";"00.00"), se per 07.42 e 00.00 intendi due valori orari, allora userai la formula
Codice: Seleziona tutto
=SE(C8=Impostazioni!C8;Orario(7;42;0);Orario(0;0;0))


Per la seconda domanda
Avrei necessità di due riferimenti così composti:
=SE(C8=Impostazioni!C8;"07.42";"00.00");SE(C8=Impostazioni!C16;"07.42";"00.00")
che controllino C8 e C16 di Impostazioni, per le stringhe:
"Lavoro" in C8 e "Recupero" in C16. Non trovo il bandolo della matassa...
non capisco la domanda, sia perche' non spieghi quale e' e sia perche' la formula di esempio, essendo scritta in una sintassi "innovativa", non aiuta a decodificarlo.

Se la prima risposta non ti aiuta anche nel secondo quesito allora posta ancora ma descrivendo il problema con "piu' dettagli"

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: ***Excel sommare celle contenenti formule***

Postdi ProbePotter » 24/12/09 11:28

Ciao Anthony47, hai ragione non è comprensibile. Cerco di spiegarmi meglio.
Se in C8 scrivo le stringhe "Lavoro" oppure "Recupero" confrontandole in Foglio
Impostazioni!C8 e Impostazioni!C16: vero -> 07.42 falso -> 00.00 che sono due
orari. Allora sto cercando una formula che renda ciò attivo. Direi che ne ho trovata
una che funziona ma rende la cella su cui lavora in testo (triangolo verde) e non mi
fa la somma nel totale. Si potrei usare il CONTA.SE o SOMMA.SE, ma non amo troppo
i tringoli verdi. Cmq la formula è questa e lavora anche se in testo:
=SE(C8=Impostazioni!C8;"07.42";SE(C8=Impostazioni!C16;"07.42";"00.00"))
perchè gli orari sono virgolettati. Rimuovendoli non va. Cosa ne pensi ?
Ciao e Auguri
Avatar utente
ProbePotter
Utente Senior
 
Post: 159
Iscritto il: 20/09/06 18:37

Re: ***Excel sommare celle contenenti formule***

Postdi Anthony47 » 24/12/09 11:45

=SE(C8=Impostazioni!C8;"07.42";SE(C8=Impostazioni!C16;"07.42";"00.00"))
Questa ha gia' una sintassi "convenzionale"...

Cosa ne pensi ?
Ne penso che devi usare Orario(7;42;0) invece che "07.42".

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: ***Excel sommare celle contenenti formule***

Postdi ProbePotter » 25/12/09 09:25

Innanzitutto Buon Natale a tutti del forum e pc-facile.
Ho modificato il Foglio "Impostazioni" in H8 nella Casella Nome: Ore,
poi nel Foglio "Gennaio", cella interessata H8, ho inserito la formula:
=SE(VAL.VUOTO(C8);;SE(O(C8="Lavoro";C8="Recupero");Ore;"00.00"))
Funziona correttamente, inoltre alla somma ore nella cella H39, pur
essendoci delle virgolette con la formula:
=SOMMA(H8:H38)
il totale ore appare corretto e soprattutto in tutte le celle sono mancanti
i triangoli verdi.
Tanti Auguri di Buone Feste a tutti ed un Grazie particolare ad Anthony47.
Avatar utente
ProbePotter
Utente Senior
 
Post: 159
Iscritto il: 20/09/06 18:37


Torna a Applicazioni Office Windows


Topic correlati a "***Excel sommare celle contenenti formule***":


Chi c’è in linea

Visitano il forum: Lucio Peruggini e 4 ospiti