Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

tabella programmata con excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

tabella programmata con excel

Postdi prinx » 02/12/09 10:55

Ciao a tutti ho un problema con una tabella di lavoro
nel senso che nella scheda di lavoro devo inserire
dei nominativi con la data di esecuzione lavoro
però i nominativi nelle varie schde si possono
ripetere però non devono essere ripetuti con la stessa data
è possibile far evidenziare il nominativo quando è uguale
anche la data?
vi spiego come è composta la scheda
le colonne A-B-C-D-E unite compongono lo spazio per il cognome e nome
la colonna F è la data
l'ultima colonna della scheda è R
le righe totali della scheda sono 47
le righe del nominativo e la data vanno dalla 19 alla 31
pertanto se il contenuto è uguale nel campo A-B-C-D-E (cognome e nome) e F (data) mi si deve evidenziare
in un altro forum ho incontrato Archi persona bravissima che mi ha dato delle dritte ma purtroppo non complete.
qualcuno di voi può aiutarmi? ringrazio anticipatamente.
prinx
Utente Junior
 
Post: 19
Iscritto il: 02/12/09 10:43

Sponsor
 

Re: tabella programmata con excel

Postdi Flash30005 » 02/12/09 16:40

Mi sembra di capiure che vuoi controllare le righe da 19 a 31 se hanno nome e data uguali,
in questo caso, prova questa macro
Codice: Seleziona tutto
Sub EvidenziaSe()
RigaIni = 19
RigaFine = 31
For RR = RigaIni To RigaFine - 1
    For RF = RR + 1 To RigaFine
        Stringa1 = Range("A" & RR).Value & Range("F" & RR).Value
        Stringa2 = Range("A" & RF).Value & Range("F" & RF).Value
        If Stringa1 = Stringa2 Then
            Range("A" & RR & ":F" & RR).Interior.ColorIndex = 6
            Range("A" & RF & ":F" & RF).Interior.ColorIndex = 6
        End If
    Next RF
Next RR
End Sub

Nel caso volessi controllare più righe modifica le variabili "RigaIni" e RigaFine
Se vuoi colorare la riga dalla colonna A alla colonna R
Sostituisci queste due righe
Codice: Seleziona tutto
            Range("A" & RR & ":R" & RR).Interior.ColorIndex = 6
            Range("A" & RF & ":R" & RF).Interior.ColorIndex = 6

Se vuoi che sia evidenziata una solo riga delle due uguali cancelli il codice corrispondente alla riga che non vuoi colorare considerando che quella relativa ad RR è la prima riga e la riga RF è la seconda

Fai sapere
Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: tabella programmata con excel

Postdi prinx » 02/12/09 17:12

grazie per la risposta ma purtroppo non è quello che speravo
nel senso che lanciando la macro lo spazio di controllo (A-B-C-D-E) (F) si colora di giallo
ma io vorrei che si colorasse di giallo solo quando il secondo dato messo è uguale ad un altro
se vuoi in privato ti mando la scheda di lavoro così ci puoi provare
ti ringrazio tanto
prinx
Utente Junior
 
Post: 19
Iscritto il: 02/12/09 10:43

Re: tabella programmata con excel

Postdi Anthony47 » 02/12/09 18:55

Ciao prinx e benvenuto nel forum.
Fallo con la formattazione condizionale:
-selezioni l' area che contiene Nominativi e date (a19:F31)
-Menu /Formato /Formattazione condizionale;
-come Condizione1 scegli "La formula è" e come formula inserisci
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--($A$19:$A37=$A19);--($F$19:$F37=$F19);--($F$19:$F37>0))>1

-Premi Formato, tab Motivo, scegli il colore di sfondo che vuoi per le celle duplicate; Ok, Ok.

Prova e fai sapere, ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: tabella programmata con excel

Postdi prinx » 03/12/09 09:33

Grazie Anthony47
hai fatto un buon lavoro e per quanto riguarda la scheda era quello che volevo
però avrei un'altra necessità e scusami se ne approfitto della tua bravura
la scheda in questione è multipla sullo stesso foglio cioè si ripete
è possibile che la formula gestisce l'ugualità anche per le altre schede che si ripetono
cioè se alla prima scheda alla cella A19 metto franco rossi data 10.10.2010
e per errore mio metto anche alla scheda successiva (o ad un'altra più in giù) per esempio alla cella A68 metto franco rossi data 10.10.2010
può indicarmi l'errore e così anche alle schede successive?
grazie
prinx
Utente Junior
 
Post: 19
Iscritto il: 02/12/09 10:43

Re: tabella programmata con excel

Postdi Anthony47 » 04/12/09 02:44

prinx ha scritto:hai fatto un buon lavoro e per quanto riguarda la scheda era quello che volevo
però avrei un'altra necessità e scusami se ne approfitto della tua bravura
Grazie per l' incoraggiamento.

Non sono certo di che cosa tu intenda per "scheda", ma forse sono gruppi di celle con dati analoghi posizionati su righe successive del foglio di lavoro.
Se e' cosi', allora si deve intendere che i tuoi dati da controllare non sono in A17:F39, ma diciamo A17:F1000; allora bastera' variare l' area selezionata (A19:F1000 invece che A19:F31) e applicare la formattazione modificando la formula in =MATR.SOMMA.PRODOTTO(--($A$19:$A1000=$A19);--($F$19:$F1000=$F19);--($F$19:$F1000>0))>1

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: tabella programmata con excel

Postdi prinx » 04/12/09 12:39

Grazie Anthony47
mi hai dato un'ottima dritta
sei grande grazie ancora
prinx
Utente Junior
 
Post: 19
Iscritto il: 02/12/09 10:43


Torna a Applicazioni Office Windows


Topic correlati a "tabella programmata con excel":


Chi c’è in linea

Visitano il forum: Nessuno e 6 ospiti