Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Formato celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Formato celle

Postdi michaltam78 » 10/11/09 18:46

Ciao a tutti!!
Ho un quesito da sottoporre alla vostra cortese attenzione.
Ho un foglio di lavoro con delle celle in cui è impostato il formato personalizzato "00" che mi restituisce come valore "01" anche se nella cella scrivo semplicemente "1".
Detto questo poniamo per esempio che nella cella A1 (formattata come sopra) ci sia il valore "01" e nella cella B1 il valore "ciao". Nella cella C5 vorrei visualizzare l'unione dei due valori: "01ciao". Usando la formula "=a1&b1" però excel mi restituisce il valore "1ciao".
Qualcuno sa suggerirmi se e come è possibile risolvere la situazione?
Grazie a tutti come al solito!
michaltam78
Utente Junior
 
Post: 70
Iscritto il: 09/10/09 10:32

Sponsor
 

Re: [Excel] Formato celle

Postdi pietrol » 10/11/09 19:02

Ciao michaltam78
in C5
=TESTO(A1;"00") & B1
ma così se A1 è vuoto otterrai
00ciao

per ovviare puoi usare
=SE(VAL.NUMERO(A1);TESTO(A1;"00");"") & B1

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: [Excel] Formato celle

Postdi michaltam78 » 10/11/09 19:17

Ciao Pietrol!
Grazie mille per il suggerimento! Ovviamente funziona tutto alla perfezione... solo che ...
ho omesso un piccolo particolare:
In realtà oltre alla cella A1 che contiente il valore "01" e la cella b1 che contiene "ciao" esiste una terza cella con un altro valore numerico "c1=08" che deve essere unita alle precedenti:
"0108ciao"
Ora ho un po' di difficoltà a modificare la formula che mi hai suggerito...
michaltam78
Utente Junior
 
Post: 70
Iscritto il: 09/10/09 10:32

Re: [Excel] Formato celle

Postdi michaltam78 » 10/11/09 19:20

Ecco, con un po' di attenzione in più... sono riuscito a fare la modifica che avevo chiesto... Grazie ancora Pietrol!
michaltam78
Utente Junior
 
Post: 70
Iscritto il: 09/10/09 10:32


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Formato celle":


Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti