Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cerca orizzontale 2 valori

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cerca orizzontale 2 valori

Postdi tony61 » 09/11/09 17:43

Ciao a tutti sono di nuovo alle prese con un problema x me non di facile soluzione ,
allora devo trovare con la formula CERCA.ORIZZ ( o formule simili)due valori che si trovano ad esem..in cella
B487 e B488 questi valori /numeri devono essere presenti sulla stessa riga ORIZZ
ma devono essere consecutivi e nella stessa colonna come da esempio immagine sotto ,
una volta trovati esem.. in C487 e C488 mi riporta (1 se è possibile ) altrimenti un vero o falso .
Riepilogando il tutto il CERCA.ORIZZ deve trovare due valori (isotopi) stessa colonna e consecutivi
identici a quelli presenti in colonna B (consecutivi)
e riportare in C..il risultato se ce la condizzione altrimenti nulla
Le celle vanno da E2 a BB2 fino a E4400 e BB4400 ecco perchè la sola format..condiz non basta
x la mia ricerca .
Spero di essere stato chiaro e vi ringrazio la la cortesia
Immagine
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Sponsor
 

Re: Cerca orizzontale 2 valori

Postdi Anthony47 » 10/11/09 00:17

Per capire: devi controllare ognuna delle coppie di numeri adiacenti presenti in col B (quindi B1 e B2; B2 e B3; B3 e B4; etc), o solo due numeri precisi, che quindi vanno prima cercati in col B e poi verificate sulle righe corrispondenti?
Se "la prima che ho detto", allora metti in C2 questa formula e poi copiala verso il basso:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(E2:BB2=B2);--(E3:BB3=B3))

Ti dara' 0 se quella riga e la sottostante non rispettano la regola, oppure un numero che indica quante coppie sono state trovate nelle colonne adiacenti; se vuoi "1" anche nella colonna sottostante, in coda alla formula inserisci "+C1" (senza apici), ma in questo caso su una riga che facesse coppia sia con la precedente che la successiva vedresti 2; salvo inserire tutta la formula in un SE, tipo: =SE(Formula>0;1;"").

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cerca orizzontale 2 valori

Postdi tony61 » 10/11/09 18:47

Anthony47 ha scritto:Per capire: devi controllare ognuna delle coppie di numeri adiacenti presenti in col B (quindi B1 e B2; B2 e B3; B3 e B4; etc), o solo due numeri precisi, che quindi vanno prima cercati in col B e poi verificate sulle righe corrispondenti?
Se "la prima che ho detto", allora metti in C2 questa formula e poi copiala verso il basso:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(E2:BB2=B2);--(E3:BB3=B3))

Ti dara' 0 se quella riga e la sottostante non rispettano la regola, oppure un numero che indica quante coppie sono state trovate nelle colonne adiacenti; se vuoi "1" anche nella colonna sottostante, in coda alla formula inserisci "+C1" (senza apici), ma in questo caso su una riga che facesse coppia sia con la precedente che la successiva vedresti 2; salvo inserire tutta la formula in un SE, tipo: =SE(Formula>0;1;"").

Ciao.



Va benissimo la 1° bravissimo Anthony47
ancora mille grazie tutto ok

gentilissimo come sempre

ciao e grazie ancora
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33


Torna a Applicazioni Office Windows


Topic correlati a "Cerca orizzontale 2 valori":


Chi c’è in linea

Visitano il forum: jos235, Marius44, papiriof e 16 ospiti