Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel contare numeri consecutivi WinForLife

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 02/11/09 12:55

Ciao

Devo analizare molte decine (WinForLife - disposte in 10 celle orizzontali ciascuna) contando, per ciacuna di esse, quante sequenze consecutive ci sono.

Cioè, per ciascuna decina, devo saperr quanti sono inumeri NON consecutivi (numeri isolati) , quante coppie di numeri consecutivi, quante triplette, quante quartine, etc etc, fino a quante decine compongono la decina analizzata.

Esempio di una decina:
1 2 3 5 6 10 11 12 13 19

A fianco, in n colonne, dovrebbe uscirmi:

nella colonna "numeri Isolati": 1 (il 19)
nella colonna "coppia": 1 (il 5 e il 6)
nella colonna "tripla": 1 (l'1, il 2 e il 3)
nella colonna "quartina": 1 (il 10, 11, 12, 13)
nella colonna "cinquina": 0
...
...
...
...
nella colonna "decina": 0

Riuscite a farmi un documento con un paio di righe (cioè un paio di decine) complete già delle n colonne?

Grazie a tutti
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Sponsor
 

Re: Excel contare numeri consecutivi WinForLife

Postdi neverlandce » 02/11/09 16:43

ciao,
hai visto il file in questo topic

viewtopic.php?f=26&t=82806

forse potrebbe fare al caso tuo
neverlandce
Utente Junior
 
Post: 48
Iscritto il: 27/08/09 18:09

Re: Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 02/11/09 17:17

grazie
ma non fa al caso mio perché lavora su max 15 numeri...
ciao-ciao
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Re: Excel contare numeri consecutivi WinForLife

Postdi tutamimetica » 02/11/09 19:36

Ho i dieci numeri nel foglio1 da B5 a K5.
Nel foglio2 da C5 a C24 numeri da 1 a 20
In D5 =CONTA.SE(Foglio1!$B$5:$K$5;C5) trascini fino in D24
In E5 =SE(D5=1;1;"") trascini fino a E24
In F5 =SE(E5="";0;1)
In F6 =SE(E6="";0;F5+E5) trascini fino a F24
Ritorni sul Foglio1 da M5 a M14
Scrivi in M5 decina…… M13 coppia, M14 numeri isolati
N5==CONTA.SE(Foglio2!$F$5:$F$24;M5)
N6==CONTA.SE(Foglio2!$F$5:$F$24;M6)-N5
N7==CONTA.SE(Foglio2!$F$5:$F$24;M7)-N6
N8==CONTA.SE(Foglio2!$F$5:$F$24;M8)-SOMMA(N6:N7)
N9==CONTA.SE(Foglio2!$F$5:$F$24;M9)-SOMMA(N6:N8)
N10==CONTA.SE(Foglio2!$F$5:$F$24;M10)-SOMMA(N6:N9)
……
N14==CONTA.SE(Foglio2!$F$5:$F$24;M14)-SOMMA(N6:N13)
Ciao tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: Excel contare numeri consecutivi WinForLife

Postdi Flash30005 » 02/11/09 20:36

Ciao Marco e benvenuto
Avevo iniziato con la solita macro e ho finito or ora

prova a vedere se è questo che volevi ottenere
http://rapidshare.com/files/301505994/WinForLifeRaggr.xls.html

e speriamo che... Marco vinca davvero ;) :lol:

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 02/11/09 20:38

Sei gentilissimo, ci ho provato ma non funziona. Posso mandartelo via mail?
Grazie - ciao
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Re: Excel contare numeri consecutivi WinForLife

Postdi Flash30005 » 02/11/09 20:43

Marco, ci siamo "sovrascritti" con i post
e non so a chi ti riferisci con l'ultimo tuo inviato
se al mio file linkato poco fa o a Tutamimetica

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 02/11/09 20:50

a tutamimetica... grazie comunque... poi guardo e ti dico... grazie...
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Re: Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 03/11/09 08:09

per falsh:
è una figata, sei bravissimo
riusciresrti anche a creare, prima della colonna L, altre 10 colonnine (da singolo a decina) più strette dove sia riportato quanti ce ne sono e non quali sono i numeri che li compongono?


per tutamimetica:
ho provato a fare l'excell che mi dici ma mi sa che c'è qualcosa che non funziona.. forse qualche errore nelle lettere delle formule...

grazie a tutti
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Re: Excel contare numeri consecutivi WinForLife

Postdi Flash30005 » 03/11/09 12:10

Penso che tu voglia questo...
Link eliminato perché non valido

Fai sapere
Ciao


Modificato Post ore 13:50 - Flash30005
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 03/11/09 12:42

Credo di sì ma non lo so esattamente perché quando premi su avvia, per un millesimo di secondo appaiono i risultati nelle prima colonne ma poi se ne vanno...

grazie ancora

ciao
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Re: Excel contare numeri consecutivi WinForLife

Postdi Flash30005 » 03/11/09 13:49

Si, in effetti... :roll:

Una chiamata non effettuata di compilazione resoconto
vedi questo
http://rapidshare.com/files/301818835/WinForLifeRaggr2.xls.html

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 03/11/09 16:01

Flash, un nick veramente appropriato
grazie ancora...
poi ti dico
ciao-cio
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Re: Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 03/11/09 16:17

Flash, se ci incollo molte colonne nelle dieci a sinistra, mi da errore e mi propone un debug (arabo per me...) : Estratto(NA) = Cells(Sis, NA)
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Re: Excel contare numeri consecutivi WinForLife

Postdi Flash30005 » 03/11/09 16:41

Beh non so quante ne hai messe io ho provato con 2100 righe e in un baleno ha dato i risultati voluti
ma
Hai per caso modificato qualcosa all'interno della macro?
Le colonne le incolli da A2 a J2 verso il basso?
ci sono valori che non sono numerici? (magari "finti numeri" ma in formato testo?)
Ci sono spazi prima o dopo il numero?
se è così
passa questa routine
Incolla l'intero codice in un modulo e avvialo prima di ogni processo
Codice: Seleziona tutto
Sub converti()
Worksheets("Foglio1").Select
URS = Worksheets("Foglio1").Range("A" & Rows.Count).End(xlUp).Row
For R = 2 To URS
    For C = 1 To 10
        Cells(R, C).Value = Val(Cells(R, C).Value)
    Next C
Next R
End Sub


Fai sapere
Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 03/11/09 16:52

Hai per caso modificato qualcosa all'interno della macro?
>non saprei farlo...

Le colonne le incolli da A2 a J2 verso il basso?
> sì

ci sono valori che non sono numerici? (magari "finti numeri" ma in formato testo?)
> no

Ci sono spazi prima o dopo il numero?
>no

se è così passa questa routine Incolla l'intero codice in un modulo e avvialo prima di ogni processo
> arabo con influenze alessandrine...
;-
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Re: Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 03/11/09 17:17

Adesso funziona
forse avevo toccato qualcosa...
poi ti dico meglio...
ciao&grazie
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Re: Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 04/11/09 12:54

flash,ciao
sbaglio o non c'è la condizione di due cinquine?
grazie
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Re: Excel contare numeri consecutivi WinForLife

Postdi Flash30005 » 04/11/09 13:55

marcoVince ha scritto:sbaglio o non c'è la condizione di due cinquine?


Due cinquine su dieci numeri? :roll:
Secondo me creano una decina 8)
(e la condizione la trovi nel gruppo decine)

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Excel contare numeri consecutivi WinForLife

Postdi marcoVince » 04/11/09 14:00

capisco...
;-)
marcoVince
Utente Junior
 
Post: 29
Iscritto il: 02/11/09 12:38

Prossimo

Torna a Applicazioni Office Windows


Topic correlati a "Excel contare numeri consecutivi WinForLife":


Chi c’è in linea

Visitano il forum: Nessuno e 49 ospiti