Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] funzione matrice.prodotto

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] funzione matrice.prodotto

Postdi ramset64 » 17/10/09 07:39

Premesso che nella colonna A ci sono date e nella colonna B valori numerici, è possibile con questa funzione ottenre il minimo della colonna B relativo alle righe in cul l'anno è 2005?

Ovvero una formula tipo questa:
=MATR.SOMMA.PRODOTTO(--(ANNO(A2:A1264)=2005),MIN(B2:B1264))

Grazie, ciao
ramset64
Utente Senior
 
Post: 396
Iscritto il: 29/10/08 10:41
Località: Torino

Sponsor
 

Re: [excel] funzione matrice.prodotto

Postdi tutamimetica » 17/10/09 10:20

Prova =SE(MATR.SOMMA.PRODOTTO(--(ANNO(A2:A1264)=2005));MIN(B2:B1264);"")
Mi sembra funzioni
Tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: [excel] funzione matrice.prodotto

Postdi ramset64 » 17/10/09 10:46

Grazie tuta ma non funziona, cosi mi da il minimo di tutto il periodo e non solo dell'anno 2005.
Ciao
ramset64
Utente Senior
 
Post: 396
Iscritto il: 29/10/08 10:41
Località: Torino

Re: [excel] funzione matrice.prodotto

Postdi tutamimetica » 17/10/09 11:23

Hai ragione. Purtroppo nel 96 avevo messo valori più grandi e ... non lo vedevo.
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: [excel] funzione matrice.prodotto

Postdi pietrol » 17/10/09 18:08

Ciao ramset64
prova questa:
=MIN(SE(ANNO($A$2:$A$1264)=2005;$A$2:$A$1264;""))
inserita come matriciale, quindi non con invio ma con CTRL+MAIUSC+INVIO

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: [excel] funzione matrice.prodotto

Postdi ramset64 » 17/10/09 22:03

Ciao pietrol,
la formula funziona ma ho necessità di inserirla con vba ed utilizzare una combinazione tra lettera della colonna e numero della riga. Se la inserisco con la formulaarray, pur essendo inserita correttametente, mi viene fuori #NOME?. Se poi vado sulla cella e clicclo su ctrl + maius + invio allora funziona.
Credo che formulaarray non possa essere inserita con una combinazione tra lettere e numero ma debba essere inserita con formule tipo:
"=MIN(IF(YEAR(RC[-11]:R[1264]C[-11])=2005,RC[87]:R[1264]C[87],""""))".
Cosi infatti funziona, ma per motivi che non sto a spiegare ho necessità di inserirla con senza RC ma con combinazione lettera - numero.

Grazie!
Ciao
ramset64
Utente Senior
 
Post: 396
Iscritto il: 29/10/08 10:41
Località: Torino

Re: [excel] funzione matrice.prodotto

Postdi Anthony47 » 17/10/09 23:04

L' help on-line dice:
Osservazioni
Se si utilizza questa proprietà per immettere una formula sotto forma di matrice, la formula dovrà utilizzare lo stile di riferimento R1C1, non lo stile A1. A tale proposito vedere il secondo esempio.

A me comunque una formula tipo questa funziona
Codice: Seleziona tutto
Selection.FormulaArray = "=MIN(IF(YEAR($A$2:$A$1264)=2005,$A$2:$A$1264,""""))"

Ciao
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [excel] funzione matrice.prodotto

Postdi ramset64 » 17/10/09 23:10

Anthony ci ero arrivato ma cosi non mi serve purtroppo. Esiste una formula che faccia lo stesso calcolo senza utilizzare formule array?
ramset64
Utente Senior
 
Post: 396
Iscritto il: 29/10/08 10:41
Località: Torino

Re: [excel] funzione matrice.prodotto

Postdi ramset64 » 17/10/09 23:33

Anthony scusami la stanchezza fa brutti scherzi. Come hai suggerito funziona... grazie a tutti e scusate! :oops:
ramset64
Utente Senior
 
Post: 396
Iscritto il: 29/10/08 10:41
Località: Torino


Torna a Applicazioni Office Windows


Topic correlati a "[excel] funzione matrice.prodotto":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti