Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Somma su piu righe

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Somma su piu righe

Postdi oxjonis » 13/10/09 09:43

Ciao a tutti, vi propongo un problema particolare,
ho una serie di dati su righe e ho bisogno della loro somma
pippo 1
………..… 2
………..… 3
poldo 1
………..… 2
………..… 3
pluto 1
………..… 2
………..… 3
ciccio 1
………..… 2
………..… 3


ho bisogno del tot di pippo di poldo di pluto ecc tenete presente che sono 3000 righe circa, sto diventando matto ho provato a farle manualmente ma alla 700 righa ho ceduto,potreste aiutarmi?

Grazie a tutti
oxjonis
Newbie
 
Post: 1
Iscritto il: 13/10/09 09:02

Sponsor
 

Re: Somma su piu righe

Postdi tutamimetica » 13/10/09 15:06

Ipotizzando che hai i tuoi dati nelle colonne B (Pluto, Pippo…) e C (valori), inserisci nella colonna G i nomi (evitando i doppioni) e in F scrivi =SOMMA.SE($B$1:$C$1000;G1;$C$1:$C$1000).
Ciao tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: Somma su piu righe

Postdi maxmula » 13/10/09 15:32

Puoi usare un paio di colonne "d'appoggio"

Se hai questa condizione:
Codice: Seleziona tutto
   COL. J      COL. K
1 pippo          11
2                42
3                 3
4 poldo           1
5               152
6                63

ecc. ecc.



Puoi fare così:
- in L1 trascrivi il contenuto di J1

- in L2 metti questa formula:
Codice: Seleziona tutto
=SE(J1="";L1;J1)


- In M1 invece metti questa:
Codice: Seleziona tutto
=SE(J1<>"";SOMMA.SE(K:K;J1;K:K);"")


- Copia M1 in M2
- Copia l'intervallo L2:M2
- Seleziona le celle da L3 a fine lista (oppure vai direttamente a L65536)
- Incolla

Avrai così i totali per categoria, indipendentemente dalla quantità (e dal nome) delle categorie.

Codice: Seleziona tutto
   COL. J      COL. K     COL. L   COL. M
1 pippo          11       pippo     56
2                42       pippo
3                 3       pippo
4 poldo           1       poldo    216
5               152       poldo
6                63       poldo

ecc. ecc.



Attenzione però: questo metodo funziona solo se hai i dati relativi ad ogni categoria tutti consecutivi.
Se non è così (ovvero se ad un certo punto del tabulato ti ritrovi una seconda serie di "pippo") , avrai più totali "parziali" che dovrai poi sommare tra loro... ma questo è un altro problema :)

Ciao!
MAx
Avatar utente
maxmula
Utente Senior
 
Post: 965
Iscritto il: 18/08/04 18:28
Località: N44°59'45 E09°00'34

Re: Somma su piu righe

Postdi Anthony47 » 13/10/09 17:41

Ciao oxjonis e benvenuto nel forum.
Se, come ho capito, l' intestatario del dato e i valori stessi sono intercalati nella stessa colonna, allora credo che dovrai usare il metodo della colonna di appoggio come suggerito da maxmula.
Come unica variante: usa riga 1 per dare una intestazione ai tuoi dati; inserisci la formula in L2 e copiala verso il basso per tutte le righe dei tuoi dati; poi ti fai una tabella pivot per avere il riepilogo delle somme per tutti i nomi.
Se hai bisogno di dettagli su come fare cio', posta ancora dando anche l' esatto layout dei tuoi dati.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Somma su piu righe":


Chi c’è in linea

Visitano il forum: tex willer e 9 ospiti