Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Cerca verticale valore cella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Cerca verticale valore cella

Postdi tony61 » 03/10/09 10:37

Immagine

Ciao a tutti
Dopo vari tentativi sono di nuovo alle prese con dei problemi con excel
devo rintracciare con la funzione cerca verticale ho simili
un determinato valore in una cella il primo a ritroso dall'alto verso il basso
(oppure se non e possibile 2° opzione dal basso verso l'alto)
Esempio se sono nella riga 120 (A120)e devo trovare il valore a ritroso esemp..il n°50(presente in A120)
cer.vert dovrebbe partire da quell punto e cercare da A121 fino ad A500 esemp ..
trovato il valore (n°50) mi deve dare il risultato della cella superiore (valore numero presente)
come nell'esempio dell'immagine .
Spero di essermi spiegato bene e non aver fatto confusione nella spiegazione
grazie ciao
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Sponsor
 

Re: Cerca verticale valore cella

Postdi tony61 » 03/10/09 13:42

Ciao qualcuno sa dirmi se e fattibile come funzione ,oppure excel non lo consente
almeno so come orientarmi ,in riferimento al mio post

grazie ciao
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Re: Cerca verticale valore cella

Postdi Flash30005 » 04/10/09 01:54

In F8 inserisci questa formula per avere 20 (della riga 17)
Codice: Seleziona tutto
=CERCA.VERT(A8;A9:E100;1;FALSO)

in G8 questa per avere 75
Codice: Seleziona tutto
=INDICE(A2:A32;CONFRONTA(A8;A9:A100;0)-1+RIF.RIGA()-1;0)


I valori E100 e A100 puoi cambiarli
Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Cerca verticale valore cella

Postdi Anthony47 » 04/10/09 10:26

Da quello che capisco Tony61 dovrebbe usare la seconda delle formule di Flash; tale formula puo' essere leggermente semplificata in
Codice: Seleziona tutto
=INDICE(A8:A$500;CONFRONTA(A8;A9:A$500;0))

La formula e' per riga 8, ma puo' essere poi copiata sulle righe precedenti e successive se il calcolo e' da fare su ogni numero presente in colonna A.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cerca verticale valore cella

Postdi tony61 » 04/10/09 12:32

Grazie mille a tutti e due

la provo subito

ciao
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Re: Cerca verticale valore cella

Postdi tony61 » 04/10/09 14:20

tony61 ha scritto:Grazie mille a tutti e due

la provo subito

ciao


Tutto ok

sempre molto gentili e preparati
ancora grazie
ciao
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Re: Cerca verticale valore cella

Postdi tony61 » 27/12/09 16:40

Anthony47 ha scritto:Da quello che capisco Tony61 dovrebbe usare la seconda delle formule di Flash; tale formula puo' essere leggermente semplificata in
Codice: Seleziona tutto
=INDICE(A8:A$500;CONFRONTA(A8;A9:A$500;0))

La formula e' per riga 8, ma puo' essere poi copiata sulle righe precedenti e successive se il calcolo e' da fare su ogni numero presente in colonna A.

Ciao.


Ciao a tutti ,
riprendo questo post perchè devo fare una modifica ,la formula va bene ok
=INDICE($A2:$A$3000;CONFRONTA(F2;$A3:$A$3000;0)) questa e la mia attuale

devo fare in modo che il CONFRONTA,non consideri solo la colonna A opp..B/C/D/E
in modo separato ,ma che si possa in qualche modo fare la ricerca sulle 5 colonne A/B/C/D/E
contemporaneamente e la ricerca si fermi al 1° risultato utile

Io ho creato 5 colonne dove mi porta i valori trovati e li mette nelle colonne F-G-H-I-J
il problema e che devo fermarmi al 1°risultato utile che la formula trova tra le colonne A-B-C-D-E
andando a ritroso
esem: cerco il valore (numero 20) tra le colonne A-B-C-D-E
colonna.A-trova il 20 nelle 15 estraz..precedenti
colonna.B-trova il 20 nelle 36 estraz..precedenti
colonna.C-trova il 20 nelle 110 estraz..precedenti
colonna.D-trova il 20 nelle 90 estraz..precedenti
colonna.E-trova il 20 nelle 8 estraz..precedenti (questo è il primo che trova )e quello che interessa a me per applicare la formula sopra CONFRONTA

spero di essermi spiegato correttamente ,
in poche parole cerca in verticale e orizzontale fermandosi al 1° risultato utile
questa e la sintesi .

grazie ancora
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Re: Cerca verticale valore cella

Postdi Flash30005 » 27/12/09 19:32

Per me comincia ad essere complesso risolvere attraverso formule
se "digerisci" le macro fammelo sapere
mi metterò a disposizione per creartene una che fa quello che vorresti

Ciao

P.s. in tal caso dovresti inviare un foglio con i dati.
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Cerca verticale valore cella

Postdi tony61 » 27/12/09 20:58

Grazie Flash

se riuscivo a farlo con le formule preferivo ,non ho molta dimestichezza con le macro
sono ancora alle prime armi ,ma col tempo cercherò di imparare .

L'immagine in alto mostra con l'esempio il lavoro che devo fare ,e penso con un qualsiasi archivio puoi verificare,
ma il problema principale e che deve trovare il primo valore a ritroso tra le 5 colonne .

Non so se esiste un cerca VERTICALE/ORIZZONTALE da includere assieme ,
pio inserire il CONFRONTA per visualizzare il valore cercato
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Re: Cerca verticale valore cella

Postdi Anthony47 » 27/12/09 22:04

Lo puoi fare con un po' di pazienza, mettendo 5 CONFRONTA nella stessa formula, cosi' combinata:
Codice: Seleziona tutto
=MAX(SE(VAL.ERRORE(CONFRONTA($F$2;A$1:A3;0));0;CONFRONTA($F$2;A$1:A3;0));SE(VAL.ERRORE(CONFRONTA($F$2;B$1:B3;0));0;CONFRONTA($F$2;B$1:B3;0));SE(VAL.ERRORE(CONFRONTA($F$2;C$1:C3;0));0;CONFRONTA($F$2;C$1:C3;0));ripeti con D$1:D3; ripeti con E$1:E3)

La formula e' costituita da 5 blocchi del tipo SE(VAL.ERRORE(CONFRONTA($F$2;A$1:A3;0));0;CONFRONTA($F$2;A$1:A3;0)); la parte in grassetto va di volta in volta modificata per puntare alla colonna B, C, D, ed E; i primi tre blocchi sono gia' sviluppati nella formula di sopra, i rimanenti due li devi creare tu, ma e' solo un gioco di copia /Incolla /modifica.
La formula e' da inserire in F3 e poi puo' essere copiata verso il basso; ti restituisce la riga piu' alta su cui si trova il valore posto in F2, ma siccome non so che cosa vuoi alla fine calcolare non so se quanto proposto ti puo' aiutare.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Cerca verticale valore cella

Postdi tony61 » 27/12/09 22:20

Grazie Anthony47 e Flash

proverò subito anche a costo di metterci l'intera notte

Grazie ancora
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Re: Cerca verticale valore cella

Postdi tony61 » 27/12/09 22:49

Con questo Anthony47
mi trova il ritardo maggiore è ok x altri tipi di statistica

io mi riferivo al post iniziale del 03/10/09 11:37--e quello di oggi-27/12/09 17:40
in riferimento a tali post
-------------------------------------------------------------------------
Ciao a tutti ,
riprendo questo post perchè devo fare una modifica ,la formula va bene ok
=INDICE($A2:$A$3000;CONFRONTA(F2;$A3:$A$3000;0)) questa e la mia attuale

devo fare in modo che il CONFRONTA,non consideri solo la colonna A opp..B/C/D/E
in modo separato ,ma che si possa in qualche modo fare la ricerca sulle 5 colonne A/B/C/D/E
contemporaneamente e la ricerca si fermi al 1° risultato utile

Io ho creato 5 colonne dove mi porta i valori trovati e li mette nelle colonne F-G-H-I-J
il problema e che devo fermarmi al 1°risultato utile che la formula trova tra le colonne A-B-C-D-E
andando a ritroso
esem: cerco il valore (numero 20) tra le colonne A-B-C-D-E
colonna.A-trova il 20 nelle 15 estraz..precedenti
colonna.B-trova il 20 nelle 36 estraz..precedenti
colonna.C-trova il 20 nelle 110 estraz..precedenti
colonna.D-trova il 20 nelle 90 estraz..precedenti
colonna.E-trova il 20 nelle 8 estraz..precedenti (questo è il primo che trova )e quello che interessa a me per applicare la formula sopra CONFRONTA

spero di essermi spiegato correttamente ,
in poche parole cerca in verticale e orizzontale fermandosi al 1° risultato utile
questa e la sintesi .

grazie ancora
Anthony47 ha scritto:Da quello che capisco Tony61 dovrebbe usare la seconda delle formule di Flash; tale formula puo' essere leggermente semplificata in
Codice: Seleziona tutto
=INDICE(A8:A$500;CONFRONTA(A8;A9:A$500;0))

La formula e' per riga 8, ma puo' essere poi copiata sulle righe precedenti e successive se il calcolo e' da fare su ogni numero presente in colonna A.

Immagine

in riferimento a questa immagine
Ciao.
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Re: Cerca verticale valore cella

Postdi tony61 » 29/12/09 11:20

Sempre inerente al post sopra (penultimo)
se si adottasse un concatena i dati della riga A1-B1-C1-D1-E1
ecc..a scendere si potrebbe risolvere il problema di trovare il primo valore utile
a ritroso ?
esem:
=INDICE($A2:$A$3000;CONFRONTA(F2;$A3:$A$3000;0))trova il n°18
=INDICE($B2:$B$3000;CONFRONTA(F2;$B3:$B$3000;0))trova il n°26
=INDICE($C2:$C$3000;CONFRONTA(F2;$C3:$C$3000;0))trova il n°45
=INDICE($D2:$D$3000;CONFRONTA(F2;$D3:$D$3000;0))trova il n°58
=INDICE($E2:$E$3000;CONFRONTA(F2;$E3:$E$3000;0))trova il n°65

di questi 5 n°(valori) trovati nell'esempio a me interessa solo
il primo valore trovato a ritroso ,e avendone a disposizione 5 faccio fatica a capire quale sia il
primo trovato tra i 5 ,fra le colonne A-B-C-D-E-

spero di essermi spiegato bene
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Re: Cerca verticale valore cella

Postdi Flash30005 » 29/12/09 23:21

Ma se trova il 20 nella colonna E(riga 16) quale valore deve essere riportato in G8? (E15? o A15?)

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Cerca verticale valore cella

Postdi tony61 » 30/12/09 00:32

Flash30005 ha scritto:Ma se trova il 20 nella colonna E(riga 16) quale valore deve essere riportato in G8? (E15? o A15?)

Ciao


Ciao in G8 mi riporta il valore dela cella superiore a dove si trova esem: il n°20(nel'imagg sarebbe il n°75)

io ho già fatto 5 colonne che mi trovano il valore superiore A-B-C-D-E
ma come spiegavo prima a me interessa solo il primo che trova a ritroso e non tutti e 5

grazie Flash30005
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Re: Cerca verticale valore cella

Postdi Flash30005 » 30/12/09 01:16

Questo è un esempio di macro che trova il primo valore (di F8) a partire dalla riga 2 considerando le 5 colonne (A-B-C-D-E)
Codice: Seleziona tutto
Sub trovaVal()
Ue = Range("A" & Rows.Count).End(xlUp).Row
Area = Range("A2:E" & Ue)
valore = Range("F8").Value
For RR = 2 To Ue
    For CC = 1 To 5
        If Cells(RR, CC).Value = valore Then
        [G8] = Cells(RR - 1, CC).Value
        GoTo esci
        End If
    Next CC
Next RR
esci:
End Sub

e posiziona in G8 il valore della cella della riga precedente posta nella stessa colonna del valore trovato

Ho solo un dubbio: nel tuo primo esempio non prendevi in considerazione il numero 20 che era in A8 quindi se ti occorre il secondo valore trovato, è sufficiente modificare "leggermente" la macro

Per inserire la macro nei moduli devi digitare contemporaneamente ALT e F11 poi dal Menu "Inserisci" scegli Modulo e incolli il codice qui postato dopodiché avvii la macro (dal vba con il tasto "play") oppure dal foglio con ALT+F8 selezioni la macro "TrovaVal" e premi il comando Esegui.

In futuro se tutto ok la si può automatizzare con pulsante o con la variazione del valore di F8

Fai sapere
Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Cerca verticale valore cella

Postdi tony61 » 30/12/09 11:22

Grazie mille Flash

va bene complimenti x il lavoro svolto bravo

dovremmo aggiungere se possibile una funzione , se voglio fare una statistica a ritroso
possa partire anche dalla riga esem:512
tipo un riferimento riga
ho record inizio ricerca

poi la macro e ok se c'è la possibilità di aggiungere questa funzione il lavoro
e completo .
Una domanda se voglio prendere solo 2 colonne x la ricerca al posto di 5 come vario il Range
di riferimento ?
sostituendo le lettere .

Grazie ancora
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Re: Cerca verticale valore cella

Postdi Flash30005 » 31/12/09 02:24

Scarica questo file

Non metto i codici perché alcuni vanno inseriti nel foglio e non nel modulo, ho aggiunto il pulsante Start, il numero di colonne da impostare direttamente sul foglio e anche la scelta sul tipo di ricerca (ritroso o no).

A proposito di ritroso, in questo caso, però, sarà presa in considerazione la colonna più vicina all'ultima riga, giusto?
es. se ho 20 sia sulla colonna A riga 39, che su B riga 38, e su C riga 37, a ritroso prenderà il valore della cella in A 38, penso che sia corretto così perché diversamente non si può fare.

Fai sapere se tutto ok

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: Cerca verticale valore cella

Postdi tony61 » 31/12/09 12:05

Grazie mille Flash

ok va benissimo le funzioni che hai messo
x quello che riguarda il pulsante ritroso non riesco a capire come funzioni
ad esempio se voglio partire a fare la ricerca dalla riga 415,
si dovrebbe partire da record 415 e trovare il primo valore
utile tra le colonne(1/5) e ci si ferma al primo risultato
il n° che metto in F8 me lo trova tra le 5 colonne

se trova il esem:
il n° 90 alla riga A434
e il n° 90 alla riga B432
quello che mi serve e il B432 perchè è il primo valore dal record stabilito in partenza 415 a ritroso

ti ringrazio molto e ti uguro a te e tutto il forum
un ottimo 2010 e tanti auguri
tony61
Utente Senior
 
Post: 176
Iscritto il: 11/04/09 13:33

Re: Cerca verticale valore cella

Postdi Flash30005 » 31/12/09 13:11

Ho pensato che la ricerca a ritroso si dovesse avviare dall'ultima riga esistente nei dati colonne A:E
Se tu intendi, invece, avere anche l'opzione di poter digitare la riga dalla quale avviare la ricerca a ritroso fammelo sapere così interveniamo sulla macro.

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Prossimo

Torna a Applicazioni Office Windows


Topic correlati a "Cerca verticale valore cella":


Chi c’è in linea

Visitano il forum: Maury170419 e 18 ospiti