Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

formula?

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

formula?

Postdi ROBI1964 » 22/09/09 10:25

ciao
ho in una cella i mesi visualizzati in numero(da1 a 12); se voglio far corrispondere in una altra cella quei numeri al mese corrispondente in lettere (1=gennaio;2=febbraio ecc che funzione devo usare?
ROBI1964
Newbie
 
Post: 9
Iscritto il: 27/10/08 11:15

Sponsor
 

Re: formula?

Postdi Statix » 22/09/09 11:26

Ciao,
puoi crearti una piccola tabella
ti faccio un esempio
A1=1 B1= gennaio
A2=2 B2=Febbraio
etc.etc
poi metti in una cella tipo D1=
=cerca.vert(A1;$A$1:$B$12;2;falso)
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: formula?

Postdi Flash30005 » 22/09/09 12:39

Ottima la soluzione di Statix con tabella e cerca verticale

un'alternativa senza uso di tabella potrebbe essere
supponendo che in A1 hai il mese (1)
mettere dove vuoi tu questa formula
Codice: Seleziona tutto
=TESTO("01/"&A1&"/2009";"mmmm")

e trascinarla nella direzione degli altri mesi

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: formula?

Postdi Anthony47 » 22/09/09 22:33

Solo un warning: la formula di Flash e' soggetta a errore per eventuale configurazione del pc nel formato data all' inglese (mm/gg/aaaa), per cui 01/11/2009 potrebbe essere Gennaio 11 2009; per evitare questo rischio si potrebbe usare la funzione DATA invece del testo concatenato:
Codice: Seleziona tutto
=TESTO(DATA(2009;A1;1);"mmmm")


Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: formula?

Postdi ROBI1964 » 07/10/09 19:15

ciao. ho un altro problema.
su un foglio1 in c1 ho l'anno : cambiando questo mi cambia il calendario per gli altri 12 fogli ,e fin qui tutto ok; grazie a voi ho trovato il modo di calcolare automaticamente anche le date della pasqua,ok.
sul foglio1 da a2:a20 ho scritto i giorni festivi di ogni anno es 01/01 /2010 ,06/01/2010 ecc
Vorrei modificare l'anno di queste celle al modificare dell'anno in c1, e' possibile?
grazie
ROBI1964
Newbie
 
Post: 9
Iscritto il: 27/10/08 11:15

Re: formula?

Postdi Statix » 07/10/09 22:43

Ciao Robi1964,

se nel foglio i giorni festivi sono fissi,
in A2:A20 potresti scrivere il giorno e mese tra le virgolette e poi concateni con & C1
Codice: Seleziona tutto
  ="26/10/"&C1
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Re: formula?

Postdi Anthony47 » 08/10/09 01:26

Un warning anche sulla soluzione di Statix, perche' non e' garantito che quella stringa, calcolata con una formula, diventi una data. Ma oramai dovresti conoscere la funzione DATA, no?
Quindi
Codice: Seleziona tutto
=DATA(C1;numero del mese; numero del giorno)

Ciao a tutti.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: formula?

Postdi ROBI1964 » 08/10/09 08:36

grazie antony,funziona a meraviglia
ROBI1964
Newbie
 
Post: 9
Iscritto il: 27/10/08 11:15


Torna a Applicazioni Office Windows


Topic correlati a "formula?":


Chi c’è in linea

Visitano il forum: Nessuno e 17 ospiti