Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

media dei valori in corrispondenza di

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

media dei valori in corrispondenza di

Postdi marcoc » 28/07/09 17:09

ciao a tutti, rieccomi con un nuovo "problema":
semplificando, ho una tabella simile a questa:
riga1: a|b|a|c|c|b|a|a|a|b
riga2: 2|5|4|7|6|8|4|8|5|4

e vorrei ottenere una tabella simile a questa
a|4,6
b|5,6
c|6,5
in cui viene riportata la media dei valori in corrispondenza di ogni lettera (4,6 è (2+4+4+8+5)/5; 5,6 è (5+8+4)/3, mentre 6,5 è (7+6)/2).

che formula devo usare? ho provato con la "solita" matrice somma prodotto ma non va.
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: media dei valori in corrispondenza di

Postdi ricky53 » 28/07/09 23:00

Ciao,
nella speranza che tu non abbia semplificat troppo e quindi la soluzione che ti sto pe proporre potrebbe non essere adatta, prova con

Codice: Seleziona tutto
=SOMMA.SE(A$1:J$1; O1; A$2:J$2) / CONTA.SE(A$1:J$1; O1)

la formula ho ipotizzato sia scritta in "P1"

dove
A1:J1 contengono i dati a,b,c
A2:J2 contengono i valori numerici
O1 contiene "a"

per le altre lettere
O2 = "b"
O3= "c"
....
copia la formula in basso da "P2" in giù

Dovrai modificare i riferimenti di cella secondo il tuo file.
Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: media dei valori in corrispondenza di

Postdi marcoc » 29/07/09 15:01

perfetto, anzi, più semplice di quanto immaginassi!
ciao!
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano


Torna a Applicazioni Office Windows


Topic correlati a "media dei valori in corrispondenza di":


Chi c’è in linea

Visitano il forum: patel e 49 ospiti