Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL]problema confronto su excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL]problema confronto su excel

Postdi colataroc » 10/06/09 08:14

ciao ragazzi avrei bisogno di una mano per excel allora vi spiego:

io ho due colonne A,B (che contengono numeri) di diversa lunghezza, vorrei che nella colonna C, quando si riscontra una uguaglianza tra A(n) e B(n), venisse segnato in C(n) un asterisco e ovviamente il tutto continui finchè non arrivi in fondo e tutto ciò per ogni valore B . come posso fare?
colataroc
Newbie
 
Post: 3
Iscritto il: 10/06/09 08:07

Sponsor
 

Re: [EXCEL]problema confronto su excel

Postdi Anthony47 » 10/06/09 09:36

Ciao colataroc e benvenuto nel forum.
In C2 la formula
Codice: Seleziona tutto
=SE(LUNGHEZZA(INT(A2))=LUNGHEZZA(INT(B2));"*";"")
poi copi C2 verso il basso.
Ricorda pero' che i numeri si pesano in valore, non si misurano in lunghezza; quindi tale confronto potrebbe non essere sempre valido.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL]problema confronto su excel

Postdi colataroc » 10/06/09 10:02

Anthony47 ha scritto:Ciao colataroc e benvenuto nel forum.
In C2 la formula
Codice: Seleziona tutto
=SE(LUNGHEZZA(INT(A2))=LUNGHEZZA(INT(B2));"*";"")
poi copi C2 verso il basso.
Ricorda pero' che i numeri si pesano in valore, non si misurano in lunghezza; quindi tale confronto potrebbe non essere sempre valido.

Ciao.

no infatti questa non può andare poichè la maggior parte dei numeri è uguale comunque ho trovato una formula che fa al caso mio
=SE(CONTA.SE(Foglio3!A1:A463;F118)=0;0;CERCA.VERT(F118;Foglio3!A1:A463;1;FALSO))
però ogni volta che la incollo il valore considerato passa alla cella successiva e di seguito anche l'intervallo. io avrei bisogno che l'intervallo fosse fisso, blocato
=SE(CONTA.SE(Foglio3!A118:A467;F122)=0;0;CERCA.VERT(F122;Foglio3!A118:A467;1;FALSO))
ho bisogno che sia come quello della formula sopra.
come faccio?
colataroc
Newbie
 
Post: 3
Iscritto il: 10/06/09 08:07

Re: [EXCEL]problema confronto su excel

Postdi bogard » 10/06/09 10:35

Devi usare il dollaro "$". In pratica, messo davanti alla lettera e/o al numero non va in progresione anche se copiato. In pratica, se ho capito bene dove devi bloccare, da:
=SE(CONTA.SE(Foglio3!A1:A463;F118)=0;0;CERCA.VERT(F118;Foglio3!A1:A463;1;FALSO))
diventa:
=SE(CONTA.SE(Foglio3!$A$1:$A$463;F118)=0;0;CERCA.VERT(F118;Foglio3!$A$1:$A$463;1;FALSO))
Oppure nella seconda stringa che hai scritto, da:
=SE(CONTA.SE(Foglio3!A118:A467;F122)=0;0;CERCA.VERT(F122;Foglio3!A118:A467;1;FALSO))
a:
=SE(CONTA.SE(Foglio3!$A$118:$A$467;F122)=0;0;CERCA.VERT(F122;Foglio3!$A$118:$A$467;1;FALSO))

Spero di esserti stato d'aiuto ;)
bogard
Newbie
 
Post: 3
Iscritto il: 10/06/09 10:11

Re: [EXCEL]problema confronto su excel

Postdi colataroc » 10/06/09 10:55

bogard ha scritto:Devi usare il dollaro "$". In pratica, messo davanti alla lettera e/o al numero non va in progresione anche se copiato. In pratica, se ho capito bene dove devi bloccare, da:
=SE(CONTA.SE(Foglio3!A1:A463;F118)=0;0;CERCA.VERT(F118;Foglio3!A1:A463;1;FALSO))
diventa:
=SE(CONTA.SE(Foglio3!$A$1:$A$463;F118)=0;0;CERCA.VERT(F118;Foglio3!$A$1:$A$463;1;FALSO))
Oppure nella seconda stringa che hai scritto, da:
=SE(CONTA.SE(Foglio3!A118:A467;F122)=0;0;CERCA.VERT(F122;Foglio3!A118:A467;1;FALSO))
a:
=SE(CONTA.SE(Foglio3!$A$118:$A$467;F122)=0;0;CERCA.VERT(F122;Foglio3!$A$118:$A$467;1;FALSO))

Spero di esserti stato d'aiuto ;)

sei un grande, un genio, un boss grazie a te ho controllato 12800 record in 5 secondi!!!!
grazi infinite....un ultima cosa ora ho ottenuto uno 0 nelle righe che non mi interessano e le devo eliminare.... dato che sono più di 5000 come faccio imposto ul filtro per eliminarle?
colataroc
Newbie
 
Post: 3
Iscritto il: 10/06/09 08:07

Re: [EXCEL]problema confronto su excel

Postdi ricky53 » 10/06/09 11:29

Ciao,
si imposta il filtro automatico e filtra per il valore che non ti interessa, poi elimina selezionando le righe.
Attenzione ai dati, eventualmente, presenti nelle altre colonne.

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL]problema confronto su excel":


Chi c’è in linea

Visitano il forum: patel e 9 ospiti