Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

copiare il contenuto di 3 celle in una

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

copiare il contenuto di 3 celle in una

Postdi gamma_ray » 21/05/09 09:55

Mi spiego: ho 3 celle A1, A2, A3, contenenti del testo (nome, cognome, età), che sono nel foglio 1 di una cartella di lavoro. C'è una formula che mi permette di copiare il contenuto di queste 3 celle in un'unica cella, e possibilmente in un altro foglio?
Grazie.
Avatar utente
gamma_ray
Utente Senior
 
Post: 1464
Iscritto il: 09/05/03 16:27

Sponsor
 

Re: copiare il contenuto di 3 celle in una

Postdi gamma_ray » 21/05/09 10:03

dunque, la formula l'ho trovata, usando i valori &" "&, solo che non riesco a farla in un foglio diverso.
Avatar utente
gamma_ray
Utente Senior
 
Post: 1464
Iscritto il: 09/05/03 16:27

Re: copiare il contenuto di 3 celle in una

Postdi dipic » 21/05/09 10:07

prova ad usare la formula CONCATENA ... se non ho capito male dovrebbe essere quello che ti serve
Avatar utente
dipic
Utente Junior
 
Post: 95
Iscritto il: 13/09/08 14:57
Località: Cormòns (I)

Re: copiare il contenuto di 3 celle in una

Postdi roberto.g » 21/05/09 10:13

Ciao
nel foglio 1 del tuo file hai le celle A1, A2 e A3 contenente nome, cognome ed età.
Vai sul foglio2 del tuo file , in una qualsiasi cella e scrivi

=CONCATENA(Foglio1!A1;" ";Foglio1!A2;" ";Foglio1!A3)

Ciao
Roberto
roberto.g
Utente Junior
 
Post: 32
Iscritto il: 14/01/09 09:54

Re: copiare il contenuto di 3 celle in una

Postdi gamma_ray » 21/05/09 12:48

perfetto, con questa funzione si fa prima! Grazie.
Avatar utente
gamma_ray
Utente Senior
 
Post: 1464
Iscritto il: 09/05/03 16:27

Re: copiare il contenuto di 3 celle in una

Postdi ricky53 » 21/05/09 12:49

Ciao,

anche senza la funzione "concatena":

Codice: Seleziona tutto
=Foglio1!A1 &" " & Foglio1!A2 & " " & Foglio1!A3


Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: copiare il contenuto di 3 celle in una

Postdi gamma_ray » 21/05/09 18:13

nel frattempo mi è sorta un'altra esigenza. In pratica alcune celle conengono delle date, e quando uso la funzione concatena, nella cella di destinazione la data viene convertita in numeri causali, giustamente perchè la cella di destinazione non è formattata per le date.
Si può fare qualcosa?
Avatar utente
gamma_ray
Utente Senior
 
Post: 1464
Iscritto il: 09/05/03 16:27

Re: copiare il contenuto di 3 celle in una

Postdi ricky53 » 21/05/09 19:06

Ciao,
prova in questo modo:

Codice: Seleziona tutto
=TESTO(A1; "gg-mm-aaaa") & " - " & TESTO(B1; "gg-mm-aaaa")


Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: copiare il contenuto di 3 celle in una

Postdi ricky53 » 21/05/09 19:09

Ciao,
non sono numeri casuali ma il progressivo assoluto, espresso in giorni, dal 01-01-1900 alla data che ha inserito.

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: copiare il contenuto di 3 celle in una

Postdi gamma_ray » 22/05/09 08:24

ti ringrazio tanto, ma devo disturbarti ancora ;)
In pratica quella formula va messa in un altro foglio. Cioè, i dati di origine sono in un foglio, mentre la formula è in un altro. Ho provato a usare la formula Foglio! ecc, ma mi da sempre l'errore di riferimento circolare e non riesco a capire dov'è l'errore. Riesci a darmi la formula esatta?
Grazie ancora tantissimo!
Avatar utente
gamma_ray
Utente Senior
 
Post: 1464
Iscritto il: 09/05/03 16:27

Re: copiare il contenuto di 3 celle in una

Postdi roberto.g » 22/05/09 08:58

Ciao
sempre in a1,a2 e a3 del tuo foglio1 del tuo file excel hai i tuoi dati. Nel foglio2 del tuo file in a1 metti la formula

=TESTO(Foglio1!A1; "gg-mm-aaaa") & " " & TESTO(Foglio1!A2; "gg-mm-aaaa") & " " & TESTO(Foglio1!A3; "gg-mm-aaaa")

a me funziona, non da nessun errore. Eventualmente se sai sempre in quali celle non hai le date, puoi togliere la parte TESTO (xxx)

Ciao
Roberto
roberto.g
Utente Junior
 
Post: 32
Iscritto il: 14/01/09 09:54

Re: copiare il contenuto di 3 celle in una

Postdi ricky53 » 22/05/09 09:11

Ciao,
le celle che ho utilizzato nella mia risposta erano solo di esempio.

Se ottieni l'errore sul riferimento circolare significa che hai scritto, in una cella, una formula che contiene il riferimento a se stessa.
Esempio in "A1" NON puoi scrivere =B1 & " " & A1.

Controlla i riferimenti alle celle che hai utilizzato ed in quali celle li hai scritti.

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "copiare il contenuto di 3 celle in una":


Chi c’è in linea

Visitano il forum: alfrimpa e 22 ospiti