Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi biancocandido55 » 19/05/09 21:55

Ciao ragazzi,
sono 2 mattine che non riesco a trovare una soluzione a questo problema in un foglio registro inserisco alcuni dati come da immagine
Immagine
in un altro foglio ho una tabella riepilogo, sempre come da immagine
Immagine
praticamente nel foglio riepilogo devo sommare i valori contenuti nelle celle della colonna H2:h500,
solo se nella colonna C2:c500 è uguale a "pippo"
e se nella colonna e2:e500 è uguale a "feb",
quindi per pippo il risultato sarebbe 35,
per pluto sarebbe 25
e paperino 25,
ho provato con SOMMA.SE o MATR.SOMMA.PRODOTTO, il risultato che ho è sempre lo stesso (quello che si vede nella 2 immagine) :cry: sigh!
Non riesco proprio a capire!! :x :eeh:
Spero vivamene in un vostro aiuto.
un saluto
biancocandido Immagine
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15

Sponsor
 

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi Anthony47 » 19/05/09 21:57

Posta le formule che hai provato e ti metteremo i "--" dove servono.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi biancocandido55 » 19/05/09 22:01

Ciao Anthony,
avevo provato questa:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(REGISTRO!$C$2:$C$500="pippo");--(REGISTRO!$E$2:$E$500="feb");(REGISTRO!$H$2:$H$500))

ma niente da fare.
ciao e grazie
bianco
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi Anthony47 » 19/05/09 22:11

Nella colonna MESE c' e' una "stringa" (es feb) o c' e' una data? In questo secondo caso dovresti usare
Codice: Seleziona tutto
--(testo(REGISTRO!$E$2:$E$500;"mmm")="feb")

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi ricky53 » 19/05/09 22:15

Ciao,
prova con una tabella PIVOT e ne esci.

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi biancocandido55 » 19/05/09 22:17

Ciao Anthony,
ho fatto le correzioni come suggerito, in effetti nella colonna mese ci sono formule,
inserita, corretta e funziona.
Come sempre, grazie 100000
ciao biancocandido Immagine
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi biancocandido55 » 19/05/09 22:24

ciao ricky53,
ti ringrazio del suggerimento, ma ad operare il file non sono solo io, ho dovuto optare con formule, lo so che una tabella pivot avrebbe risolto il problema, ma sarebbe stata più complessa da spiegare ad altre persone che masticano ancor meno di me l'excel.
grazie comunque del suggerimento.
ciao biancocandido Immagine
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi biancocandido55 » 19/05/09 22:29

Ciao ragazzi,
dimenticavo di dire che la formula che ho usato è stata questa:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(REGISTRO!$C$2:$C$500="pippo");--(TESTO(REGISTRO!$E$2:$E$500;"mmm")="feb");(REGISTRO!$H$2:$H$500))

ciao e grazie
biancocandido55 Immagine
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi Flash30005 » 20/05/09 00:43

biancocandido55 ha scritto:Ciao ragazzi,
dimenticavo di dire che la formula che ho usato è stata questa:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(REGISTRO!$C$2:$C$500="pippo");--(TESTO(REGISTRO!$E$2:$E$500;"mmm")="feb");(REGISTRO!$H$2:$H$500))

...


Penso tu possa migliorarla se invece di ="pippo" ci mettessi il riferimento cella sulla testata del foglio riepilogo (dove c'è scritto pippo) otterresti una formula valida anche per pluto e paperino (in quanto valore relativo cella) e... con lo stesso ragionamento puoi sostituire ="feb" con valore cella relativa ai mesi (attento alle maiuscole, usa semmai MINUSC(B3) se B3 corrisponde a FEB)
fai sapere
ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi biancocandido55 » 20/05/09 08:16

Ciao Flash,
ti ringrazio dell'ulteriore suggerimento, quindi, scritto in questa forma:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(REGISTRO!$C$2:$C$500=B1);--(TESTO(REGISTRO!$E$2:$E$500;"mmm")=A2);(REGISTRO!$H$2:$H$500))

oppure in questa:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(REGISTRO!$C$2:$C$500="pippo");--(TESTO(REGISTRO!$E$2:$E$500;"mmm")="feb");(REGISTRO!$H$2:$H$500))

l'importante è il risultato. :D :lol:
Come sempre, alla prossima,
ciao e grazie
biancocandido
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi Flash30005 » 20/05/09 08:33

biancocandido55 ha scritto:...oppure in questa:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(REGISTRO!$C$2:$C$500="pippo");--(TESTO(REGISTRO!$E$2:$E$500;"mmm")="feb");(REGISTRO!$H$2:$H$500))

l'importante è il risultato. :D :lol:

In questa sei costretto a variare il nome "pippo" quando trascini la formula nella colonna a fianco e a cambiare "feb" quando trascini la formula verso il basso, nell'altro caso no ;)

ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi Anthony47 » 20/05/09 11:57

Ma allora sarebbe meglio
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(REGISTRO!$C$2:$C$500=B$1);--(TESTO(REGISTRO!$E$2:$E$500;"mmm")=$A2);(REGISTRO!$H$2:$H$500))
In questo modo, scritta la formula in B2 la puoi copiare "in lungo e in largo" senza bisogno di modifiche.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: MATR.SOMMA.PRODOTTO oppure SOMMA.SE

Postdi biancocandido55 » 20/05/09 12:54

Ciao ragazzi,
Ecco, così abbiamo accontentato tutti, la stessa formula, ripetuta più volte, ma ogni volta con piccole variazioni di parametro, per tutte le esigenze ;) .
Ora posso affermare che, questa formula, MATR.SOMMA.PRODOTTO è veramente un portento. :lol: :lol:
un saluto ed un abbraccio
ciao
biancocandido Immagine
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15


Torna a Applicazioni Office Windows


Topic correlati a "MATR.SOMMA.PRODOTTO oppure SOMMA.SE":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti