Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Excel cerca e sostituisci automatico

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Excel cerca e sostituisci automatico

Postdi piciui » 05/05/09 10:50

Salve a tutti,

dovrei realizzare, come da titolo, una funzione che cerchie sostituisca automaticamente tra 2 fogli.
Esempio:

Foglio 1

A1 = 0001
B1 = 10
A2 = 0002
B2 = 1212
A3= 0004
B3 = 1524

Foglio 2

A1 = 0002
A2 = 0001
A3 = 0004

In pratica sul foglio 2, i rispettivi valori dovrebbero essere sostituiti con il valore presente nella cella B del foglio 1, ovvero:

A1 = 1212
A2 = 10
A3 = 1524

Grazie


In pratica nel secondo foglio, A1 dovrebbe diventare 10 ovvero il valore di B1 visto che
piciui
Newbie
 
Post: 1
Iscritto il: 05/05/09 10:43

Sponsor
 

Re: Excel cerca e sostituisci automatico

Postdi Anthony47 » 05/05/09 21:08

Ciao piciui e benvenuto nel forum.
Non sei torinese, vero?
Venendo alla tua domanda, il mio suggerimento e' che ti riporti in col B di Foglio2 il valore che corrisponde a quanto hai in col A, usando la funzione Cerca.Vert; ad esempio, in B1 (di Foglio2):
Codice: Seleziona tutto
=CERCA.VERT(A1;Foglio1!A:B;2;0)
Poi copi B1 in verticale quanto basta.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "Excel cerca e sostituisci automatico":


Chi c’è in linea

Visitano il forum: Nessuno e 10 ospiti