Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

EXCEL : ignora codice errore su =SOMMA()

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

EXCEL : ignora codice errore su =SOMMA()

Postdi alessandro75 » 10/04/09 21:11

Salve ...
ho una formula =SOMMA(A2+C2+E2+H2+J2),in una o più celle potrebbero apparire codici di errore, tipo #N/D o #Valore!, dato che a loro volta contengono delle formule, le quali potrebbero darmi come risultato un codice errore.
Chiedo : è possibile avere la somma delle sole celle con un valore numerico ed ignorare quelle che danno il codice di errore ?
Attualmente con la formula di esempio di cui sopra, il risultato è #N/D.
Grazie :)
alessandro75
Newbie
 
Post: 6
Iscritto il: 25/03/09 21:35

Sponsor
 

Re: EXCEL : ignora codice errore su =SOMMA()

Postdi pietrol » 10/04/09 21:44

Ciao alessandro75
di solito questi problemi si risolvono "a monte" cioè nelle celle che poi devono essere sommate, evitando che restituiscano un codice di errore.
Di solito i valori #N/D! derivino da formule com il CERCA.VERT., supponiamo che la tua formula sia
=CERCA.VERT(H1;C1:D100;2;FALSO)
modificala in
=SE(VAL.ERRORE(CERCA.VERT(H1;C1:D100;2;FALSO));0;CERCA.VERT(H1;C1:D100;2;FALSO))
in questo modo invece di un errore restituirà 0 (zero) e la somma finale non avrà problemi.

Se non sono stato chiaro, fammi sapere.

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: EXCEL : ignora codice errore su =SOMMA()

Postdi alessandro75 » 14/04/09 17:22

grazie sei stato chiarissimo..... il problema è che, se fosse possibile non vorrei mettermi in un ginepraio di parecchie decine di formule, così visto che la modifica che devo apportare era su un altro foglio che riprendeva quei risultati, mi sembrava più semplice (nella sfera del possibile :) ) ignorare '' L'errore '' per poter proseguire.
Anche perchè un valore 0 in realtà con le formule attuali mi darebbe risultato 10, sarebbe meglio allora che desse una cella '' pulita '' .
alessandro75
Newbie
 
Post: 6
Iscritto il: 25/03/09 21:35

Re: EXCEL : ignora codice errore su =SOMMA()

Postdi Anthony47 » 14/04/09 18:20

Potresti fare cosi':
-porti le celle sparse che vuoi sommare in un range di celle adiacenti, diciamo B10:B20
-poi userai la seguente formula:
Codice: Seleziona tutto
=SOMMA(SE(VAL.NUMERO(B10:B20);B10:B20;0))
Confermerai la formula con Contr-Maiusc-Enter NON con solo Enter.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: EXCEL : ignora codice errore su =SOMMA()

Postdi ricky53 » 14/04/09 19:01

Ciao Alessandro,
premesso che la soluzione al tuo problema l'hai ottenuta da Anthony, a mio avviso ritengo tu debba seguire il consiglio di Pietrol e rimuovere "a monte" la causa dell'errore.
Non è "pulito" (intendi "E' Errato") avere celle con "#N/D" perchè le stesse celle possono essere utilizzate in altre formule oltre quelle che Anthony ti ha risolto ed avresti lo stesso problema.
Che formule hai nelle celle con errore?
Anche l'utilizzo di "VAL.NON.DISP" può esserti di aiuto.
Spesso fare una "pulizia" nelle formule ti agevola e semplifica il futuro ...

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: EXCEL : ignora codice errore su =SOMMA()

Postdi marcoc » 16/04/09 10:21

ciao a tutti,
ho letto questo interessante post e mi sono ritrovato anche io lo stesso problema.
La differenza è che a me #N/D esce nelle matrici somma prodotto; si può rimediare in questo caso?
la mia formula è questa:
=MATR.SOMMA.PRODOTTO(--('foglio1'!$A$3:$A$6572=$A4);--('foglio1'!$D$3:$D$6572=D$3);('foglio1'!$S$3:$S$6572))
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: EXCEL : ignora codice errore su =SOMMA()

Postdi ricky53 » 16/04/09 17:38

Ciao,
l'intervallo di dati (colonna "A", "D" ed "S") che utilizzi nella matr.somma.prodotto è tutto "buono" ossia senza "#N/D"?
Non avendo i dati non ho controllato l'esattezza delle tua formula ma a "naso" non mi convince quanto hai scritto.
VERIFICALO!
Un esempio dei dati contenuti lo puoi inviare?

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: EXCEL : ignora codice errore su =SOMMA()

Postdi ricky53 » 16/04/09 23:33

Ciao,
forse è meglio inserire una nuova discussione per non confondere gli altri utenti.

Ciao da Ricky53
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W7; Office 2003-10-13-16
Avatar utente
ricky53
Utente Senior
 
Post: 4223
Iscritto il: 11/04/09 19:29
Località: Italia

Re: EXCEL : ignora codice errore su =SOMMA()

Postdi Anthony47 » 17/04/09 00:16

La precedente discussione con Alessandro direi che e' chiusa, si puo' continuare accodando.
Comunque direi che l' ipotesi di Ricky e' quella piu' probabile: hai errori nelle celle indirizzate. Tecnicamente potresti ignorare gli errori con una formula con questa sintassi:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(Se(Val.errore('foglio1'!$A$3:$A$6572);0; 'foglio1'!$A$3:$A$6572)=$A4); idem; idem)
Da confermare con Contr-Maiusc-Enter.
Ma ha senso fare un totale in presenza di errori nella catena?

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "EXCEL : ignora codice errore su =SOMMA()":


Chi c’è in linea

Visitano il forum: Nessuno e 19 ospiti