Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Importo esatto con arrotondamento

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Importo esatto con arrotondamento

Postdi Cedamido » 02/04/09 21:56

63,73 x 0,62 x 26,58 = 1.050,24

63,73 x 0,6229 x 26,58 = 1.055,16

Dopo aver creato un filtro con convalida elenco vorrei essere aiutato ad automatizzare le moltiplicazioni degli importi finali il primo importo deve dare 1.050,24 l'altro 1.055,16.
Questi due importi sono dimostrativi, nel senso che l'automatismo dovrebbe funzionare con qualsiasi importo.
Nel filtro la descrizione è la seguente: arrotonda a due decimali e arrotonda a quattro decimali.
Grazie, Peppino
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Sponsor
 

Re: Importo esatto con arrotondamento

Postdi tutamimetica » 03/04/09 12:00

Ciao Peppino
puoi arrotondare il valore A1 utilizzando la funzione
=ARROTONDA(A1;E1) ove in E1 puo inserire il numero di decimali desiderati.
Cioè se in A1 c'è 123,45666 e in E1=1 il risultato è 123,4
se in E2=2 il risultato è 123,45
se in E3=3 il risultato è 123,457
se il vuoi il risultato 123,456 utilizzi invece TRONCA(A1;E1)
Ciao tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: Importo esatto con arrotondamento

Postdi Cedamido » 03/04/09 18:23

Ciao Tuta, Ti ringrazio per la risposta. Mi sono espresso male, intendevo scrivere nel post precedente come procedere una volta aperto il filtro all'interno del quale vi sono due domande:" vuoi arrotondare a due decimali" - "vuoi arrotondare a quattro decimali" la casella dove è impresso 0,6229 dovrebbe eseguire l'operazione in automatico a quattro decimali con prodotto finale 1.055,16, la casella dove è impresso 0,62 dovrebbe eseguirlo a due decimali con prodotto finale 1.050,24.
Grazie Peppino
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Importo esatto con arrotondamento

Postdi pietrol » 03/04/09 23:04

Ciao Cedamido
la cosa più semplice che puoi fare è scrivere in una cella, poniamo H2, 2 o 4 e fare riferimento a quella nelle formule di arrotondamento, che è poi quello che aveva scritto tutamimetica(ciao).
Se proprio vuoi puoi aggiungere per H2 una regola di convalida:
Menu Dati/Convalida, in Criteri di Convalida,Consenti scegli "Elenco", in "Origine" scrivi "2;4" (senza virgolette) .
poi nelle formule di arrotondamento invece di scrivere 2 o 4 scriverai H2.

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: Importo esatto con arrotondamento

Postdi Cedamido » 04/04/09 16:24

Ringrazio entrambi per le risposte, ho eseguito le istruzioni impartite e ci sono riuscito.
Ciao Peppino
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26


Torna a Applicazioni Office Windows


Topic correlati a "Importo esatto con arrotondamento":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti