Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] perdita riferimenti?

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] perdita riferimenti?

Postdi beaumont » 04/03/09 17:33

Ciao a tutti!

ho realizzato un grafico dinamico, secondo quanto descritto qui.

Quando inserisco la stringa =nomefile.xls!nome nel campo valori di origine dati grafico la visualizzazione è corretta, purtroppo, quando riapro il grafico salvato, qualcosa non va e nello stesso campo viene riportato =[0]!nome.
La cosa strana è che non lo fa per tutti i grafici e per tutti i nomi... mi sembra 100% random!!

Grazie per l'eventuale aiuto
beaumont
Newbie
 
Post: 2
Iscritto il: 04/03/09 17:31

Sponsor
 

Re: [excel] perdita riferimenti?

Postdi Anthony47 » 04/03/09 19:48

Ciao beaumont e benvenuto nel forum.
Non ho trovato nell' articolo il momento in cui dice di inserire =nomefile.xls!; puoi descrivere che cosa fai tu in un caso che non ti funziona?

Ciao, ti aspettiamo.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [excel] perdita riferimenti?

Postdi beaumont » 05/03/09 11:06

ciao Anthony e grazie del benvenuto!

la formula con la funzione scarto mi seleziona un intervallo di celle, qualora si aggiunga una cella (che importo da un db), la funzione me la include dinamicamente nell'intervallo. Fin qui tutto ok.

Il problema è quando voglio graficare le informazioni, e quindi inserire come serie del grafico quell'intervallo che mi seleziona scarto... se ci fai caso nell'ultimo screenshot dell'articolo nel campo "valori:" viene inserito proprio il =nomefile.xls!nomedefinito

questa cosa l'ho provata e funziona perfettamente, e la ripeto anche per "etichette valori". Purtroppo quando vado a riaprire l'xls salvato, alcuni intervalli vengono aggiornati correttamente, altri no, e nel campo valori, invece di visualizzare un intervallo del tipo =Foglio1!$G$2:$G$32, viene visualizzato =[0]!nomedefinito

Naturalmente lo scope dei nomi è esteso a tutta la cartella.

Spero di essere stato più chiaro, grazie!

Beaumont
beaumont
Newbie
 
Post: 2
Iscritto il: 04/03/09 17:31

Re: [excel] perdita riferimenti?

Postdi Anthony47 » 05/03/09 12:46

Se si tratta di leggere e commentare una lezione di Microsoft sinceramente ne vorrei fare a meno.
Se il problema e' aiutarti a fare una cosa, allora dovresti spiegare che cosa vorresti fare, come lo fai, che cosa invece ti succede.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[excel] perdita riferimenti?":


Chi c’è in linea

Visitano il forum: Nessuno e 18 ospiti