Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

macro per ricerca date da ... a...

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Re: macro per ricerca date da ... a...

Postdi Anthony47 » 26/02/09 14:05

Prova cosi':
-togli il filtro automatico che hai (menu /dati /Filtro /togli Filtro automatico)
-poi cambi cosi':
Codice: Seleziona tutto
Range("C2:C2000").Select     '<<<< INVECE di Range("C:C")...
Se hai piu' di 2000 righe allunga la selezione.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Sponsor
 

Re: macro per ricerca date da ... a...

Postdi martin » 26/02/09 15:14

:lol:
perfetto ........
quindi riassumendo
totali in testa alle colonne su primo rigo e accanto celle di ricerca con macro filtro comandato da un pulsante
altro pulsante che disattiva filtro e torna alla lista precedente quando voglio funziona da bomba :D
ciao, di nuovo grazie a tutti voi e alle prossime
martin
Utente Senior
 
Post: 108
Iscritto il: 03/12/08 17:04

Re: macro per ricerca date da ... a...

Postdi stirner » 12/03/09 16:48

Stamattina ho dato uno sguardo veloce a questo vecchio Topic e scusandomi (da neofita) con i maestri che mi hanno preceduto, vorrei proporti di modificare l’impostazione della tua tabella e conseguentemente adattare come da mio allegato.
Le formule inserite nel mio file:
In F2
Codice: Seleziona tutto
=SOMMA(E:E)

In M2
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(1*($A:$A>=P1)*($A:$A<=Q1);$E:$E)

IN H2
Codice: Seleziona tutto
=INDICE(A$2:A$20;PICCOLO(SE(($A$2:$A$20>=$P$1)*($A$2:$A$20<=$Q$1);RIF.RIGA($A$2:$A$20)-1;"");RIF.RIGA(A1)))
inserita matricialmente (Ctrl+Shift+Invio), trascinando a dx fino a L2 e susseguentemente in basso.
Naturalmente adatta ai tuoi intervalli.
Ancora due accorgimenti:
1° Fare molto attenzione alla formattazione delle colonne. In ogni caso quando trascinerai INDICE avrai una formattazione disorganica … adatta di conseguenza.
2° Ho anche considerato che la colonna *Scarico* contenesse dei valori. In caso contenesse una formula, ti sarà facile adattare.
Spero comunque che grazie ai precedenti suggerimenti tu abbia già risolto.

Stirner
Allegati

[L’estensione zip è stata disattivata e non puó essere visualizzata.]

--------
Stirner
stirner
Utente Junior
 
Post: 79
Iscritto il: 14/02/09 15:13

Re: macro per ricerca date da ... a...

Postdi martin » 14/03/09 14:42

stirner ha scritto:Stamattina ho dato uno sguardo veloce a questo vecchio Topic e scusandomi (da neofita) con i maestri che mi hanno preceduto, vorrei proporti di modificare l’impostazione della tua tabella e conseguentemente adattare come da mio allegato.
Le formule inserite nel mio file:
In F2
Codice: Seleziona tutto
=SOMMA(E:E)

In M2
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(1*($A:$A>=P1)*($A:$A<=Q1);$E:$E)

IN H2
Codice: Seleziona tutto
=INDICE(A$2:A$20;PICCOLO(SE(($A$2:$A$20>=$P$1)*($A$2:$A$20<=$Q$1);RIF.RIGA($A$2:$A$20)-1;"");RIF.RIGA(A1)))
inserita matricialmente (Ctrl+Shift+Invio), trascinando a dx fino a L2 e susseguentemente in basso.
Naturalmente adatta ai tuoi intervalli.
Ancora due accorgimenti:
1° Fare molto attenzione alla formattazione delle colonne. In ogni caso quando trascinerai INDICE avrai una formattazione disorganica … adatta di conseguenza.
2° Ho anche considerato che la colonna *Scarico* contenesse dei valori. In caso contenesse una formula, ti sarà facile adattare.
Spero comunque che grazie ai precedenti suggerimenti tu abbia già risolto.

Stirner



ciao stirner

ottimo era una delle soluzioni che cercavo senza macro
funziona ok
grazie :lol:
martin
Utente Senior
 
Post: 108
Iscritto il: 03/12/08 17:04

Re: macro per ricerca date da ... a...

Postdi stirner » 14/03/09 17:18

Grazie a te per il riscontro.
Ciao

Stirner
--------
Stirner
stirner
Utente Junior
 
Post: 79
Iscritto il: 14/02/09 15:13

Precedente

Torna a Applicazioni Office Windows


Topic correlati a "macro per ricerca date da ... a...":


Chi c’è in linea

Visitano il forum: patel e 4 ospiti