Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL] RIF. RIGA variabile

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL] RIF. RIGA variabile

Postdi stirner » 15/02/09 14:55

Ciao a tutti,
da A2 a scendere ho date sequenziali (+1); da B2 a scendere devo inserire dei valori (Km rilevati) in corrispondenza di A2 (cioè quando vado a fare benzina). Naturalmente le date, quando vado a fare benzina, sono casuali e, in orrispondenza, colonna B,inserisco i Km rilevati. Vorrei nella colonna C a partire dal secondo rilevamento in poi il valore dei Km effettuati e così in poi la differenza (Km effettuati) fra terzo e secondo, fra quarto e terzo e così via. Se gli
intervalli fossero regolari forse me la saprei cavare ma con la variabilità non riesco a raccapezzarmi o mi sfugge qualcosa di semplice
EXCEL 2007
Grazie.
Stirner
--------
Stirner
stirner
Utente Junior
 
Post: 79
Iscritto il: 14/02/09 15:13

Sponsor
 

Re: [EXCEL] RIF. RIGA variabile

Postdi pietrol » 15/02/09 16:52

Ciao stirner

formula da inserire in C3

Codice: Seleziona tutto
=SE(B3>0;B3-MAX(B2:$B$2);"")

e poi la copi su tutta la colonna

Ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: [EXCEL] RIF. RIGA variabile

Postdi stirner » 15/02/09 17:07

Ciao stirner
formula da inserire in C3
=SE(B3>0;B3-MAX(B2:$B$2);"")
e poi la copi su tutta la colonna
************************************
Ciao pietrol
Forse è meglio apportare una piccola modifica:
=SE(B3>0;B3-MAX($B$2:B2);"")
Altrimenti con la tua i Km parziali appiaono nella riga successiva al giorno quando faccio benzina e non in corrispondenza.
Grazie comunque. Questa l'avevo sotto gli occhi ma non riuscivo a vederla.
Altre soluzioni?

Stirner
--------
Stirner
stirner
Utente Junior
 
Post: 79
Iscritto il: 14/02/09 15:13

Re: [EXCEL] RIF. RIGA variabile

Postdi stirner » 15/02/09 17:19

stirner ha scritto:Ciao stirner
formula da inserire in C3
=SE(B3>0;B3-MAX(B2:$B$2);"")
e poi la copi su tutta la colonna
************************************
Ciao pietrol
Forse è meglio apportare una piccola modifica:
=SE(B3>0;B3-MAX($B$2:B2);"")
Altrimenti con la tua i Km parziali appiaono nella riga successiva al giorno quando faccio benzina e non in corrispondenza.
Grazie comunque. Questa l'avevo sotto gli occhi ma non riuscivo a vederla.
Altre soluzioni?
***************************************
Stirner

Scusami è la stessa cosa: avevo sbagliato inserimento cella.
Soluzioni diverse?
Stirner
--------
Stirner
stirner
Utente Junior
 
Post: 79
Iscritto il: 14/02/09 15:13

Re: [EXCEL] RIF. RIGA variabile

Postdi Anthony47 » 16/02/09 03:04

Ciao a tutti, e benvenuto nel forum a stirner.
Forse in C3
Codice: Seleziona tutto
=SE(B2>0;B2-MAX(B1:$B$2);"")

Copiare poi verso il basso.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] RIF. RIGA variabile

Postdi stirner » 16/02/09 18:42

[EXCEL]
Piacere di conoscerti Anthony!
Ti invio in allegato un stralcio di file con le soluzioni proposte sia da Pietrol sia da te stesso.
Tieni conto che è solo un esempio. In effetti la colonna delle date parte dal primo gennaio e finisce con il 31 dicembre ed altresì i Km non sono reali ma simulati sia nel valore che nella posizione. Questa non è conditio sine qua no
invece avete entrambi presunto che io necessariamente avessi valori di Km iniziali in corrispondenza, per stare all'esempio in allegato, già il 1° gennaio ma io avrei potuto far benzina a partire per esempio dal 5 gennaio. Colpa mia naturalmente di avervi fuorviato con la mia imprecisa sintassi.
In conclusione, per far funzionare Pietrol devo inserire necessariamente nella riga sottostante il primo valore dei Km di partenza. Per far funzionare Anthony devo inserire nella stessa riga dei Km di partenza.
Prova a cancellare i Km di partenza in corrispondenza del 1° gennaio e vedi cosa succede.
Insomma io vorrei cominciare ad inserire una formula in C1 che, trascinando in basso, mi dia quanto mi occorre ANCHE SE IN B1 ON C'è ALCUN VALORE. Vorrei quindi una formula generazzita e generalizzante.
Grazie per l'attenzione.
Ciao a te e Pietrol.

Stirner
stirner
Utente Junior
 
Post: 79
Iscritto il: 14/02/09 15:13

Re: [EXCEL] RIF. RIGA variabile

Postdi Anthony47 » 16/02/09 19:18

Lo stralcio del file non era allegato, ma credo di aver capito.
Prova in C2
Codice: Seleziona tutto
=SE(VAL.ERRORE(CONFRONTA(B2-1;B:B));"";B2-SCARTO(B$1;CONFRONTA(B2-1;B:B)-1;0))
Poi copia verso il basso qb. Richiede che i km siano crescenti, se sbagli tu sbaglia anche la formula.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] RIF. RIGA variabile

Postdi stirner » 16/02/09 19:54

Anthony scrive:
Lo stralcio del file non era allegato, ma credo di aver capito.
Prova in C2 =SE(VAL.ERRORE(CONFRONTA(B2-1;B:B));"";B2-SCARTO(B$1;CONFRONTA(B2-1;B:B)-1;0))
Poi copia verso il basso qb. Richiede che i km siano crescenti, se sbagli tu sbaglia anche la formula.

Ciao
************************************
Adesso ci siamo!
Provo di nuovo a spedire l'allegato (non conosco ancora molto bene le procedure di questo nobilissimo forum).
Io facccio: Invia allegato poi "sfoglio" e apro il file quindi Invia.
Se non arriva spiegami bene la procedura.Grazie.
Un saluto a te e Pietrol

stirner
stirner
Utente Junior
 
Post: 79
Iscritto il: 14/02/09 15:13

Re: [EXCEL] RIF. RIGA variabile

Postdi stirner » 17/02/09 06:10

provo ancora
--------
Stirner
stirner
Utente Junior
 
Post: 79
Iscritto il: 14/02/09 15:13

Re: [EXCEL] RIF. RIGA variabile

Postdi stirner » 17/02/09 06:12

niente da fare
--------
Stirner
stirner
Utente Junior
 
Post: 79
Iscritto il: 14/02/09 15:13

Re: [EXCEL] RIF. RIGA variabile

Postdi zem » 17/02/09 06:31

per spedire il file devi zipparlo...
ciao
Avatar utente
zem
Utente Junior
 
Post: 45
Iscritto il: 11/02/09 00:02

Re: [EXCEL] RIF. RIGA variabile

Postdi Flash30005 » 17/02/09 14:50

Per Stiner
Come dice Zem il file excel deve essere compresso in archivio (.rar o .zip)
1) Premi "Sfoglia" (hai la possibilità di indicare il percorso del file nel tuo Pc.)
2) Premi "Aggiungi file" (pulsante a destra)
3) Prima di inviare Inserisci una parola o frase nel Commento File
4) Premi "Anteprima" per vedere se è tutto a posto (dovresti vedere anche il file allegato oltre al tuo post)
5) Premi "Invia"


Ciao


P.s. I termini racchiusi tra i due apici "..." sono dei pulsanti
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: [EXCEL] RIF. RIGA variabile

Postdi stirner » 17/02/09 22:01

provo
Allegati

[L’estensione zip è stata disattivata e non puó essere visualizzata.]

--------
Stirner
stirner
Utente Junior
 
Post: 79
Iscritto il: 14/02/09 15:13

Re: [EXCEL] RIF. RIGA variabile

Postdi stirner » 17/02/09 22:31

Adesso reinvio il file con le formule. Provate a cancellare il valore 14900 e vedrete che la soluzione NUOVA Anthony è quella corrispondente alle mie esigenze. Grazie a tutti quelli che hanno partecipato
Allegati

[L’estensione zip è stata disattivata e non puó essere visualizzata.]

--------
Stirner
stirner
Utente Junior
 
Post: 79
Iscritto il: 14/02/09 15:13


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL] RIF. RIGA variabile":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti