Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Automatismo tabella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Automatismo tabella

Postdi Cedamido » 12/02/09 22:44

Cortesemente, forse chiedo troppo, vorrei automatizzare il file allegato nel senso che allorquando digito i mesi inferiori a 31 giorni non vanno via le celle di conseguenza somma i giorni F G S come se fossero sempre di 31 giorni.
Grazie a Tutti
Peppino
Allegati

[L’estensione rar è stata disattivata e non puó essere visualizzata.]

excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Sponsor
 

Re: Automatismo tabella

Postdi pietrol » 13/02/09 02:41

Ciao Cedamido
credo di avere capito che vorresti che, nelle celle AI8:AK8, vengano sommate le F, G ed S solo se esiste il giorno nelle celle sopra.

Inserisci questa formula in AI8 e poi trascinala nelle altre due celle

Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--($D$8:$AH$8=AI$7);--($D$7:$AH$7<>""))


Fammi sapere se ho capito bene.

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: Automatismo tabella

Postdi Cedamido » 13/02/09 15:04

Pietro, Ti ringrazio, ho seguito le Tue istruzione le somme vanno bene.Però quando il mese è inferiore a 31 giorni le colonne non vanno via, rimanendo le colonne restano visibili F G S senza essere sommati.
Esempio: digito l'anno 2009 digito il mese di febbraio somma 28 giorni distinguendo la quantità di F G S ma rimangono le colonne. Si può risolvere? Ciao Peppino
excel 2003
Cedamido
Utente Senior
 
Post: 234
Iscritto il: 17/08/08 23:26

Re: Automatismo tabella

Postdi pietrol » 13/02/09 15:20

Puoi usare una funzione SE
in AF8 per esempio

Codice: Seleziona tutto
=SE(AF7="";"";"G")


eccetera

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34


Torna a Applicazioni Office Windows


Topic correlati a "Automatismo tabella":


Chi c’è in linea

Visitano il forum: alfrimpa e 4 ospiti