Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

SE(la cella non comprende una certa parola) ALLORA(scrivi)

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi marcoc » 04/02/09 14:55

ciao a tutti,
ho un'altra domanda x voi...
ho bisogno una formula che comprenda nella dicitura la condizione "che non contiene la parola "aaa" "
ho provato con
=SE((A1<>"*aaa*");B1;"")
ma non è esatta.
sapete aiutarmi?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi biancocandido55 » 04/02/09 15:04

Ciao marcoc,
prova a riscrivere la formula così
=SE(A1<>"aaa";B1;"")
.
ciao e fammi sapere se ti va bene.
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15

Re: SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi marcoc » 04/02/09 15:10

la formula che hai scritto dice che se A1 [u]è diverso [/u]da "aaa" allora scrivi B1.
a me serve che dica che se A1 [u]non contiene [/u]"aaa" allora scrivi B1, per quello che avevo provato a mettere gli asterischi.
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi Flash30005 » 04/02/09 15:23

La formula di Marcoc va bene se il testo in A1 è identico ad aaa
ma non se è contenuto in A1 es. sgaftaaaxcv
Ho testato questa formula e funziona sia se il testo sta all'inizio, in mezzo o alla fine della parola in A1
vedi se va bene
Codice: Seleziona tutto
=SE(VAL.ERRORE(RICERCA("aaa";A1;1)="VERO");"";B1)


Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi biancocandido55 » 04/02/09 15:28

Ok, marcoc,
non sò se lo hai già fatto, prova ad usare le seguenti funzioni:
funzione IDENTICO()
funzione STRINGA.ESTRAI()
Funzione RICERCA().
nidificandole nella finzione SE().
ciao
biancocandido55
Utente Senior
 
Post: 305
Iscritto il: 03/03/06 10:15

Re: SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi Flash30005 » 04/02/09 15:32

Errata Corrige
nel mio post precedente intendevo dire
la formula di Biancocandido va bene se...
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi marcoc » 04/02/09 18:14

la formula
SE(VAL.ERRORE(RICERCA("aaa";A1;1)="VERO");"";B1)
va bene se ho una sola condizione...

nel mio caso, anche se non l'ho detto prima, ho 2 condizioni, e facendo
=SE(VAL.ERRORE(RICERCA("aaa";A1;1)="VERO");B1;SE(VAL.ERRORE(RICERCA("bbb";B1;1)="VERO");"";B1))
ottengo
"" se la cella contiene "aaa" - e ok
B1 se la cella non contiene "aaa" - e ok
B1 anche se la cella contiene "bbb", poichè comunque non contiene "aaa"
B1 se la cella è vuota

in pratica non differenzia il caso in cui la cella contiene "bbb" dal caso di celle vuote o di celle con altro testo.

dove sbaglio?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi Anthony47 » 04/02/09 20:13

nel mio caso, anche se non l'ho detto prima, ho 2 condizioni
Se si esprime chiaramente il problema all' inizio ci sono piu' chances di avere la soluzione e si evita di far lavorare inutilmente i volontari...
Lo scrivo a marcoc ma vale per tutti.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi marcoc » 04/02/09 21:27

ok, ma sinceramente pensavo che trovata la formula fosse poi più semplice inserirla in un'altra sottoforma di condizione
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi pietrol » 05/02/09 01:14

Ciao marcoc

ok, ma sinceramente pensavo che trovata la formula fosse poi più semplice inserirla in un'altra sottoforma di condizione


è vero ma bisogna farlo nella maniera corretta, in questo caso devi verificare contemporaneamente due condizioni, per cui invece di nidificare un SE è meglio usare un E in questo modo:

Codice: Seleziona tutto

=SE(E(VAL.ERRORE(RICERCA("aaa";A1;1)=VERO);VAL.ERRORE(RICERCA("bbb";A1;1)=VERO));B1;"")



la funzione E(condizione1;condizione2;ecc.) restituisce VERO solo se restituiscono VERO tutti i test inglobati

ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi marcoc » 05/02/09 10:03

grazie pietrol la lormula funziona, non so perchè mi ero incartato scrivendo la formula che ho messo 2 post fa...
sorge ora un altro "problema":
nella colonna di fianco devo invece mettere i valori corrspondenti alle "aaa", prima esclusi.
Scrivendo:
=SE((VAL.ERRORE(RICERCA("aaa";A1;1)=VERO));"";B13)
mi trova i valori corretti in corrispondenza degli "aaa", ma mi dà ZERO, sugli altri che non lo contengono.
Avendo bisogno di fare poi la media della colonna, mi sballa tutto.
Idem se al posto di "" inserisco ad esempio "-" o "x"
che devo scrivere?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Re: SE(la cella non comprende una certa parola) ALLORA(scrivi)

Postdi Flash30005 » 05/02/09 12:03

Marcoc
ricrontrolla bene, perché con questa formula
Codice: Seleziona tutto
=SE((VAL.ERRORE(RICERCA("aaa";A1;1)=VERO));"";B1)


non avrai mai il valore 0 ma una cella vuota pertanto la media è corretta

Ho fatto qeuesta prova inserendo da
A1 a A18 delle parole contenenti "aaa" solo in
A1,A3,A5,A7,A9,A11.A13,A15,A17
da B1 a B18 ho inserito i numeri rispettivamente da 1 a 18
in C1 ho messo la formula postata nel codice
trascinando da C1 a C18 ottengo solo i valori
1,3,5,7,9,11,13,15,17, tutte le altre celle sono vuote
mettendo la formula
Codice: Seleziona tutto
=MEDIA(C1:C18)

in C20 ottengo il valore corretto 9
in quanto la somma dei valori è 81 diviso 9 (numero dei valori) ho la media = 9
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-


Torna a Applicazioni Office Windows


Topic correlati a "SE(la cella non comprende una certa parola) ALLORA(scrivi)":


Chi c’è in linea

Visitano il forum: patel e 4 ospiti