Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

cerca.vert con 2 condizioni

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

cerca.vert con 2 condizioni

Postdi marcoc » 02/02/09 15:09

ciao a tutti,
è possibile scrivere una formula simile al cerca.vert che tenga presente 2 condizioni?
in pratica, mi serve cercare il valore in colonna X sulla riga in corrispondenza di un dato valore in colonna A e di un altro dato valore in colonna B.
che dite?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Re: cerca.vert con 2 condizioni

Postdi Flash30005 » 02/02/09 15:35

Un sistema abbastanza semplice è:
utilizzare una terza colonna che crea un valore univoco di A e B
In generale (per testo e/o numero) Col C =A&B che userai come indice (1 o Col1) della matrice nella quale cercare il valore.
Se i valori in A e B sono numerici, in C, potresti mettere il valore A moltiplicato n volte (10,100,1000,10000 etc) in funzione del max valore di B e, quindi, aggiungere B (se ciò è possibile).
es. Se il valore max di B è 870 e A qualsiasi valore (es.37)
in C =A*1000+B = 37870 (valore univoco di A=37 e B=870) in effetti è come & ma il risultato, in questo caso, è numerico

Ciao
Flash
Win7 + Office 2010 Ita
"Fotografica" al servizio dell'immagine

Ottime opportunità di lavoro (part-time o full-time) con guadagni immediati. Info in MP
Avatar utente
Flash30005
Moderatore
 
Post: 8460
Iscritto il: 27/09/07 11:44
Località: Roma +o-

Re: cerca.vert con 2 condizioni

Postdi Tribuno » 03/02/09 00:39

Ciao,

ammettendo di avere la tabella nel range A1:X23, in A25 il primo valore da cercare, in B25 il secondo valore da cercare:

=SE(CERCA.VERT(A25;A1:X23;2)=B25;CERCA.VERT(A25;A1:X23;24);"Falso")

Spero di aver ben interpretato.

Ciao
Tribuno
Avatar utente
Tribuno
Utente Senior
 
Post: 181
Iscritto il: 22/08/08 19:24

Re: cerca.vert con 2 condizioni

Postdi pietrol » 04/02/09 00:43

Ciao marcoc
secondo me una soluzione potrebbe essere questa:
avendo i dati in A3:X23 e i valori da cercare in colonna A e B rispettivamente in Z3 e AA3 la formula diventa
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--($A$3:$A$23=Z3);--(B$3:$B$23=AA3);($X$3:$X$23))


Attenzione, però, se i due valori si ripetono uguali in righe differenti il risultato sarà la somma delle corrispondenti celle nella colonna X.

Ciao
pietrol
il lupo ululà, il castello ululì
pietrol
Utente Senior
 
Post: 270
Iscritto il: 07/01/09 14:34

Re: cerca.vert con 2 condizioni

Postdi marcoc » 04/02/09 22:44

Grazie pietrol, è perfetta!
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano


Torna a Applicazioni Office Windows


Topic correlati a "cerca.vert con 2 condizioni":


Chi c’è in linea

Visitano il forum: Nessuno e 24 ospiti