Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Confronto caratteri fra due celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Confronto caratteri fra due celle

Postdi tutamimetica » 29/12/08 09:29

Nella cella A3 ho una parola esempio ABCDE (i caratteri sono sempre diversi, cioè non ci sono doppioni) e in B3 ho un'altra parola esempo ABCF, è possibile sapere quanti caratteri di B3 sono uguali ad A3, cioè il risultato della formula dovrebbe essere 3. Io non ci sono riuscito.
Grazie Tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Sponsor
 

Re: Confronto caratteri fra due celle

Postdi nerolubo85 » 29/12/08 12:00

Copiati queste formule nella celle della colonna D (che poi potrai nascondere):

D1: =SE(STRINGA.ESTRAI($B$3;1;1)<>"";TROVA(STRINGA.ESTRAI($B$3;1;1);$A$3);"")
D2: =SE(STRINGA.ESTRAI($B$3;2;1)<>"";TROVA(STRINGA.ESTRAI($B$3;2;1);$A$3);"")
D3: =SE(STRINGA.ESTRAI($B$3;3;1)<>"";TROVA(STRINGA.ESTRAI($B$3;3;1);$A$3);"")
D4: =SE(STRINGA.ESTRAI($B$3;4;1)<>"";TROVA(STRINGA.ESTRAI($B$3;4;1);$A$3);"")
D5: =SE(STRINGA.ESTRAI($B$3;5;1)<>"";TROVA(STRINGA.ESTRAI($B$3;5;1);$A$3);"")
D6: =SE(STRINGA.ESTRAI($B$3;6;1)<>"";TROVA(STRINGA.ESTRAI($B$3;6;1);$A$3);"")

Io ho presupposto un numero massimo di 6 caratteri inseribili nella cella B3, ma se ne devi poter inserire di più, puoi continuare a copiare la formula nelle celle seguenti, cambiando il valore dove necessario.
Poi devi copiare questa formula nella cella dove vuoi ottenere il risultato:

=CONTA.NUMERI(D1:D6)

Facci sapere se ci sono problemi, ciao.
nerolubo85
Utente Senior
 
Post: 124
Iscritto il: 04/12/05 11:33

Re: Confronto caratteri fra due celle

Postdi tutamimetica » 29/12/08 12:42

Prima di tutto grazie di avermi risposto.
Avevo risolto anch'io con una soluzione tipo la tua.
Purtroppo a volte mi capita di avere 15/16 caratteri da confrontare e questo mi crea qualche problema.
Speravo di risolvere con un'unica formula.
Comunque di nuovo grazie.
tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25

Re: Confronto caratteri fra due celle

Postdi Anthony47 » 29/12/08 15:55

Puoi condensare in una unica formula tipo matr.somma.prodotto:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--VAL.NUMERO(RICERCA(STRINGA.ESTRAI(A3;RIF.RIGA(INDIRETTO("1:"&LUNGHEZZA(A3)));1);B3)))

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Confronto caratteri fra due celle

Postdi nerolubo85 » 29/12/08 16:34

[quote="Anthony47"]Puoi condensare in una unica formula tipo matr.somma.prodotto:
[code]=MATR.SOMMA.PRODOTTO(--VAL.NUMERO(RICERCA(STRINGA.ESTRAI(A3;RIF.RIGA(INDIRETTO("1:"&LUNGHEZZA(A3)));1);B3)))
[/code]
Ciao.[/quote]


Ottima soluzione, che tra l'altro funziona anche se ci sono doppioni di caratteri. Complimenti.
nerolubo85
Utente Senior
 
Post: 124
Iscritto il: 04/12/05 11:33

Re: Confronto caratteri fra due celle

Postdi tutamimetica » 29/12/08 16:42

Grazie Anthony era proprio quello che mi ci voleva.
Perfetto. Grazie di nuovo.
Tuta
tutamimetica
Utente Senior
 
Post: 209
Iscritto il: 10/06/08 17:25


Torna a Applicazioni Office Windows


Topic correlati a "Confronto caratteri fra due celle":


Chi c’è in linea

Visitano il forum: Nessuno e 12 ospiti