Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL] MATR.SOMMA.PRODOTTO

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL] MATR.SOMMA.PRODOTTO

Postdi dipic » 13/09/08 15:07

Buongiorno a tutti...
Ho creato la seguente formula
=MATR.SOMMA.PRODOTTO(($B$3:$B$64="Uno")*($A$3:$A$64))
che funziona perfettamente

ma se voglio che il risultato venga prodotto in un'altro foglio?
la stessa formula con le matrici precedute dal nome foglio non funziona
=MATR.SOMMA.PRODOTTO((FOGLIO1!$B$3:$B$64="Uno")*(FOGLIO1!$A$3:$A$64)
neanche se uso i NOMI al posto delle matrici.

Grazie per qualsiasi suggerimento.
Avatar utente
dipic
Utente Junior
 
Post: 95
Iscritto il: 13/09/08 14:57
Località: Cormòns (I)

Sponsor
 

Re: [EXCEL] MATR.SOMMA.PRODOTTO

Postdi Anthony47 » 13/09/08 16:52

Ciao dipic, benvenuto nel forum; ti aspettavamo.
La formula deve funzionare e a me funziona. Fai questa prova: scrivi una formula che ti funziona, poi selezioni la cella, Contr-x (taglia), vai su un altro foglio, seleziona una cella vuota e incolla con Enter.

Perche' dici che non funziona? Ti da un qualche errore o non fa quello che vorresti? E usi la formula per alcolare il valore da inserire in una cella o in qualche altra condizione?
(ignoro la parentesi mancante sulla tua seconda formula, perche' quell' errore e' puntualmente segnalato col chiaro messaggio "manca una parentesi")

Ciao, fatti sentire.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] MATR.SOMMA.PRODOTTO

Postdi dipic » 14/09/08 09:18

Ho scoperto che la formula funziona perfettamente...
=MATR.SOMMA.PRODOTTO((foglio1!$D$3:$D$64="Uno")*(foglio!$A$3:$A$64 ))
l'errore è dovuto al fatto che in entrambi i range ho delle celle vuote che non posso riempire.
Come posso controllare la cella vuota ed escluderla dalla funzione?
Avatar utente
dipic
Utente Junior
 
Post: 95
Iscritto il: 13/09/08 14:57
Località: Cormòns (I)

Re: [EXCEL] MATR.SOMMA.PRODOTTO

Postdi Anthony47 » 14/09/08 10:30

Ciao,
Il problema e' nella colonna A, che in alcune celle contiene evidentemente dei valori non numerici (sarebbe Ok se la cella fosse vuota). Nel caso specifico comunque non hai bisogno di usare Matrice.Somma.Prodotto; infatti la tua operazione e' una Somma pura.
La puoi risolvere con la formula
Codice: Seleziona tutto
=SOMMA((Foglio1!$D$3:$D$64="Uno")*SE(VAL.ERRORE(VALORE(Foglio1!$A$3:$A$64));0;(Foglio1!$A$3:$A$64)))

che confermerai NON con Enter MA con Contr-Maiusc-Enter (vedrai la formula tra parentesi graffe).

Se devi per forza usare Matr.Somma.Prodotto (ad esempio perche' devi usare una seconda matrice di dati) allora posta ancora. Comunque fai sapere.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] MATR.SOMMA.PRODOTTO

Postdi Anthony47 » 14/09/08 11:27

Oppure, ancora piu' semplicemente com
=SOMMA.SE(Foglio1!$D$3:$D$64;"Uno";Foglio1!$A$3:$A$64)
(Qui basta il solo Enter)

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [EXCEL] MATR.SOMMA.PRODOTTO

Postdi dipic » 14/09/08 16:11

funziona perfettamente.... non capisco perchè mi ero intestardito con la formula inserita nel titolo.
Grazie 1.000
Avatar utente
dipic
Utente Junior
 
Post: 95
Iscritto il: 13/09/08 14:57
Località: Cormòns (I)


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL] MATR.SOMMA.PRODOTTO":


Chi c’è in linea

Visitano il forum: Anthony47 e 8 ospiti