Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

match tra 2 file excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

match tra 2 file excel

Postdi andrew298 » 05/07/08 16:52

Buonasera a tutti

Sono appena iscritto al forum , ed ho letto molti Topic per trovare soluzione al mio problema attuale in Excel senza riuscirvi.

Vengo al punto: Dovrei riuscire a creare un match tra 2 file .xls

Il primo contiene 2 colonne del tipo:

paola 5
maria 6
giovanni 23

Il secondo contiene altre 2 colonne del tipo:

apaola_pc 45
ggiovannig_pc 54
dmariaa_pc 44

L'obiettivo è di inserire una terza colonna nel primo file che "legga" il secondo file riportando in terza colonna i dati del secondo file. Il risultato dovrà essere

paola 5 45
maria 6 44
giovanni 23 54

L'unica formula che parzialmente sono riuscito a impostare è di inserire la formula (SOSTITUISCI(n.cella;"_pc";"")) nel secondo file per cercare la similitudine nei testi; ma mi sono arenato.
C'è qualche soluzione con qualche formula nidificata?

Grazie per il vostro aiuto
saluti
andrew298
Newbie
 
Post: 2
Iscritto il: 05/07/08 16:47

Sponsor
 

Re: match tra 2 file excel

Postdi Anthony47 » 06/07/08 17:47

Ciao Andrew e benvenuto nel forum.
Mi pare che tu abbia in mente regole alquanto flessibili per definire una uguaglianza tra il primo e il secondo file; perche' se (sembra che) tutti hanno un carattere di prefisso e un suffisso "_pc", alcuni hanno un carattere aggiuntivo di suffisso.
Puoi restringere le regole, o ti sta bene che "nando" e "ferdinando" siano intercambiabili?

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: match tra 2 file excel

Postdi andrew298 » 07/07/08 17:08

Buonasera Anthony

In effetti la mia necessità riguarda un file .xls costituito di 50 record al massimo dove il campo "nominativo" (più che nomi nella realtà sono cognomi..) del secondo file può essere caratterizzato da uno o più caratteri di prefisso e/o uno o più caratteri di suffisso successivo al nome.
Il campo "nominativo" (nella realtà cognomi; per cui l'intercanbiambilità da te correttamente ipotizzata, nella realtà ha scarsa possibilità di verificarsi) del primo file deve farmi da riferimento del confronto/match.

Grazie ancora per la cortesia e scusatemi per eventuali approssimazioni

saluti
andrew298
Newbie
 
Post: 2
Iscritto il: 05/07/08 16:47

Re: match tra 2 file excel

Postdi Anthony47 » 08/07/08 00:15

Con le approssimazioni del caso ti propongo questo procedimento:
-sul secondo file, quello con apaola_pc, ti fai una col D con la formula
Codice: Seleziona tutto
=STRINGA.ESTRAI(SOSTITUISCI(A1;"_pc";"");2;99)
poi riporti in col E il valore che hai gia' in B; basta la formula
Codice: Seleziona tutto
=B1

-copi queste formule in basso per quane righe di dati hai
-sul primo file, in col C usi la formula
Codice: Seleziona tutto
=CERCA.VERT(A1&"*";[file2.xls]Foglio1!$D:$E;2;0)

-in col D invece
Codice: Seleziona tutto
=CERCA.VERT(A1&"*";[file2.xls]Foglio1!$D:$E;1;0)

-copi le formule in basso per quante righe di dati hai
Ovviamente devi adattare le formule per riflettere nomi file e nomi fogli in uso.
In questo modo in col C dovresti avere il valore che cercavi, mentre in col D hai visibile il cognome del secondo foglio che e' stato associato al cognome attuale, per una verifica visiva.

Spero ti aiuti, ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13894
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "match tra 2 file excel":


Chi c’è in linea

Visitano il forum: Nessuno e 13 ospiti