Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Aiuto su funzione CONTA

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Aiuto su funzione CONTA

Postdi dambro82 » 30/01/08 14:55

Salve sono nuovo del forum e vi scrivo per chiedervi dei suggerimenti.

Dovrei contare nel foglio dati quante volte è presente "61b" 57a" "32a" ecc ecc. come devo impostare la funzione CONTA???

GRAZIE

Immagine
dambro82
Newbie
 
Post: 3
Iscritto il: 30/01/08 13:30

Sponsor
 

Re: [Excel] Aiuto per funzione CONTA

Postdi Anthony47 » 31/01/08 00:21

Ciao dambro82 e benvenuto nel forum.

Puoi usare la funzione CONTA.SE, nella sintassi (ad esempio)
Codice: Seleziona tutto
=CONTA.SE(E:O;"61b")

Oppure metti il termine cercato in una cella, diciamo A1, e poi usi
Codice: Seleziona tutto
=CONTA.SE(E:O;A1)


Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Aiuto su funzione CONTA

Postdi dambro82 » 31/01/08 07:39

grazie. però cosi conta solo 61b. e lo dovrei fare per tutti i codici, uno alla volta. Non c'è un modo per contarli tutti insieme?
dambro82
Newbie
 
Post: 3
Iscritto il: 30/01/08 13:30

Re: [Excel] Aiuto su funzione CONTA

Postdi Anthony47 » 31/01/08 12:22

Se hai un elenco delle cose che vuoi contare, accanto al primo item dell' elenco scrivi la seconda formula; poi la copi sulle celle adiacenti per tutte le voci in elenco.

Se non hai un elenco, allora dovresti spiegare bene che cosa devi contare, e se lo devi fare ripetitivamente o una tantum.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Aiuto su funzione CONTA

Postdi dambro82 » 31/01/08 12:38

intanto grazie per la disponibilità

allora vedi l'immagine. A me serve il numerico di quanti 61b, 72, 1, ecc ecc ci sono nelle colonne Notizie e altre notize ecc
dambro82
Newbie
 
Post: 3
Iscritto il: 30/01/08 13:30

Re: [Excel] Aiuto su funzione CONTA

Postdi Anthony47 » 31/01/08 22:15

Allora puoi usare questa macro per farti l' inventario delle voci che hai nel tuo foglio, poi accanto alle voci dell' inventario inserirai la formula del Conta.se che gia' ti ho detto.
Codice: Seleziona tutto
Sub Inv_Val()
Area = "E11:O100"                              '<<<<  Area da esaminare
Sheets("Counter").Range("A:A").ClearContents
For Each Item In Range(Area)
 If Application.WorksheetFunction.CountIf(Sheets("Counter").Range("A:A"), Item.Value) = 0 Then
  Item.Copy Destination:=Sheets("Counter").Range("A65536").End(xlUp).Offset(1, 0)
 End If
Next Item
End Sub

Uso del codice:
Da excel apri il vba editor con Alt-F11; fai Menu /Inserisci /Modulo; copia il codice e incollalo nel frame vuoto di destra.
Guarda subito l' istruzione marcata <<<, e correggila come da situazione sul tuo foglio.

Eventualmente assegna alla macro un tasto di avvio rapido; da excel: Menu /Strumenti /Macro /Macro; selezioni Inv_Val dall' elenco, premi Opzioni; nella casella "Tasto di scelta rapida" inserisci "I" (I maiuscolo, come Inventario), e completa con Ok; chiudi con la X.

La macro presuppone che sia gia' presente nel tuo documento un foglio chiamato Counter, la cui colonna A viene azzerata completamente prima di ricrearel' elenco.

Uso della macro:
dal foglio "Inserimento dati" premere Contr-Maiusc-i per lanciare la macro.
Poi inserisci le formule per il conteggio dei valori.

Ciao, fai sapere...
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Aiuto su funzione CONTA":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti