Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Formattazione condizionata multipla

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Formattazione condizionata multipla

Postdi Venerdi » 29/01/08 11:37

Ciao, nuovo problemino...

Poniamo abbia una tabella così fatta (2 colonne / 10 righe):

B 11700
B 8400
B 35250
C 27000
C 28000
D 40900
E 2100
E 8000
F 8400
F 28000

Ora il problema da risolvere

B non deve superare 33000
C non deve superare 33000
D non deve superare 10000
E non deve superare 7500
F non deve superare 20000

Mi occorre una funzione (o altro) che mi metta in rosso e grassetto i valori della seconda colonna che superano quanto da me videnziato nelle condizioni.
Ovviamente nella realtà la tabella è più grande, utilizza quasi tutte le lettere dell'alfabeto ed è composta da da circa 35.000 righe. Con la formattazione condizionata, dovendo porre due condizioni contemporaneamente (la lettera ed il valore), non ci riesco.


Grazie per l'attenzione
V.
Avatar utente
Venerdi
Utente Junior
 
Post: 43
Iscritto il: 18/03/02 20:05
Località: Roma

Sponsor
 

Re: [Excel] Formattazione condizionata multipla

Postdi Anthony47 » 29/01/08 11:55

Suggerisco di fare una tabella di 2 colonne con le definizioni dei limiti che hai descritto; poi usi la formattazione condizionale sulla colonna B (i valori) con la clausola Il valore della cella e', Maggiore di, =CERCA.VERT(A1;Coord di tabella;2;0), e i formati descritti.

Ok cosi'?
Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Formattazione condizionata multipla

Postdi Venerdi » 29/01/08 12:05

Grazie della risposta...
...ci avevo già pensato a fare così, però quello che mi chiedo è se possa esserci un modo per fare tutto senza creare nulla i più di quello che ho già...

Esempio... una macro che scorra i valori della colonna B, verifichi la lettera nella colonna A ed inserisca o meno la formattazione condizionata in funzione di una tabella che contenga le condizioni.

V.
Avatar utente
Venerdi
Utente Junior
 
Post: 43
Iscritto il: 18/03/02 20:05
Località: Roma

Re: [Excel] Formattazione condizionata multipla

Postdi Venerdi » 29/01/08 12:23

Mi sono reso conto dopo, di non aver compreso bene la tua risposta.
Ho fatto come hai detto e mi va benissimo; grazie!

V.
Avatar utente
Venerdi
Utente Junior
 
Post: 43
Iscritto il: 18/03/02 20:05
Località: Roma


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Formattazione condizionata multipla":


Chi c’è in linea

Visitano il forum: Nessuno e 17 ospiti