Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Convalida dei dati soggetto a funzione SE

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Convalida dei dati soggetto a funzione SE

Postdi 8alex8 » 16/01/08 19:03

Salve a tutti... ho un problema con Excel, mi servirebbe poter convalidare i dati di una cella con due diverse condizioni:
Se nella cella a fianco c'è scritto "NO" allora voglio che sia convalidata solo una parola, altrimenti che si possa inserire un numero decimale (uno qualsiasi).
Sono riuscito ad inserire la funzione SE per scegliere un elenco diverso a seconda della condizione, ma a cambiare il tipo di convalida SE non riesco proprio.
Si può fare secondo voi?
Ciao,
8alex8

P.S. Forse con un esempio pratico mi spiego meglio, questo è il risultato che vorrei ottenere in C1:
A1: Esistono fori su questa piastra? B1: SI/NO (con elenco) C1: SE B1=NO Allora scrivi "N/A" Altrimenti convalida un numero decimale
Avatar utente
8alex8
Newbie
 
Post: 6
Iscritto il: 16/01/08 18:48
Località: Genova

Sponsor
 

Impostazione

Postdi 8alex8 » 16/01/08 19:46

Chiedo scusa per non aver rispettato le linee guida su come impostare un Topic.
La prossima volta sarà fatto.
Avatar utente
8alex8
Newbie
 
Post: 6
Iscritto il: 16/01/08 18:48
Località: Genova

Re: Convalida dei dati soggetto a funzione SE

Postdi Anthony47 » 17/01/08 01:25

Ciao e benvenuto nel forum.
Potresti usare la Convalida con criteri di convalida “Personalizzato”. Ad esempio, se la prima cella e’ B1 e la seconda (con convalida) e’ C1:
-selezioni C1
-Menu /Dati /Convalida; tab Impostazioni
-scegli Personalizzato dall’ elenco “Consenti:”
-nell’ area formula inserisci
Codice: Seleziona tutto
=SE(B1="NO";VAL.TESTO(C1);VAL.NUMERO(C1))

-Tab Messaggio di input
-inserisci un messaggio quale “N/A, oppure Numero”
-Tab Messaggio di errore
-ad esempio: N/A se “no fori”, oppure il numero di fori
-completi con Ok

Io aggiungerei anche una macro tipo Worksheet_Change per compilare automaticamente C1 con N/A se B1 viene compilato con NO:
-tasto dx sul tab col nome del foglio su cui lavori;
-ti si apre il vba editor
-copia il seguente codice e incollalo nel frame vuoto di dx:
Codice: Seleziona tutto
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Address <> "$B$1" Then Exit Sub     '<<< 1
Application.EnableEvents = False
Target.Offset(0, 1).Select
If Target.Value = "NO" Then
ActiveCell.Value = "N/A"
Else: ActiveCell.ClearContents
End If
Application.EnableEvents = True
End Sub


In questo modo:
-se scrivi NO, C1 si compila con N/A
-se scrivi altro, C1 si cancella

Spero di non averti confuso oltre i miei obiettivi :-))

Ciao, fai sapere.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Convalida dei dati soggetto a funzione SE

Postdi 8alex8 » 17/01/08 09:06

Grazie mille per il tuo prezioso aiuto!
Grazie al tuo suggerimento ho messo di mio per convalidare solo il testo "N/A" senza utilizzare macro:

Codice: Seleziona tutto
=SE(B1="NO";IDENTICO("N/A";C1);VAL.NUMERO(C1))


L'utilizzo delle macro non mi è permesso in questo tipo di lavoro per via di regolamenti aziendali, mi tocca fare tutto con le "semplici" funzioni e formule.

Molto valido questo forum!! Spero di poter essere d'aiuto anche io ogni tanto in qualcuno dei vari argomenti trattati.

Ciao,
8alex8
Avatar utente
8alex8
Newbie
 
Post: 6
Iscritto il: 16/01/08 18:48
Località: Genova


Torna a Applicazioni Office Windows


Topic correlati a "Convalida dei dati soggetto a funzione SE":


Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti