Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel]

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel]

Postdi A123691 » 19/12/07 22:45

Salve a chi mi legge.
Avrei un nuovo quesito da sottoporre....
Io,ogni giorno estraggo un foglio di excel con molti dati,metto un paio di funzioni per far risaltare dei dati e con una tabella pivot faccio uscire i dati che maggiormente mi servono.
Il giorno dopo idem ed i dati estratti variano,alcuni (lavorati il giorno prima) spariscono ed altri si aggiungono,
.....La domanda è: c'e' modo di confrontare due tabelle pivot in modo che vengano evidenziati(con colore o altro modo)cio' che da tabella pivot1 è sparito e cio' che da tabella pivot 2 si è aggiunto?
......e ne approfitto: dove si trova la "cartella personale delle macro"??cerco ma non rieso a trovarla.
grazie per le risposte che spero non troppo "difficili",....non sono molto "imparato" :oops:
A123691
Utente Junior
 
Post: 53
Iscritto il: 27/11/07 22:34
Località: Lat.45° 04' Long. 6° 53'

Sponsor
 

Postdi Anthony47 » 20/12/07 12:42

Per evidenziare, potresti usare la formattazione condizionale; ad esempio se vuoi vedere se un certo valore presente nella prima tabella col B esiste nella seconda tabella (in col R) puoi selezionare tutta la colonna B, poi imposti la formattazione condizionale su “la formula è”, come formula usi
Codice: Seleziona tutto
=CONTA.SE($R:$R;B1)<>1
e poi imposti un formato (es. un colore di sfondo rosso).
In questo modo i valori che esistono in quella colonna ma non nella seconda colonna saranno in evidenza.
E’ possibile anche impostare formule piu’ complesse per fare verifiche multiple.

Dovrai ripetere poi le operazioni anche sulle colonne della seconda tabella, per controllare quei valori che mancano sulla prima tabella.


Spero che trovi lo spunto giusto, se no posta ancora.

Per la seconda domanda, penso che tu intenda il file PERSONAL.XLS; se ce l’ hai gia’ lo trovi (per XP) sotto C:\Documents and Settings\Nome-Utente\Dati applicazioni\Microsoft\Excel\XLSTART
Se non ce l’ hai ne puoi generare uno facendo una registrazione macro, e all’ opzione “Memorizza macro in:” scegli Cartella macro personale. Poi magari vai ul vba editor (con Alt-F11), apri il Progetto PERSONAL.xls, trovi il Modulo1 e cancelli le istruzioni.

Excel all’ apertura ti carichera’ in automatico e in modalita’ nascosta tutti i file che trova nella directory suddetta, qualsiasi sia il loro nome.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi A123691 » 20/12/07 17:43

ti ringrazio del suggerimento, domani al lavoro ,ci provo.....
....se non dovessi piu' scrivere prima delle feste auguro a te e chi mi legge un Buon natale.
A123691
Utente Junior
 
Post: 53
Iscritto il: 27/11/07 22:34
Località: Lat.45° 04' Long. 6° 53'

Re: [Excel]

Postdi A123691 » 23/12/07 19:49

.......non riesco....
mi dice che son troppi i dati..
considerato i dati da confrontare in A3:A15
e B3:B15
riesco a far qualcosa con una formula matriciale "{=SE(O(B3=(A$3:A$15));"doppione'";"")} in colonna C3:C15
{=SE(O(B3=(A$3:A$15));"'";"sparito")} in E3:E15
{=SE(O(A3=(B$3:B$15));"'";"aggiunto")} in F3:F15

ma sta funzione non ne vuol sapere di rimanere attiva nella stringa della formattazione condizionale,la scrivo,ma quando devo dare CTRL+MAIUSC+INVIO al posto del solo Invio ,si inceppa .


saluti
A123691
Utente Junior
 
Post: 53
Iscritto il: 27/11/07 22:34
Località: Lat.45° 04' Long. 6° 53'

Re: [Excel]

Postdi Anthony47 » 23/12/07 23:19

Se vuoi usare la formattazione condizionale, con i dati che hai fornito:
-selezioni l' area A3:A15
-menu /Formato /Formattazione condizionale
-scegli come Condizione 1 "la formula è" e come formula scrivi
Codice: Seleziona tutto
=CONTA.SE($B$3:$B$15;A3)=0

-premi Formato
-tab Motivo, selezioni un colore tipo Rosso; confermi con Ok, Ok

In questo modo se un valore compare in A3:A15 ma non in B3:B15 quella cella e' colorata di rosso.

Ripeti sui dati B3:B15, ma con la formula
Codice: Seleziona tutto
=CONTA.SE($A$3:$A$15;B3)=0
per avere anche l' evidenza dei valori che mancano in col A mo sono in col B.

Se invece vuoi aver il messaggio "sparito" o "aggiunto", allora:
in E3
Codice: Seleziona tutto
=SE(CONTA.SE($A$3:$A$15;B3)=0;"aggiunto";"")

e in F3
Codice: Seleziona tutto
=SE(CONTA.SE($B$3:$B$15;A3)=0;"sparito";"")


Non sono certo della condizione sparito/aggiunto; eventualmente devi invertire la stringa di testo con la stringa vuota ("").

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel]

Postdi A123691 » 24/12/07 10:08

Funziona tutto!!
Ti ringrazio moltissimo.
Auguri di Buone Feste
A123691
Utente Junior
 
Post: 53
Iscritto il: 27/11/07 22:34
Località: Lat.45° 04' Long. 6° 53'


Torna a Applicazioni Office Windows


Topic correlati a "[Excel]":


Chi c’è in linea

Visitano il forum: Nessuno e 15 ospiti

cron