Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

excel ,riconoscere le celle con testo

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

excel ,riconoscere le celle con testo

Postdi luca baldazzi » 02/12/07 15:28

buongiorno a tutti
Ho in a1 la data(es.: dom 02/12/2007)
Ho in d1 un totale
ho in w1 la formula ( = se (a1="dom";(d1*2))
Comeposso far riconoscere la parola "dom" che mi calcoli il doppio?senza dover usare un'altra colonna per inserire manualmente la parola "dom"? grazie a tutti anticipamente, un grazie a anthony per la pazienza . luca
luca baldazzi
Utente Junior
 
Post: 16
Iscritto il: 25/11/07 16:03

Sponsor
 

Postdi Anthony47 » 02/12/07 22:45

In realta' la cella in cui "vedi" dom 02/12/2007 "contiene" il numero 39418 (e' il modo di excel di rappresentare una data; vedi l' help on line); se vuoi riconoscere che quella data e' una domenica allora puoi usare la funzione GIORNO.SETTIMANA (vedi help on line); quindi in W1:
Codice: Seleziona tutto
=SE(GIORNO.SETTIMANA(A1;2)=7;D1*2;D1)


Nel post gia' segnalato (http://www.pc-facile.com/forum/viewtopic.php?t=64085) la funzione e' ampiamente usata (per colorare le righe dei giorni festivi e per calcolare lo straordinario).

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi luca baldazzi » 03/12/07 19:37

ciao anthony.. laformula che mi hai dato, non si riesce assolutamente a inserire nel mio foglio. ti spiego come è formato.
A10 data della tua macro
B10 colonna da eliminare in quanto ora contenente la parola " dom" da riconoscere per orario calcolato doppio
C10 motivo di recupero ore
D10 e E10 entrata(ore;minuti)
F10 e G10 uscita (ore;minuti)
H10 =TESTO(y10/24;"h:mm")
R10 =se(S10>0,91667;(S10-0,91667+W10)) (per entrata dopo le 22)
S10 =ORARIO(D10;E10)
T10 =ORARIO(F10;G10;)+SE(F10=24;(F10+1)-24)+SE(F10=1;(F10+24))
U10 =SOMMA(T10-S10)
V10 =SE(T10>0.91667;T10-0.91667)
W10 =SE(B10="DOM";(U10-V10)) (questa la formula della domenica da variare)
X10 =SE(U10<>"";(U10+V10+W10-R10);"")
Y10 =(X10-INT(X10))*24

Questo è ilmio foglio , fatto senza conoscer excel , tutto da solo e tutto a tentativi, mi pare funzioni tutto , ma quella formula della domenica , proprio non mi riesce di inserirla...
luca baldazzi
Utente Junior
 
Post: 16
Iscritto il: 25/11/07 16:03

Postdi Anthony47 » 03/12/07 22:13

Mi limito alla formula in W10; la formula che devi metterci e’ la seguente:
Codice: Seleziona tutto
=SE(GIORNO.SETTIMANA(A10;2)=7;quello che vuoi calcolare se la data e’ di domenica;quello che vuoi calcolare se non e’ domenica)


Questa e’ la sintassi della funzione SE (vedi help on line); la clausola di “test” e’ GIORNO.SETTIMANA(A10;2)=7 che nel contesto significa “la data e’ di domenica”.

Forse la formula puo’ essere inserita in una delle colonne precedenti (penso la V), ma siccome non mi dici che cosa esse rappresentano non posso affermarlo con certezza.

Ciao, se non trovi il suggerimento giusto fatti sentire.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi luca baldazzi » 03/12/07 23:58

...hai ragione, non ti ho spiegato, ora ci provo..
in colonna S e colona T sono solo ora orari
la lunga formula di T è semplicemente per far si che si riconosca l'orario dopo le 24, perchè excel dopo le 23:59 , restituisce 00:00 , io invece ho bisogno che continui il conteggio fino almeno l'1 di notte. E questo sistema che ho ideato in colonna T , funziona
in U le ore fatte di lavoro
in V c'è la differenza di orario dalle ore 22 in poi(che sono doppie) , che viene poi sommata alla colonna X, dove troviamo la somma di :
in U le ore fatte di lavoro
in V le ore oltre le 22
in W le ore se c'è la domenica
praticamente il totale di tutto, spero di essermi spiegato, non è cosi semplice purtroppo..
luca baldazzi
Utente Junior
 
Post: 16
Iscritto il: 25/11/07 16:03

Postdi luca baldazzi » 04/12/07 00:07

...FATTO!!! la tua formula funziona alla grande!!!
ho provato ora e funziona benissimo.. dovevo poi scrivere in w :=SE(GIORNO.SETTIMANA(A10;2)=7;(U10-V10))
.... grazie di cuore anthony
luca baldazzi
Utente Junior
 
Post: 16
Iscritto il: 25/11/07 16:03


Torna a Applicazioni Office Windows


Topic correlati a "excel ,riconoscere le celle con testo":


Chi c’è in linea

Visitano il forum: Nessuno e 19 ospiti