Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel] 2 formule nella stessa cella

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel] 2 formule nella stessa cella

Postdi marcoc » 30/11/07 12:36

è un domanda (credo) un po' azzardata...
è possibile che nella stessa cella ci sia il risultato di due formule?
per esempio nella cella A1 è possibile che ci sia SOMMA(A2:A10) e MEDIA(A2:A10) separati da " - " o da " ; "?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Postdi Anthony47 » 30/11/07 17:20

Tipo
Codice: Seleziona tutto
=SOMMA(B2:B6)&"-"&MEDIA(B2:B6)
oppure, per avere qualche opzione in piu', qualcosa come
Codice: Seleziona tutto
=TESTO(SOMMA(B2:B7);"#,00")&" - "&TESTO(MEDIA(B2:B7);"#,000")


Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi marcoc » 30/11/07 18:05

se metto la prima formula funziona;
se metto la seconda formula invece, scrivendo "TESTO" mi dà lo stesso risultato della prima;
se metto dei riferimenti ad altre celle al posto di "TESTO" mi dà "#RIF!"
se metto "SOMMA" e "MEDIA" mi dà "#VALORE!";
se metto "AUTO" e "MODULI" (cioè il testo che mi serve scrivere), mi dà "#NOME?";
cosa sbaglio?
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Postdi Anthony47 » 01/12/07 13:22

#RIF, #NOME, #VALORE sono tutti messaggi di errore.

cosa sbaglio?

Se non mi dici che cosa scrivi, per dirti "che cosa" sbagli e non solo che sbagli dovrei avere poteri che non ho....

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi marcoc » 01/12/07 18:38

Espongo meglio il problema: metto da B2 a B6 i valori 2;3;4;5;6, e in C1 e C2 rispettivamente "SOMMA" e "MEDIA"; poi scrivo le seguenti formule e ottengo i seguenti risultati:

formula:
=SOMMA(B2:B6)&"-"&MEDIA(B2:B6)
risultato:
20-4
va bene ma non si capisce cosa vogliano dire i valori, per cui, come hai scritto tu, passo alla seconda formula;

formula:
=TESTO(SOMMA(B2:B6);"#,00")&" - "&TESTO(MEDIA(B2:B6);"#,000")
risultato:
20,00-4,000
mi dà lo stesso risultato di prima, con solo i decimali in più;

provo a scrivere la formula:
=C1(SOMMA(B2:B6);"#,00")&" - "&C2(MEDIA(B2:B6);"#,000")
ma mi dà come risultato:
#RIF!
mentre vorrei ottenere: "SOMMA20 - MEDIA4"

con la formula:
=SOMMA(SOMMA(B2:B6);"#,00")&" - "&MEDIA(MEDIA(B2:B6);"#,000")
ottengo:
#VALORE!
mentre vorrei ottenere: "SOMMA20 - MEDIA4"

con la formula:
=AUTO(SOMMA(B2:B6);"#,00")&" - "&MODULI(MEDIA(B2:B6);"#,000")
ottengo:
#NOME?
mentre vorrei ottenere: "AUTO20 - MODULI4"

grazie x l'aiuto
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Postdi Anthony47 » 01/12/07 19:29

formula:
=SOMMA(B2:B6)&"-"&MEDIA(B2:B6)
risultato:
20-4
va bene ma non si capisce cosa vogliano dire i valori, per cui, come hai scritto tu, passo alla seconda formula;

Questo e' esattamente quello che avevi chiesto: il valore della "somma", trattino, il valore della "media2". Ma forse tu volevi ottenere: stringa "SOMMA" seguita dal "valore" della somma, trattino, stringa "MEDIA" seguita dal valore della media??


formula:
=TESTO(SOMMA(B2:B6);"#,00")&" - "&TESTO(MEDIA(B2:B6);"#,000")
risultato:
20,00-4,000
mi dà lo stesso risultato di prima, con solo i decimali in più;

Ti da' lo stesso risultato ma (come promesso) con "qualche opzione in più", cioe' la possibilita' di formattare il testo come da bisogno (decimali, numeri interi, eventuale spaziatura)



provo a scrivere la formula:
=C1(SOMMA(B2:B6);"#,00")&" - "&C2(MEDIA(B2:B6);"#,000")
ma mi dà come risultato:
#RIF!
mentre vorrei ottenere: "SOMMA20 - MEDIA4"

Prova allora
Codice: Seleziona tutto
=C1&(SOMMA(B2:B6);"#,00")&" - "&C2&(MEDIA(B2:B6);"#,000")
che ti restituira' SOMMA20,00 - MEDIA4,000 oppure
Codice: Seleziona tutto
=C1&SOMMA(B2:B6)&"-"&C2&MEDIA(B2:B6)

Oppure invece di C1 e C2 puoi mettere direttamente le stringhe:
="SOMMA"&SOMMA(B2:B6)& etc etc



formula:
con la formula:
=SOMMA(SOMMA(B2:B6);"#,00")&" - "&MEDIA(MEDIA(B2:B6);"#,000")
ottengo:
#VALORE!
mentre vorrei ottenere: "SOMMA20 - MEDIA4"

Vedi sopra



formula:
con la formula:
=AUTO(SOMMA(B2:B6);"#,00")&" - "&MODULI(MEDIA(B2:B6);"#,000")
ottengo:
#NOME?
mentre vorrei ottenere: "AUTO20 - MODULI4"

Le funzioni AUTO e MODULI non esistono, quindi l' errore #NOME.
Vedi sopra per l' uso delle stringhe nel concatenamento.

Spero che sia piu' chiaro...

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13892
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi marcoc » 03/12/07 17:40

ok, è tutto chiaro.
AUTO e MODULI sono due stringhe che mi serviva inserire, e ho risolto con le "".
Ho aggiunto un filtro e ho un po' modificato la formula che mi serviva e con:
=SUBTOTALE(9;C3:C114)&" Moduli ("&SUBTOTALE(9;C3:C114)/3&" Auto)"
ottengo ciò che mi serve...
grazi ancora e... alla prossima domanda!
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano


Torna a Applicazioni Office Windows


Topic correlati a "[excel] 2 formule nella stessa cella":


Chi c’è in linea

Visitano il forum: Nessuno e 11 ospiti