Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

conta valori diversi tra loro

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

conta valori diversi tra loro

Postdi marcoc » 20/11/07 12:55

ciao a tutti,
esiste una formula che, dato un tot di celle (es: da A1 a A10), rileva quanti sono i valori diversi tra loro?

esempio, per questo intervallo:
A1 aaa
A2 b
A3 c
A4 d
A5 aaa
A6 e
A7 f
A8 aaa
A9 h
A10 aaa

mi deve dare "7".
grazie ciao
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Postdi Anthony47 » 20/11/07 23:35

In una colonna libera (es. B), su riga 1 segni “1”, poi sotto metti la formula
Codice: Seleziona tutto
=SE(CONTA.SE($A$1:A2;A2)>1;0;1)
che poi copi nelle colonne sottostanti; infine calcoli
Codice: Seleziona tutto
=SOMMA(B1:B10)


Puo’ andare? Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi marcoc » 21/11/07 10:09

ok, funziona, ma non capisco perchè mi dici di scrivere "1" in B1; se metto la formula che hai scritto da B1 a B10 e poi faccio la somma, il risultato è quello cercato.
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Postdi Anthony47 » 21/11/07 15:43

Hai ragione, basta una unica formula.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "conta valori diversi tra loro":


Chi c’è in linea

Visitano il forum: eliorimnap e 13 ospiti