Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel]Somma celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel]Somma celle

Postdi nikfitz » 15/08/07 22:07

Ciao a tutti avrei un problemino con la somma celle: Ho due valori in A1 e B1 che voglio sommare in C1.
Scrivo per esempio A1=5 e B1=6 e in C1=somma(A1:B1).
Se cancello il valore in A1 avrò C1=6 (credo che Excel consideri le celle vuote come se fossero=0).
Quello che vorrei è un sistema che mi consenta di avere C1=0 se uno dei termini della somma viene cancellato.
Grazie
nikfitz
Utente Junior
 
Post: 62
Iscritto il: 01/05/07 13:54

Sponsor
 

Postdi archimede » 16/08/07 07:31

Codice: Seleziona tutto
=SE(CONTA.VUOTE(A1:B1) > 0;0;SOMMA(A1:B1))
Questo però non funzionerà se invece di cancellare scrivi zero in una delle celle.

HTH.

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

Postdi nikfitz » 16/08/07 13:08

Grazie è comunque un passo avanti.
nikfitz
Utente Junior
 
Post: 62
Iscritto il: 01/05/07 13:54

Postdi archimede » 16/08/07 14:37

Codice: Seleziona tutto
=SE(O(CONTA.VUOTE(A1:B1) > 0;NON(VAL.ERRORE(CONFRONTA(0;A1:B1;0))));0;SOMMA(A1:B1))
HTH.

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova


Torna a Applicazioni Office Windows


Topic correlati a "[Excel]Somma celle":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti

cron