Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Somma solo dei risultati più alti in excel

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Somma solo dei risultati più alti in excel

Postdi ashintop » 08/08/07 20:53

Ho creato una tabella a 13 righe con casella finale di totale, vorrei fare in modo che la somma di queste 13 non fosse fatta semplicemente tra tutte, ma solo in quelle 10 che hanno il numero più alto.

Non ho trovato da nessuna parte il codice esatto

Sapreste dirmi come fare se si può fare?

Grazie
ashintop
Utente Junior
 
Post: 17
Iscritto il: 08/08/07 18:02

Sponsor
 

Postdi Anthony47 » 08/08/07 21:37

Puoi usare la seguente formula, che immagina che i tuoi dati siano in A1:A13
=SOMMA(A1:A13*(RANGO(A1:A13;$A$1:$A$13)<11))

che confermerai NON con Invio ma con Contr-Maiusc-Invio

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi ashintop » 09/08/07 10:03

ho fatto come dici con questa formula

=SOMMA(L3:L16*(RANGO(L3:L16;$L$3:$L$16)<11))


ma fa il calcolo normale e non solo di quelli con la cifra più alta
ashintop
Utente Junior
 
Post: 17
Iscritto il: 08/08/07 18:02

Postdi Anthony47 » 10/08/07 01:33

Quello che dici potrebbe succedere se hai 4 o piu' righe con lo stesso punteggio piu' basso.
Se e' questo il tuo caso, si puo' aggirare; mi confermi e provo a spiegare come?

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi ashintop » 10/08/07 12:42

infatti credo sia proprio questo il problema...
ashintop
Utente Junior
 
Post: 17
Iscritto il: 08/08/07 18:02

Postdi Anthony47 » 10/08/07 16:18

Hai un paio di alternative:
-ordini la classifica in modo decrescente e poi calcoli quanto cerchi con la formula
Codice: Seleziona tutto
=SOMMA(L3:L12)
; questo nell' ipotesi che i tuoi numeri siano da L3 in giu', altrimenti aggiusta la formula; vedi http://www.pc-facile.com/forum/viewtopic.php?t=52846. L’ ordinamento puoi farlo con una macro che registri e poi assegni a un pulsante per una facile ripetizione.
OPPURE eviti che nella classifica possano esserci degli ex aequo; ad esempio io spesso sottraggo al calcolo una frazione del numero-riga corrente, ad esempio:
Codice: Seleziona tutto
=VITTORIE*3+PAREGGI-RIF.RIGA()/10000

In una visualizzazione normale i decimali scompaiono ma nel calcolo della posizione in classifica chi e’ in una riga piu’ bassa figura primo; a questo punto usi la formula gia' in tuo possesso.

Riesci ad adattare una di queste due? Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi ashintop » 15/08/07 18:48

credo che mi convenga usare la prima, non dovendo farlo solo io questo calcolo, la prima soluzione mi pare la più semplice da far capire. Azionare una macro magari non è semplice per tutti.

Grazie
ashintop
Utente Junior
 
Post: 17
Iscritto il: 08/08/07 18:02


Torna a Applicazioni Office Windows


Topic correlati a "Somma solo dei risultati più alti in excel":


Chi c’è in linea

Visitano il forum: patel e 5 ospiti