Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Copia e Incolla fino alla prima riga, intera, vuota.

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Copia e Incolla fino alla prima riga, intera, vuota.

Postdi krandall » 20/07/07 23:25

Salve,
da un file html ricavo questi dati per un foglio excel:

http://img103.imageshack.us/my.php?image=schemasi4.jpg

Io vorrei che il nome dello sport (Es.: "Formula1" (B3)) venisse
copiato nella colonna vuota tra la data e il codice( ossia nelle
celle D5:D17) e fermarsi quando incontra una riga vuota (riga 18 ) per poi
riprendere il contenuto della cella (B19) e lo ricopiasse nelle celle
(D21:D25) per poi fermarsi alla riga26 in quanto vuota..etc etc.

E possibile fare questo ? e, se sì, in che modo ?

Grazie in anticipo...e a buon rendere.
Giorgio
krandall
Utente Junior
 
Post: 14
Iscritto il: 24/07/03 17:49

Sponsor
 

Postdi Anthony47 » 21/07/07 00:46

Prova con questa formula in D3:
Codice: Seleziona tutto
=se(c3="";b3;d2)


Poi copi questa formula (selezioni cella, Contr-c) e la incolli nelle celle sottostanti (selezioni D4:Dxxx, Contr-v).

E' sufficiente?
Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi krandall » 21/07/07 01:57

Anthony47 ha scritto:Prova con questa formula in D3:
E' sufficiente?


Altrochè :lol:

Grazie davvero,
Ciao
krandall
Utente Junior
 
Post: 14
Iscritto il: 24/07/03 17:49

Postdi krandall » 21/07/07 22:44

e se volessi anche eliminare una parte di testo da copiare (una serie di caratteri sempre uguali es. "CALCIO" e sempre ad inizio campo) ?

It's possible ?
Grazie
krandall
Utente Junior
 
Post: 14
Iscritto il: 24/07/03 17:49

Postdi Anthony47 » 23/07/07 01:56

e se volessi anche eliminare una parte di testo da copiare (una serie di caratteri sempre uguali es. "CALCIO" e sempre ad inizio campo) ?

Anche riguardando l' esempio pubblicato non ho capito che cosa vuoi eliminare, ma "probabilmente si puo' fare".

Ad esempio, se volessi eliminare la prima parola dalla stringa contenuta (vedi esempio) in B3, B19 etc, userai questa formula da mettere in D3:
Codice: Seleziona tutto
=SE(C3="";STRINGA.ESTRAI(B3;RICERCA(" ";B3;1)+1;99);D2)


Oppure spiega meglio che cosa eliminare, da dove, quando; insomma la regola da tradurre in formula.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Copia e Incolla fino alla prima riga, intera, vuota.":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti