Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL 2007]Contare celle

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL 2007]Contare celle

Postdi Statix » 17/06/07 10:39

Ho una riga di 25 celle A1:Y1,che contengono numeri,alcuni sono colorati in rosso tramite formattazione condizionale,in Z1 vorrei contare quanti numeri sono in rosso.



43 25 85 61 63 78 60 30 6 47 62 44 14 80 60 75 57 27 3 42 57 39 9 75


mi serve un esempio,anche di colonna.

Grazie
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Sponsor
 

Postdi Statix » 17/06/07 13:46

ho ancora problemi con la formattazione condizionale.

esempio senza formattazione condizionale

43 25 85 61 63 78 60 30 6 47 62 44 14 80 60 75 57 27 3 42 57 39 9 75 23



esempio con la formattazione condizionale da sinistra a destra

43 25 85 61 63 78 60 30 6 47 62 44 14 80 60 75 57 27 3 42 57 39 9 75 23


esempio con la formattazione condizionale da destra a sinistra.


43 25 85 61 63 78 60 30 6 47 62 44 14 80 60 75 57 27 3 42 57 39 9 75 23


purtroppo non riesco a fare questa formattazione condizionale


Ringrazio anticipatamente.
Statix
Windows 7,
Office 2010,
Statix
Utente Senior
 
Post: 1078
Iscritto il: 12/05/06 21:55
Località: Provincia di Caserta

Postdi Anthony47 » 17/06/07 23:05

1- La formattazione condizionale
Ne abbiamo trattato ampiamente; le situazioni che descrivi possono essere affrontate con lo stesso metodo di tutte le precedenti:
-"la formula è"
-=CONTA.SE(. . . . )>0

La sintassi del conta.se dovrebbe essere oramai nota.
Il range oggetto del conta.se deve essere, nei casi che descrivi, "dalla cella successiva a destra (quindi con indirizzo relativo) alla cella finale (quindi con indirizzamento assoluto, es $Z$1)" oppure "dalla prima cella (indirizzo assoluto) alla cella precedente a sinistra (indirizzo relativo)

2- Contare le celle colorate
Se il colore dato con formattazione di cella puo' essere conteggiato con una user function, il colore da formattazione condizionale e' "praticamente" non coteggiabile. Devi quindi replicare in una seconda serie di dati le condizioni della formattazione condizionale e contare queste situazioni.
Nei casi considerati, ti creerai in una cella una formula tipo =se(conta.se(. . . . )>0;1;0) dove la formula conta.se e' la stessa usata per la formattazione condizionale della cella corrispondente, poi copi nelle celle adiacenti in modo da avere una stringa pari alla stringa di numeri originale. Infini sommi questa serie di 1 e 0.

Quindi: dacci sotto e fatti sentire.
Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13904
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL 2007]Contare celle":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti