Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

conta.se nel testo è compreso

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

conta.se nel testo è compreso

Postdi marcoc » 08/05/07 13:31

ciao a tutti; riassumendo, ho un elenco dalla cella A1 alla cella C172, e sotto di esso ho queste formule:
=CONTA.SE(C$3:C$172;C174) in riga 174
=CONTA.SE(C$3:C$172;C175) in riga 175
=CONTA.SE(C$3:C$172;C176) in riga 176
che mi conta quante volte nella colonna C dalla riga 3 alla 172 è presente il nome in cella C174, C175 e C176; ora in queste tre celle ho bisogno di aggiungere alcuni caratteri al nome presente (es: in riga 174 da "AAA" a "AAA B")
è possibile nella stessa formula aggiungere un "compreso" che continua a contarmi il nome AAA? ho provato con "=CONTA.SE(C$3:C$172;*C174*)" ma non funziona.
grazie
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Sponsor
 

Postdi Anthony47 » 08/05/07 15:15

Prova con
=CONTA.SE(C$3:C$172;"*"&C174&"*")

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi marcoc » 08/05/07 16:08

grazie per la risposta; ho provato questa formula e funziona se aggiungo del testo nelle celle dell'elenco, però ho bisogno che il testo che contiene la parte da contare più la parte che aggiungo io sia non nell'elenco, bensì nella tabella sotto di esso (righe 174,175,176) che mi riassumono l'elenco.
esempio:

elenco (righe 1-6) e tabella (righe 8-10):
riga167|2001 |1|AAA
riga168|2002 |1|BBB
riga169|2003 |2|BBB
riga170|2004 |1|CCC
riga171|2005 |2|AAA
riga172|2006 |3|BBB
riga173
riga174| |3|BBB 2006
riga175| |2|AAA 2005
riga176| |1|CCC 2004

dove nella prima colonna c'è l'anno, nella seconda il numero progressivo in cui si verifica l'evento e nella terza il nome dell'evento. Nelle righe 174,175,176 inserisco io manualmente il nome dell'ultimo anno in cui si è verificato l'evento elencato nelle righe sopra.
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Postdi Anthony47 » 08/05/07 16:37

Dato l' elenco di A1:C172, che cosa vuoi calcolare e dove?

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi marcoc » 08/05/07 20:52

Voglio calcolare nella cella B174, il numero di celle da C3 a C172 che contengono una parte del testo della cella C174.
cercherò di spiegarmi meglio:
la formula che mi hai scritto " =CONTA.SE(C$3:C$172;"*"&C174&"*") " conta il numero di celle dell'elenco da C3 a C172 in cui è contenuto il testo della cella C174 (per cui se in C35 c'è scritto "XXX 6", e in C174 c'è scritto "XXX", la formula conta anche la cella C35.
io invece ho bisogno di modificare proprio la cella C174, per cui la formula dovrebbe dire "conta le celle da C3 a C172 in cui è presente una parte del testo nella cella C174"; in alcune celle da C3 a C172 c'è un testo (es: abcd), mentre in C174 c'è lo stesso testo, più altri 5 caratteri finali (es: abcd_2006), ma in tale cella si dovrebbe inserire una formula che conta il numero di abcd. Nella formula si dovrebbe quindi avere come riferimento non la cella C174, ma solo parte di essa.
Non so se è possibile e se sono riuscito a spegarmi meglio, ma se riesci a scrivere la formula che mi serve, ti ringrazio in anticipo.
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Postdi Anthony47 » 09/05/07 00:06

Quindi vuoi cercare nell' elenco (C3:C172) quante volte compare una stringa che e' presente, concatenata con altro testo, in C174?
Mi sembra che in C174 la tua stringa sia sempre a sinistra del testo complessivo; allora, se sai la lunghezza del testo (es. 3 crt) potrai usare la formula
Codice: Seleziona tutto
=CONTA.SE(C$3:C$172;SINISTRA(C174;3))

Se invece non sai la lunghezza ma conosci il carattere di separazione (es. "_") allora userai la formula
Codice: Seleziona tutto
=CONTA.SE(C$3:C$172;SINISTRA(C174;TROVA("_";C174)-1))


Fai sapere se mi sono avvicinato...
Intanto mi viene una domanda: come viene genarato il contenuto di C174?

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi marcoc » 09/05/07 09:17

perfetto, grazie!
il contenuto di C174 e delle celle sotto è generato manualmente, sapendo i contenuti delle celle nell'elenco.
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Postdi marcoc » 09/05/07 09:45

Non conosco la lunghezza, perchè varia, quindi va bene la seconda formula; il carattere di separazione è uno "spazio"; in questo modo però, se ci sono altri spazi nelle celle della colonna C, il "conta.se" non funziona; è possibile specificare che il carattere di separazione è sempre, ad esempio, il settimo carattere da destra, indipendentemente dal numero effettivo di "spazi"? una soluzione più "spartana" se così vogliamo dire, è lasciare come carattere di separazione il "_" e camuffare la cella C174 colorando il "_" di bianco.
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano

Postdi Anthony47 » 09/05/07 16:30

Allora potresti usare
Codice: Seleziona tutto
=CONTA.SE(C$3:C$172;SINISTRA(C174;LUNGHEZZA(C174)-7))


Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13903
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi marcoc » 09/05/07 18:23

ok, grazie, così è perfetto!
Avatar utente
marcoc
Utente Senior
 
Post: 216
Iscritto il: 22/03/07 21:58
Località: Nerviano


Torna a Applicazioni Office Windows


Topic correlati a "conta.se nel testo è compreso":


Chi c’è in linea

Visitano il forum: Nessuno e 7 ospiti