Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[EXCEL] Funzione SE per la scelta di un risultato

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[EXCEL] Funzione SE per la scelta di un risultato

Postdi davide70 » 12/03/07 15:59

All'interno dell'elaborazione di un calcolo ho dovuto estrapolare tra le grandezze in gioco anche un numero derivato da una tabella di valori.
Il numero viene calcolato applicando un'interpolazione lineare fra due numeri diversi in base all'intervallo fra due importi.
Tutto mi funziona bene. Ho costruito la tabella con i dati di partenza (numeri ed importi) ed ho ripetuto la struttura del calcolo per tutte le colonne.
Alla fine ho ottenuto una seconda tabella con le interpolazioni fra tutte i numeri in base a tutti gli intervalli di importo. Ora devo scegliere quale sia il mio numero giusto calcolato in base all'importo.
Ho seguito il seguente procedimento:

Dato che la casella Y18 contiene l'importo di riferimento

Dato che i numeri calcolati con l'interpolazione sono tabellati da CC18 a BC18 per importi da 4000000000 a 250000

La casella in cui mi trovo (Per es. A1) deve restituirmi il seguente valore:

=SE(Y18>4000000000;CC18;SE(Y18>3000000000;CB18;SE(Y18>2000000000;CA18;SE(Y18>1500000000;BZ18;SE(Y18>...
In altre parole:

Se
Y18>4000000000 restituisci il valore CC18
Y18>3000000000 restituisci il valore CB18
Y18>2000000000 restituisci il valore CA18
e così via...

Tutto bellissimo se non fosse che il limite della funzione SE è posto a 7 livelli ed io ne ho 29!!!

Qualcuno sa darmi un suggerimento?
Grazie
Ciao ciao
Davide
:-)
davide70
Utente Junior
 
Post: 11
Iscritto il: 03/10/05 10:02

Sponsor
 

Postdi Anthony47 » 12/03/07 23:39

Devi mettere in una riga superiore alla 18, nelle stesse colonne BC:CC, il valore a cui corrisponde il numero calcolato in riga 18; quindi da CC verso BC metterai 4000000000, 3000000000, 2000000000 etc.
Poi userai la funzione CERCA.ORIZZONTALE: se le intestazioni fossero in riga 17 la formula da adottare sarebbe:
Codice: Seleziona tutto
=CERCA.ORIZZ(Y18;BC17:CC18;2;1)

Se le intestazioni fossero su righe precedenti dovrai modificare di conseguenza gli indirizzi della matrice_tabella e l' indice di ricerca.

Se hai difficolta', fatti sentire.
Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[EXCEL] Funzione SE per la scelta di un risultato":


Chi c’è in linea

Visitano il forum: patel e 6 ospiti