Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[exce]conteggiare solo certi valori

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[exce]conteggiare solo certi valori

Postdi cassioli » 16/01/07 09:35

Nella colonna A ho dei valori.
Nella colonna B dei "marker" che associano ogni valore a una certa categoria.
Come faccio ad avere in una casella la somma dei valori di una certa categoria?
cassioli
Utente Senior
 
Post: 1014
Iscritto il: 05/03/04 11:02

Sponsor
 

Postdi Anthony47 » 16/01/07 14:28

In A i valori, in B i marker; ti fai in D l' elenco dei marker (magari lo stesso elenco lo usi per il Data/Convalida della colonna B) e poi:
-se vuoi sommare le celle di A che hanno quel marker usi la formula
Codice: Seleziona tutto
=SOMMA.SE($B$1:$B$30;$D1;$A$1:$A$30)
che poi copi in basso su tutto l' elenco dei marker
-se vuoi solo contarne il numero usi la formula
Codice: Seleziona tutto
=CONTA.SE($B$1:$B$30;D1)


Aiuta? Ciao,
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi cassioli » 20/01/07 19:22

Anthony47 ha scritto:In A i valori, in B i marker; ti fai in D l' elenco dei marker (magari lo stesso elenco lo usi per il Data/Convalida della colonna B) e poi:
-se vuoi sommare le celle di A che hanno quel marker usi la formula
Codice: Seleziona tutto
=SOMMA.SE($B$1:$B$30;$D1;$A$1:$A$30)
che poi copi in basso su tutto l' elenco dei marker
-se vuoi solo contarne il numero usi la formula
Codice: Seleziona tutto
=CONTA.SE($B$1:$B$30;D1)


Aiuta? Ciao,

ho potuto provare solo oggi...
Si, funziona, grazie.
Peccato solo che, a quanto pare, il secondo parametro non possa puntare a un altro foglio (almeno, in excel 95)
cassioli
Utente Senior
 
Post: 1014
Iscritto il: 05/03/04 11:02

Postdi Anthony47 » 20/01/07 23:48

Peccato solo che, a quanto pare, il secondo parametro non possa puntare a un altro foglio

Invece che mettere l' indirizzo, prova con il "nome" di una cella (usa Inserisci/Nome/Definisci per assegnare il nome); e' solo una prova, non so che esito ti puo' dare.

Ciao,
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13885
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi cassioli » 21/01/07 13:32

Anthony47 ha scritto:
Peccato solo che, a quanto pare, il secondo parametro non possa puntare a un altro foglio

Invece che mettere l' indirizzo, prova con il "nome" di una cella (usa Inserisci/Nome/Definisci per assegnare il nome); e' solo una prova, non so che esito ti puo' dare.

Ciao,

no, vabbe, anche cosi' va bene; anzi, mi fa piu' comodo riportare la lista dei marker dall'altro foglio.
cassioli
Utente Senior
 
Post: 1014
Iscritto il: 05/03/04 11:02


Torna a Applicazioni Office Windows


Topic correlati a "[exce]conteggiare solo certi valori":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti