Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[excel]Distribuzione valori

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[excel]Distribuzione valori

Postdi cassioli » 14/01/07 09:24

Esiste in Excel un tipo di grafico o una funzione gia' pronta che mi permette di sapere come sono distribuiti in vari intervalli i valori di un elenco?
Ovvero: dato un elenco di spese, vorrei creare un grafico che mostra quante sono comprese tra 0 e 10 euro, quante tra 10 e 20, ecc...
Ho provato a scrivere accanto a ogni spesa questa formula:
=CONTA.SE(a$1:a$20;">b1")
su ogni riga c'e' la stessa formula, ma b1 diventa b2, b3, b4... perche' in B ho scritto 10,20,30....

Non funziona! :mmmh:

se invece di ">b1" metto ">10" funziona, ma col riferimento non va. Perche'? :-?
cassioli
Utente Senior
 
Post: 1014
Iscritto il: 05/03/04 11:02

Sponsor
 

Postdi Anthony47 » 14/01/07 18:46

cassioli ha scritto:se invece di ">b1" metto ">10" funziona, ma col riferimento non va. Perche'?

"SEMBRA" che non funzioni, ma funziona: prova a scrivere nel range A1:A20 "b2" (si, la stringa b2) e vedrai che verra' contata, perche' b2 e' >b1.
Ovviamente non e' quello che tu stavi cercando di calcolare...

Io suggerisco di usare la funzione MATR.SOMMA.PRODOTTO:
-in B1:H1 scrivi le soglie che vuoi verificare
-in B2 scrivi la formula =MATR.SOMMA.PRODOTTO(($A$1:$A$20>=B1)+0;($A$1:$A$20<C1)+0)
-copi poi la formula di B2 in C2:H2
In questo modo in B2 calcolerai quanti valori sono "uguali o superiori" alla soglia inferire contenuta in B1 E sono anche "inferiori" alla soglia superiore contenuta in C1; e cosi' via nelle celle adiacenti, salvo che vengono shiftate le soglie Inf e Sup.

Funziona? Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi cassioli » 14/01/07 19:14

forte! :)
Non so perche' funzioni :lol: ma funziona.
Grazie.
cassioli
Utente Senior
 
Post: 1014
Iscritto il: 05/03/04 11:02

Postdi Anthony47 » 14/01/07 20:06

Funziona perche':
-($A$1:$A$20>=B1) creaa un elenco di VERO/FALSO/FALSO/VERO... secondo il risultato del test;
-il +0 trasforma questa sequenza in 1/0/0/1...
-idem per ($A$1:$A$20<C1)+0 --> 1/0/1/0...
-la FUNZIONE moltiplica i primi per i secondi, coppia a coppia; ma facendo 1*1 in realta' e' come se "contasse" gli eventi.

Miracolo targato Microsoft.

Ciao,
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[excel]Distribuzione valori":


Chi c’è in linea

Visitano il forum: Nessuno e 4 ospiti