Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel]Classifica campionato

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel]Classifica campionato

Postdi Barbalbero » 21/12/06 21:53

Salve a tutti.
Mi ritrovo con un problema su Excel.

Devo sistemare un file, contenente due fogli.
Nel primo foglio ho l'elenco delle 18 giornate che compongono un campionato di pallavolo con l'elenco di tutte le partite che vengono giocate, ordinate giornata per giornata.

Il formato è:
Colonna A: squadra di casa
Colonna B: squadra ospite
Colonna C: Seti vinti dalla squadra di casa (0-3)
Colonna D: Set vinti dalla squadra ospite (0-3)

Nel foglio due riporto la classifica, e la ordino.
IL formato è:
Colonna A: squadra
Colonna B: punti
Colonna C: partite giocate
Colonna D: partite vinte
Colonna E: set vinti
Colonna F: set persi

Il mio problema nasce quando devo contare il numero di seti vinti o persi da una squadra.
L'unica soluzione che ho trovato è quella di prendere una cella di passaggio per mettere una somma, in cui manualmente vado a scegliere tutti gli addendi che servono. Il problema è che ripetere la cosa per 18 addendi per 10 squadre è lungo e facilmente soggetto ad errori, ma soprattutto che se un odmani, neanche troppo remoto, cambio l'ordine con cui sono inserite le partite, devo andare a rimodificare tutte le somme.

Esiste un'altra soluzione, più automatizzata, che mi permetta anche di cambiare facilmente l'elenco delle partite del campionato?
Il meglio sarebbe che esistesse una strada che non faccia ricorso a macro, ma che sia limitata a formule nelle celle, ma non sapendo da dov einiziare accetto anche soluzioni tramite macro.

Grazie mille a chi abbia la pazienza di aiutarmi, se mi sono spiiegato male o ho dimenticato qualche informazione fondamentale alla risoluzione, sono pronto a fornirla come me la segnalate!
Barbalbero
Newbie
 
Post: 2
Iscritto il: 21/12/06 21:41

Sponsor
 

Postdi Barbalbero » 21/12/06 22:00

Dimenticavo...

il risultato finale dovrebbe essere un qualcosa di simile al foglio linkato in passato sul forum per i mondiali 2006...che forniva gli stessi risultati che vorrei ottenere. Solo che quello era protetto e quindi non ho potuto prendere in esame le formule e le eventuali macro che ci stanno dietro
Barbalbero
Newbie
 
Post: 2
Iscritto il: 21/12/06 21:41

Postdi Anthony47 » 28/12/06 13:07

Ciao Barbalbero, e benvenuto nel forum.
La tua domanda era rimasta trascurata, vediamo se siamo ancora in tempo.

Io farei cosi:
Sul primo foglio, quello con le partite e i risultati, da J1 a O1 (che assumo siano libere) scrivi le intestazioni Squadra, Punti, Giocate, Vinte, Set fatti, Set subiti
Da J2 in basso metti l’ elenco delle squadre;
In L2 (Giocate) metti la formula
Codice: Seleziona tutto
 =MATR.SOMMA.PRODOTTO(($A$1:$A$1000=J2)+0;($C$1:$C$1000<>"")+0)+MATR.SOMMA.PRODOTTO(($B$1:$B$1000=J2)+0;($C$1:$C$1000<>"")+0)

In M2 (vinte) metti
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(($A$1:$A$1000=J2)+0;($C$1:$C$1000=3)+0)+MATR.SOMMA.PRODOTTO(($B$1:$B$1000=J2)+0;($D$1:$D$1000=3)+0)

In N2 (Set fatti) metti
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(($A$1:$A$1000=J2)+0;($C$1:$C$1000>0)+0)+MATR.SOMMA.PRODOTTO(($A$1:$A$1000=J2)+0;($C$1:$C$1000>1)+0)+MATR.SOMMA.PRODOTTO(($A$1:$A$1000=J2)+0;($C$1:$C$1000>2)+0)+MATR.SOMMA.PRODOTTO(($B$1:$B$1000=J2)+0;($D$1:$D$1000>0)+0)+MATR.SOMMA.PRODOTTO(($B$1:$B$1000=J2)+0;($D$1:$D$1000>1)+0)+MATR.SOMMA.PRODOTTO(($B$1:$B$1000=J2)+0;($D$1:$D$1000>2)+0)

In O2 (set subiti) metti
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(($A$1:$A$1000=J2)+0;($D$1:$D$1000>0)+0)+MATR.SOMMA.PRODOTTO(($A$1:$A$1000=J2)+0;($D$1:$D$1000>1)+0)+MATR.SOMMA.PRODOTTO(($A$1:$A$1000=J2)+0;($D$1:$D$1000>2)+0)+MATR.SOMMA.PRODOTTO(($B$1:$B$1000=J2)+0;($C$1:$C$1000>0)+0)+MATR.SOMMA.PRODOTTO(($B$1:$B$1000=J2)+0;($C$1:$C$1000>1)+0)+MATR.SOMMA.PRODOTTO(($B$1:$B$1000=J2)+0;($C$1:$C$1000>2)+0)

Poi copi le formule di L2:O2 in L2:Lxx (xx dipende dal numero di squadre)

In questo modo dovresti calcolare i dati per ogni squadra, in funzione dei risultati scritti nelle colonne C:D.

I punti li calcoli in funzione delle regole di pallavolo, che io non conosco.

Se vuoi, puoi “tagliare” dal primo foglio tutto il gruppo di caselle di riepilogo e “incollarle” su altro foglio: selezioni le celle J1:Oxx, fai Contr-x; vai sul secondo foglio, selezioni la casella in cui vuoi incollare, fai Contr-c oppure Enter.

Aiuta?

Ciao,
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13895
Iscritto il: 21/03/06 16:03
Località: Ivrea


Torna a Applicazioni Office Windows


Topic correlati a "[Excel]Classifica campionato":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti