Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Classifica squadre di calcio

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Postdi papclems » 06/12/07 08:39

grazie mille di nuovo.

Allora il problema dell'ordinamento mi sembra risolto, con la soluzione della colonna A.
Nel foglio Conference non ce ne è neanche il bisogno vedo che li tutto va perfetto.

la questione delle Conference, altra conference e Division tu l'hai intesa bene, perchè è vero che le squadre di una Division sono anche dentro una conference, vorrei però estrapolare i risultati degli scontri intra division, da quelli intra conference ed ovviamente da quelli opposite conference.

La division è formata da 5 squadre, fra di loro si incontrano 4 volte per un totale di 16 gare (4 x4). Vorrei che si vedesse che rendimento hanno nella Division.

Nello stesso tempo le squadre sono anche in una conference che raggruppa in totale 10 squadre, 5 per division, ovviamente con quelle della propria division come ho detto sopra giocano 4, ma le 5 dell'altra division che forma 1 conference vengono affrontate 2 volte (quindi 2x5) per un totale di 10 gare. Anche qui vorrei che si vedesse il rendimento contro le 5 della stessa conference.

Infine c'è la conference opposta, contro di queste si gioca 1 sola volta nel corso della stagione, quindi 10x1, quindi 10 gare. Idem che per le altre.

E' fattibile?



Domanda aggiuntiva :P

Il calendario degli scontri la scorsa stagione l'ho creato random, e quindi ci sono squadre che hanno iniziato con 13 trasferte sulle prime 16 e squadre che han fatto il contrario.
Per questo secondo anno ho copiato lo stesso.
Volendo farlo in maniera più seria e consona, è possibile crearlo sempre da Excel dandogli la lista delle squadre, magari divisa per Division, Confernce e conference opposta in modo da farglielo sorteggiare meglio?
papclems
Utente Junior
 
Post: 85
Iscritto il: 19/11/07 08:48

Sponsor
 

Postdi papclems » 08/12/07 17:50

cmq provando e riprovando.. sta cosa dell'ordinamento che non si esegue è strana forte.

Ora anche se fo l'ordinamento manuale non me lo fa corretto...da cosa può dipendere?

:D
papclems
Utente Junior
 
Post: 85
Iscritto il: 19/11/07 08:48

Postdi Anthony47 » 09/12/07 00:33

Per l' ordinamento: intendi dire che non funziona nemmeno utilizzando la soluzione della prima chiave in col E e seconda in col A, selezionando solo A:F? Hai pero' notato che nel file postato (classificaB) le formule erano "ingarbugliate", cioe' i riferimenti delle varie formule non puntano piu' sulla squadra della stessa linea (almeno per le divisioni sfondo Blu e Bianco). Vanno quindi editate, altrimenti i risultati non quadreranno mai piu'. In effetti questo lo avevo menzionato nel msg precedente ma senza chiarire che le formule andavano editate.

Per quanto riguarda l' estrazione del calendario, dovresti fare (per ogni "ipotesi di estrazione") la verifica se un tot di parametri sono in un range accettabile (es. se N >2 estrazioni, in casa almeno N/2-2 e max N/2+2; idem per scontri intra Divisione e intra Conference). E se uno di questi paramentri e' fuori, ripetere l' estrazione.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi papclems » 09/12/07 11:46

urcola..sta cosa dei riferimenti ingarbugliati m'era sfuggita.. ora provo a studiare una soluzione diversa :D

per la cosa del calendario da estrarre.. mi sa troppo complicato per me -.-

:D
papclems
Utente Junior
 
Post: 85
Iscritto il: 19/11/07 08:48

Postdi Anthony47 » 09/12/07 14:11

Rimetti a posto le formule, salva e poi prova secondo il sistema originale (senza portare PF in col A); dovrebbe funzionare gia' cosi'.
L' ingarbugliamento delle formule potrebbe essere stato il risultato di un ordinamento fatto solo su un pezzo della tabella.

Questo a correzione del mio post del 6-12.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi papclems » 21/12/07 12:33

Ho lavorato ancora sul foglio, risistemando un pò tutto.


HO pensato di fare una specie di "accrocco" che però a me va bene (un foglio dove ci sono i calcoli per le division, ed uno dove invece ci sono i dati solo riportati)

Una sola cosa non mi funziona :

Ma inizio ricapitolando il tutto:
Division (5 squadre)
Conference (due division insieme)
VS Conference (le due division opposte)

Nella colonna G e H ho provato a fare il calcolo secondo questa procedura : Le vittorie totali, meno le vittorie in Division e le vittorie contro l'altra conference.
Idem per le sconfitte.

Dovrebbe funzionare egregiamente, solo che mi ha evidenziato un "errore" (forse non un errore ma magari mi spiego male quindi la formula che mi avevi dato era giusta ma calcolava qualcosa di + di quanto mi serviva) :D

L'errore è che i totali di I e J e K ed L non sono sempre giusti.

Alcuni volte mi danno + di 15 (totali partite giocate attualmente).

Per chiarezza ti posto il file.

http://www.papclems.com/lega1/classifichelega1.xls

Se hai tempo e puoi darci un occhio te ne sono grato.

ovviamente grazie comunque. :D
papclems
Utente Junior
 
Post: 85
Iscritto il: 19/11/07 08:48

Re: [Excel] Classifica squadre di calcio

Postdi Anthony47 » 23/12/07 23:30

Il fatto e' che non ho ancora capito bene che cosa intendi per Conference, Division, Vs Conf; adesso credo di aver capito che:
-vanno sotto Conference quelle partite tra squadre non della stessa Div ma della stesssa Conf
-sotto Division quelle tra squadre della stessa Div
-sotto Vs Conf quelle tra squadre di Conf diverse

Se e' cosi', allora in G4, H4, I4, J4, K4 ed L4 del foglio Division devi usare rispettivamente le formule:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO((Risultati!$D$1:$D$500=Division!$B4)*1;(Risultati!$N$1:$N$500=1)*1;(Risultati!$P$1:$P$500=1)*1;(Risultati!$O$1:$O$500=0)*1)+MATR.SOMMA.PRODOTTO((Risultati!$F$1:$F$500=Division!$B4)*1;(Risultati!$N$1:$N$500=0)*1;(Risultati!$P$1:$P$500=1)*1;(Risultati!$O$1:$O$500=0)*1)

=MATR.SOMMA.PRODOTTO((Risultati!$D$1:$D$500=Division!$B4)*1;(Risultati!$N$1:$N$500=0)*1;(Risultati!$P$1:$P$500=1)*1;(Risultati!$O$1:$O$500=0)*1)+MATR.SOMMA.PRODOTTO((Risultati!$F$1:$F$500=Division!$B4)*1;(Risultati!$N$1:$N$500=1)*1;(Risultati!$P$1:$P$500=1)*1;(Risultati!$O$1:$O$500=0)*1)

=MATR.SOMMA.PRODOTTO((Risultati!$D$1:$D$500=Division!$B4)*1;(Risultati!$N$1:$N$500=1)*1;(Risultati!$O$1:$O$500=1)*1;(Risultati!$P$1:$P$500=1)*1)+MATR.SOMMA.PRODOTTO((Risultati!$F$1:$F$500=Division!$B4)*1;(Risultati!$N$1:$N$500=0)*1;(Risultati!$O$1:$O$500=1)*1;(Risultati!$P$1:$P$500=1)*1)

=MATR.SOMMA.PRODOTTO((Risultati!$D$1:$D$500=Division!$B4)*1;(Risultati!$N$1:$N$500=0)*1;(Risultati!$O$1:$O$500=1)*1;(Risultati!$P$1:$P$500=1)*1)+MATR.SOMMA.PRODOTTO((Risultati!$F$1:$F$500=Division!$B4)*1;(Risultati!$N$1:$N$500=1)*1;(Risultati!$O$1:$O$500=1)*1;(Risultati!$P$1:$P$500=1)*1)

=MATR.SOMMA.PRODOTTO((Risultati!$D$1:$D$500=Division!$B4)*1;(Risultati!$N$1:$N$500=1)*1;(Risultati!$P$1:$P$500=0)*1)+MATR.SOMMA.PRODOTTO((Risultati!$F$1:$F$500=Division!$B4)*1;(Risultati!$N$1:$N$500=0)*1;(Risultati!$P$1:$P$500=0)*1)

=MATR.SOMMA.PRODOTTO((Risultati!$D$1:$D$500=Division!$B4)*1;(Risultati!$N$1:$N$500=0)*1;(Risultati!$P$1:$P$500=0)*1)+MATR.SOMMA.PRODOTTO((Risultati!$F$1:$F$500=Division!$B4)*1;(Risultati!$N$1:$N$500=1)*1;(Risultati!$P$1:$P$500=0)*1)


Poi copi queste formule nelle righe sottostanti.
In questo modo la somma delle colonne G:L fa sempre 15 (con i risultati forniti).
Non ho seguito il ragionamento degli altri fogli, ma credo che se tutto e' corretto su Division devi solo mappare questi dati su quei fogli.

Se invece anche cosi' non ho indovinato, allora devi proprio chiarire tu che cosa va nelle tre serie di colonne.

Ciao.
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13891
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: [Excel] Classifica squadre di calcio

Postdi papclems » 25/12/07 17:26

é tutto molto perfetto.

grazie mille. :D
papclems
Utente Junior
 
Post: 85
Iscritto il: 19/11/07 08:48

Precedente

Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Classifica squadre di calcio":


Chi c’è in linea

Visitano il forum: cromagno e 6 ospiti

cron