Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Conta Personale

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Conta Personale

Postdi sax » 10/07/06 14:07

sul Foglio 1 ho una lista di nomi dalla cella F15:F40 dove si trovano anche doppioni vorrei conoscere il numero delle persone presenti infatti se scrivo
Codice: Seleziona tutto
=CONTA.VALORI(F14:F41)

mi da il numero delle celle occupate ma non riesce a riconoscere se ci siano dei doppioni
grazie
sax
Utente Junior
 
Post: 93
Iscritto il: 20/05/06 19:34

Sponsor
 

Postdi Anthony47 » 10/07/06 15:57

Cia Sax,
se in G14 scrivi
Codice: Seleziona tutto
=CONTA.SE(F$14:F$41;F14)
vedrai in questa cella il numero di occorrenze del valore di F14; copia verso il basso per contare anche gli altri valori.
Oppure puoi farti una tabella pivot sul range F14:F41, facendo la conta della colonna F: avrai quindi un elenco di nomi unici e accanto il numero di loro occorrenza.
Ci sarebbe anche una funzione UNIQUEVALUE tra le opzioni di excel, non ricordo pero’ il suo nome in italiano e dove va cercata.

Ciao,

*** Antony quando compio gli anni mi mandi una virtual torta....tanto per andare a pari con tutte le modifiche sui codici
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi Alexsandra » 10/07/06 16:15

io ho fatto così
Ho messo in F1 questa formula
Codice: Seleziona tutto
=SOMMA.SE(G2:G100;">0")
poi nella colonna G (che puoi anche nascondere) ho messo questa formula
Codice: Seleziona tutto
=SE(F2="";0;SE(CONTA.SE(F2:$F$2;F2)>1;0;1))
e ti restituisce in F1 il n° dei valori senza doppioni
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31

Postdi sax » 11/07/06 09:45

Grazie siete unici al solito
la soluzione ideale e quella di Alexandra
sax
Utente Junior
 
Post: 93
Iscritto il: 20/05/06 19:34

Postdi archimede » 12/07/06 08:14

Codice: Seleziona tutto
=CONTA.VALORI(F15:F40)-SOMMA(1/CONTA.SE(F15:F40;F15:F40))
NB: va inserita premendo Ctrl-Shift-Invio e presuppone che non ci siano celle vuote nel range.

HTH.

Alessandro
archimede
Moderatore
 
Post: 2755
Iscritto il: 07/11/02 12:41
Località: Genova

Postdi danieleg » 12/07/06 08:52

Una soluzione molto stupida, ma che funziona (sono meno di una trentina di nomi) consiste nel farli ordinare alfabeticamente. Così a occhio vedi se ci sono dei doppioni.
Avatar utente
danieleg
Utente Senior
 
Post: 850
Iscritto il: 10/07/06 15:58
Località: Vicino a Imperia

Vedi topic CONTARE RECORD SENZA DOPPIONI DEL 26/7/06

Postdi facciotto » 26/07/06 20:04

Alexsandra ha scritto:io ho fatto così
Ho messo in F1 questa formula
Codice: Seleziona tutto
=SOMMA.SE(G2:G100;">0")
poi nella colonna G (che puoi anche nascondere) ho messo questa formula
Codice: Seleziona tutto
=SE(F2="";0;SE(CONTA.SE(F2:$F$2;F2)>1;0;1))
e ti restituisce in F1 il n° dei valori senza doppioni


Cara Alexsandra, ho anch'io un problema che credo sia simile . Ho provato a ricopiare tutte le tue formule, ma il risultato è ZERO.
Come si fa a spedirti il foglio Excel perché tu possa vederlo?
facciotto
Utente Junior
 
Post: 80
Iscritto il: 13/02/06 14:55
Località: VERONA

Postdi Alexsandra » 26/07/06 20:36

Ti da zero perchè hai lasciato la formula nella cella G2.
Devi trascinarla nella colonna G fino alla riga che contiene dati nella colonna F,oppure la trascini fino alla riga 300 e poi nascondi la colonna G.
Il risultato lo vedi in F1 (8 sono i nomi)
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31

Postdi facciotto » 26/07/06 20:46

Alexsandra ha scritto:Ti da zero perchè hai lasciato la formula nella cella G2.
Devi trascinarla nella colonna G fino alla riga che contiene dati nella colonna F,oppure la trascini fino alla riga 300 e poi nascondi la colonna G.
Il risultato lo vedi in F1 (8 sono i nomi)


Nella cella G2 non ho mai messo alcuna formula. Sto trascinando a destra e sinistra, ma non succede nulla.
facciotto
Utente Junior
 
Post: 80
Iscritto il: 13/02/06 14:55
Località: VERONA

Postdi Alexsandra » 26/07/06 20:59

Ho sbagliato a scrivere io intendevo G1 in G1 metti
Codice: Seleziona tutto
=SE(F2="";0;SE(CONTA.SE(F2:$F$2;F2)>1;0;1))
e trascini la formula fino in fondo al tuo elenco di dati nella colonna G (per quello c'è il valore assoluto in F2)
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Conta Personale":


Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti