Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

[Excel] Istruzioni se nidificate

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

[Excel] Istruzioni se nidificate

Postdi sax » 05/06/06 18:02

Ho un problema nell'estrarre il mese da una casella di excel la data è inserita 200605 con formato cella Generale quindi visto che 05 è Maggio
uso stringa estrai per recuperare "05" ma è in formato testo quindi uso la funzione SE per dare il nomemese ma oltre 7 istruzioni non le accetta
come devo fare vi è qualche altra soluzione magari in VB
Grazie

Sotto ho copiato le istruzioni che ho usatoè
Codice: Seleziona tutto
=SE(STRINGA.ESTRAI(Sviluppo!A7;5;2)="01";"GENNAIO";_
SE(STRINGA.ESTRAI(Sviluppo!A7;5;2)="02";"FEBBRAIO";_
SE(STRINGA.ESTRAI(Sviluppo!A7;5;2)="03";"MARZO";_
SE(STRINGA.ESTRAI(Sviluppo!A7;5;2)="04";"APRILE";_
SE(STRINGA.ESTRAI(Sviluppo!A7;5;2)="05";"MAGGIO";_
SE(STRINGA.ESTRAI(Sviluppo!A7;5;2)="06";"GIUGNO";""))))))
sax
Utente Junior
 
Post: 93
Iscritto il: 20/05/06 19:34

Sponsor
 

Postdi Alexsandra » 05/06/06 19:16

Ho modificato per l'ennesima volta il post. Si invita a inviare post leggibili senza costringere chi legge a dover scorrere la barra per visualizzarlo integralmente. Si invita a fare un'anteprima prima di inviarlo e quando viene postato del codice deve essere racchiuso entro i tag [ ] (tasto Code)

Spero che venga raccolto questo mio invito in quanto sono stufa di continuare a modificare post per renderli leggibili

http://www.pc-facile.com/forum/viewtopic.php?t=46435

Ringrazio tutti della collaborazione
- Il primo fondamento della sicurezza non e' la tecnologia, ma l'attitudine mentale.

Win7 + Office 2003 Ita
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31

Postdi Anthony47 » 06/06/06 00:14

Ciao Sax,
lascia stare gli If e usa SCEGLI, con la formula
Codice: Seleziona tutto
=SCEGLI(DESTRA(A7;2);"Gennaio";"Febbraio";"Marzo";"Aprile";"Maggio"; ..... )
avendo la pazienza di inserire invece dei .... tutti i mesi dell' anno.

Decidi tu se usare DESTRA(A7;2) o STRINGA.ESTRAI(A7;5;2), dipende se i tuoi numeri sono a 6 cifre (es 200505, usa Destra) o possono averne di piu' (es 20050523, usarea Stringa.estrai).

Ciao,

*** Il codice và racchiuso entro i Tag [ ] usando il tasto code
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi sax » 06/06/06 17:11

Ha Funzionato Perfettamante Grazie

Ho un altro problema e cioe devo utilizzare una funzione che modificando i dati nel foglio1 colonna a1:a26 li modifichi anche nel foglio2 riga a1:z1 ho cercato di usare
Codice: Seleziona tutto
 =SCARTO(Ordine!$G$1;RIF.COLONNA(B2);0)

che hai dato tu in un precedente forum ma non mi funziona o comunque non ho capito come modificarla

*** Formule e tabelle vanno racchiusi entro i Tag [ ] usando il tasto Code o il Quote
sax
Utente Junior
 
Post: 93
Iscritto il: 20/05/06 19:34

Postdi Anthony47 » 06/06/06 19:34

RIF.COLONNA(B2) restituisce 2 (il numero colonna di B); e’ chiaro che Ordine!$G$2 punta in modo assoluto all’ indirizzo G2 del foglio “Ordine”; quindi la formula che hai citato
Codice: Seleziona tutto
=SCARTO(Ordine!$G$1;RIF.COLONNA(B2);0)
và messa nella cella B2 del secondo foglio, e restituisce il valore che si trova nella colonna G riga 1+2, cioe’ cella G3.

se ti serve un ulteriore aiuto non mi neghero’.

Ciao,
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi sax » 07/06/06 12:28

Forse saro un po rintro,ho consultato anche la guida on line ma non ho capito
Ho trovato una altra soluzione ho inserito una riga da D5 in poi dove ho inserito i numeri da 1 a 31
Codice: Seleziona tutto
=SCARTO(Sviluppo!$R$6;D5;0)
per usare la tua formula invece la devo modificare come segue
Codice: Seleziona tutto
=SCARTO(Sviluppo!$R$3;RIF.COLONNA(J9);0)
sax
Utente Junior
 
Post: 93
Iscritto il: 20/05/06 19:34

Postdi Anthony47 » 08/06/06 00:35

Ehi, vedo che adesso padroneggi anche la gestione dell' offset (SCARTO, in Italiano).
L' istruzione e' abbastanza versatile e interessante per la sua capacita' di muovere il riferimento in tutte le direzioni ed eventualmente restituire un range dinamico; ad esempio basta un
Codice: Seleziona tutto
=SOMMA(SCARTO(B2,0,0,1,A2))
per sommare un numero N di celle da B2 verso dx, con N definito in A2 (purche' >0).

Ciao, alla prossima...
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi Alexsandra » 08/06/06 07:27

Ricordo che questo è un forum di assistenza e aiutare coloro che postano i propri problemi ne è lo scopo principale.Pertanto evitiamo di usare "toni" poco "brillanti".

Se Sax ha chiesto chiarimenti vuol dire che non ha risolto il problema.

Edito i toni poco brillanti ed evitiamo commenti, rimaniamo in topic.
- Il primo fondamento della sicurezza non e' la tecnologia, ma l'attitudine mentale.

Win7 + Office 2003 Ita
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31

Postdi Anthony47 » 10/06/06 12:34

:) :D
Anthony
Win7 + Office 2010 Ita; Win 7 + Office 2013 Ita
Xp + Office 2003 Ita
E voi cosa usate? (per istruzioni vedere viewtopic.php?f=26&t=97449)
Avatar utente
Anthony47
Moderatore
 
Post: 13899
Iscritto il: 21/03/06 16:03
Località: Ivrea

Postdi sax » 11/06/06 15:26

:) :D
sax
Utente Junior
 
Post: 93
Iscritto il: 20/05/06 19:34

Postdi Alexsandra » 11/06/06 16:11

:D :D
Ok.
- Il primo fondamento della sicurezza non e' la tecnologia, ma l'attitudine mentale.

Win7 + Office 2003 Ita
Avatar utente
Alexsandra
Utente Senior
 
Post: 2358
Iscritto il: 09/01/06 20:31


Torna a Applicazioni Office Windows


Topic correlati a "[Excel] Istruzioni se nidificate":


Chi c’è in linea

Visitano il forum: albval e 68 ospiti