Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

somma.se valori con zero iniziale

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

somma.se valori con zero iniziale

Postdi ramo » 08/11/22 16:38

Ciao a tutti, ho dei problemi con la formula somma se perché mi somma i valori di due stringhe diverse tra loro solo per lo zero iniziale.
Mi spiego meglio:
Foglio1
A1 = 101000775 B1 = 5
A2 = 0101000775 B2 = 6

Foglio 2
A1 = 101000775 B1 = SOMMA.SE(Foglio1!A:A;A1;Foglio1!B:B) risultato 11
A2 = 0101000775 B2 = SOMMA.SE(Foglio1!A:A;A2;Foglio1!B:B) risultato 11

C'è un modo per fare in modo che excel faccia distinzione tra il valore con lo zero iniziale e quello senza? In entrambi i fogli la colonna A è formattata come testo e ho anche provato a mettere l'apostrofo ma niente. Non trovo una soluzione e ho oltre 5.000 codici per i quali devo confrontare il valore di tre anni diversi quindi è impensabile farlo a mano :cry:
Grazie mille!
ramo
Newbie
 
Post: 2
Iscritto il: 08/11/22 15:54

Sponsor
 

Re: somma.se valori con zero iniziale

Postdi Anthony47 » 08/11/22 19:41

Intanto Benvenuto nel forum
Si, trovo sconveniente che la funzione, pur avendo qualificato i due dati come stringhe, si incaponisca a considerare uguali 101000775 e 0101000775

Usa allora Matr.Somma.Prodotti:
Codice: Seleziona tutto
=MATR.SOMMA.PRODOTTO(--(Foglio1!$A$1:$A$10000=A1);Foglio1!$B$1:$B$10000)


I dati vanno inseriti come Stringhe; quindi o formatti come testo l'area Foglio1-Colonna A prima di inserirvi i dati, oppure devi avere l'accortezza di usare l'Apostrofo prima di introdurre valori numerici.
Analoga accortezza su Foglio2, dove inserirai i valori da usare come filtro

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18601
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: somma.se valori con zero iniziale

Postdi ramo » 09/11/22 10:47

Ciao Anthony, ti ringrazio, mi hai salvata!
ramo
Newbie
 
Post: 2
Iscritto il: 08/11/22 15:54


Torna a Applicazioni Office Windows


Topic correlati a "somma.se valori con zero iniziale":


Chi c’è in linea

Visitano il forum: Nessuno e 14 ospiti