Valutazione 4.87/ 5 (100.00%) 5838 voti

Condividi:        

Dato un elenco ottenere tutte le voci escludendo i ripetuti

Vuoi potenziare i tuoi documenti Word? Non sai come si fa una macro in Excel? Devi creare una presentazione in PowerPoint?
Oppure sei passato a OpenOffice e non sei sicuro di come lavorare al meglio?

Moderatori: Anthony47, Flash30005

Dato un elenco ottenere tutte le voci escludendo i ripetuti

Postdi ricky53 » 13/10/22 01:00

Ciao,
eccomi quindi per chiedere una soluzione diversa da quella che ho applicato io perchè la devo proporre ad un ragazzo delle superiori che non ha conoscenze spinte di excel. Quindi utilizzando solo funzioni e formule matematiche semplici

Questo è il caso:
ho un elenco in colonna "A", a partire dalla riga 2.
Questo elenco contiene tanti codici articolo, molti di essi sono ripetuti diverse volte.

Io vorrei ottenere:
1. in colonna "E" a partire da una qualunque riga (ipotizziamo la riga 25), tutti i codici articolo presenti nella colonna "A" riportando una sola volta i codici articolo ripetuti.

2. nella colonna "F" quante volte l'articolo si ripete nella colonna "A". (questo dato può essere calcolato anche con il "CONTA.SE", questa funzione la conosce). Se avete un'altra soluzione sarà ben accetta


La soluzione che ho utilizzato io è:
una semplicissima tabella pivot solo sulla colonna "A" che mi ha dato l'elenco senza i valori ripetuti ed il conteggio degli articoli presenti in colonna "A", poi ho copiato questi risultati nelle colonne in cui i dati mi servivano. Ed il gioco è fatto.

Grazie ragazzi
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W10; Office 2003-10-13-16-19
Avatar utente
ricky53
Utente Senior
 
Post: 4559
Iscritto il: 11/04/09 19:29
Località: Italia

Sponsor
 

Re: Dato un elenco ottenere tutte le voci escludendo i ripet

Postdi Anthony47 » 13/10/22 08:56

Se disponibile nella versione Excel in uso, si puo' usare UNICI; es, in E2:
Codice: Seleziona tutto
=UNICI(A25:A200)


Oppure, ad esempio sempre in E2:
Codice: Seleziona tutto
=SE.ERRORE(INDICE($A$25:$A$200;CONFRONTA(0;CONTA.SE($E$1:E1;$A$25:$A$200);0));"")
Da confermare con Contr-Maiusc-Enter, non il solo Enter, e poi copiare verso il basso

Per la conta delle occorrenze non mi viene in mente niente piu' semplice che il Conta.Se

Ciao
Avatar utente
Anthony47
Moderatore
 
Post: 18602
Iscritto il: 21/03/06 16:03
Località: Ivrea

Re: Dato un elenco ottenere tutte le voci escludendo i ripet

Postdi ricky53 » 17/10/22 01:57

Ciao,
grazie per la tempestiva risposta.

UNICI su excel 2019 non c'è
La seconda è troppo complessa per lui.

grazie per il tentativo.
per il momento andiamo avanti con la pivot.
Dice il vecchio saggio provare e riprovare è l'unica strada per imparare

Più chiara è la vostra spiegazione
Più immediata sarà la nostra soluzione


. . . . . . . . . .
S.O. W10; Office 2003-10-13-16-19
Avatar utente
ricky53
Utente Senior
 
Post: 4559
Iscritto il: 11/04/09 19:29
Località: Italia


Torna a Applicazioni Office Windows


Topic correlati a "Dato un elenco ottenere tutte le voci escludendo i ripetuti":


Chi c’è in linea

Visitano il forum: Nessuno e 32 ospiti

cron